Closed Bug 292411 Opened 19 years ago Closed 19 years ago

View Saved Passwords list is blank with animateFadeIn set to true

Categories

(Firefox :: Settings UI, defect)

defect
Not set
major

Tracking

()

RESOLVED FIXED
Firefox1.5

People

(Reporter: ttolonen, Assigned: mossop)

References

Details

(Keywords: regression)

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050427 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050427 Firefox/1.0+

This works correctly in 20050427. Broken in 20050428.

Reproducible: Always

Steps to Reproduce:
1. Set animateFadeIn to true in about:config
2. Open View Saved Passwords (Options>Privacy>Passwords>View Saved Passwords)

Actual Results:  
Saved Passwords window opens without content

Expected Results:  
See saved passwords
i confirm.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050429
Firefox/1.0+
Could this be caused by the fix for Thunderbird bug 292009?
Confirming with 20050429, windows xp.
Severity: minor → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true
I assume animateFadeIn is going to be on by default for 1.1 ?
->?1.1
->regression
Flags: blocking-aviary1.1?
Keywords: regression
Empty password manager.

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050430
Firefox/1.0+  (phiw13)
Severity: normal → major
OS: Windows XP → All
Hardware: PC → All
Attached patch potential patchSplinter Review
This is fallout from Bug 284081. For some reason the password manager window is
opened with the argument "8". I can find nothing in the password manager that
references it so this patch stops passing an argument. There could be fallout
though since I don't know what the "8" was for in the first place.
Comment on attachment 182255 [details] [diff] [review]
potential patch

This is correct indeed. The "8" parameter was introduced by bryner's checkin
from 2003-08-11 22:22 "Enable new password manager for Firebird."
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/browser/components/prefwind
ow/content/pref-privacy.js&rev=1.7&mark=281-284#281

It was "S" before:
http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&r
oot=/cvsroot&subdir=mozilla/browser/components/prefwindow/content/Attic&command
=DIFF_FRAMESET&file=pref-privacy.js&rev2=1.7&rev1=1.6
SignOnViewer uses that to "differentiate between password manager and form
manager":
http://lxr.mozilla.org/seamonkey/source/extensions/wallet/signonviewer/resource
s/content/SignonViewer.js#68

The form manager was the first thing bryner ripped out, so we don't the "8"
argument either. There is no window.arguments anywhere in
http://lxr.mozilla.org/seamonkey/source/toolkit/components/passwordmgr/resource
s/content/passwordManager.js.
Attachment #182255 - Flags: review?(bryner)
Comment on attachment 182255 [details] [diff] [review]
potential patch

low-risk regression fix
Attachment #182255 - Flags: review?(bryner)
Attachment #182255 - Flags: review+
Attachment #182255 - Flags: approval-aviary1.1a?
*** Bug 292483 has been marked as a duplicate of this bug. ***
Comment on attachment 182255 [details] [diff] [review]
potential patch

a=asa
Attachment #182255 - Flags: approval-aviary1.1a? → approval-aviary1.1a+
Assignee: nobody → dave.townsend
Checking in mozilla/browser/components/preferences/privacy.js;
/cvsroot/mozilla/browser/components/preferences/privacy.js,v  <--  privacy.js
new revision: 1.7; previous revision: 1.6
done
Status: NEW → RESOLVED
Closed: 19 years ago
Flags: blocking-aviary1.1?
Resolution: --- → FIXED
Target Milestone: --- → Firefox1.1
You need to log in before you can comment on or make changes to this bug.