Release mouse button on scroll bar -> page won't stop scrolling

RESOLVED WORKSFORME

Status

()

Core
Selection
P3
normal
RESOLVED WORKSFORME
19 years ago
10 years ago

People

(Reporter: Eli Goldberg, Unassigned)

Tracking

({helpwanted})

Trunk
helpwanted
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
* TITLE/SUMMARY
Release mouse button on scroll bar -> page won't drop scrolling

* STEPS TO REPRODUCE
0) Launch Apprunner
1) View a web page tall enough to not fit within a browser window (or shorten
the browser window to require scrolling)
2) Drag-select the page content:
	- starting from any point within the content
	- down to anywhere below the horizontal scroll bar at the bottom of the window
	- quickly move the mouse pointer back up to the horizontal scroll bar region
	- release the mouse button.

* RESULT
 - What happened

The page will continue to scroll, even though the mouse button isn't depressed.
If you move the mouse pointer around (as mjudge notes), you'll still see a
selection --- it looks like the mouseUp event didn't get passed.

 - What was expected

Scrolling should stop upon mouse button release. Afterwards, moving mouse
pointer around content area shouldn't result in further changes to selection.

* REGRESSION

 - Occurs On
        Mac OS Apprunner (2.25.00 AM optimized build)		
        Win32 Apprunner (2.25.00 AM optimized build [NT 4, Service Pack 5])
        Linux Apprunner (2.25.00 AM optimized build)		

* CONFIGURATIONS TESTED

- [Mac] Beige Power Mac G3 (266 MHz PowerPC 750), 96 MB RAM (VM on; 1 MB of VM
used), 1024x768 (Thousands of Colors), Mac OS 8.6

- [Win32] Vectra VL (233 MHz P2), 96 MB RAM, 800x600 (True Color), NT 4.0 SP5.

- [Linux] Vectra VL (266 MHz P2), 96 MB RAM. Red Hat Linux 6.0 (GNOME).
(Reporter)

Comment 1

19 years ago
CC:ing Mr. Event Handling.

Comment 2

19 years ago
set to M15 for further triage
Target Milestone: M15
(Reporter)

Comment 3

19 years ago
Per brade's request, it's still an issue on 3.5.00 AM Mac OS build.
(Reporter)

Updated

19 years ago
Summary: Release mouse button on scroll bar -> page won't drop scrolling → Release mouse button on scroll bar -> page won't stop scrolling

Comment 4

19 years ago
moving to M17
Target Milestone: M15 → M17

Comment 5

19 years ago
I'm not sure exactly which bug needs to be fixed before we can even attempt to 
reproduce this bug (drag scrolling hasn't been working).  I'm marking 34020 but 
it may be 30609 or another bug.
Depends on: 34020

Updated

18 years ago
Blocks: 36868

Comment 6

18 years ago
I can't reproduce this anymore on Linux build 2000072508.  The scrolling stops
immediately, or a few seconds after releasing the mouse button over the
horizontal scrollbar.  Can anyone reproduce this on Win or Mac?

Comment 7

18 years ago
I think this may be Mac only. brade can you test drag selecting and releasing 
mouse at wierd times?  maybe elig can help also? I am reassigning to kathy. 
bounce it back to me once you can reproduce this.  My Mac is dead.
Assignee: mjudge → brade
Target Milestone: M17 → ---
I can reproduce this on NT, build 2000072508.
(Reporter)

Comment 9

18 years ago
...you can always use mine, mjudge!

Comment 10

18 years ago
we were not able to reproduce on winNT using the build from yesterday. I cannot 
reproduce on a win98 build either
Target Milestone: --- → M19
I can reproduce this on Linux as well. It isn't simply that you select/drag over
any content. Here is how I can reproduce this:

1. Open this bug page.
2. Select/drag starting from the word Summary.
3. Bring the cursor down over the scrollbar.
4. Scroll until you are over the Additional Comments edit box.
5. Release the button.

The page continues to scroll. On Linux this happens much slower than on Windows,
but I can reproduce this always.

Comment 12

18 years ago
reassign this back to mudge; apparently not a mac-specific bug
Assignee: brade → mjudge

Comment 13

18 years ago
marking as worksforme, I am still unable to reproduce this problem on win32, 
linux or mac builds from today

Eli, can you please check this out and if you can reproduce this, please show me
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
I just pulled and built on Linux. I can reproduce this every time with the steps
I described above. Reopening.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 15

18 years ago
*SPAM*: Changing the QA contact of all open/resolved Selection bugs from 
elig@netscape.com to BlakeR1234@aol.com.  After the many great years of service 
Eli has given to Mozilla, it's time for him to move on; he has accepted a 
position at Eazel.  We'll be sad to see him go, and I'll do my best to fill his 
spot...
QA Contact: elig → BlakeR1234

Comment 16

18 years ago
moving to future
Target Milestone: M19 → Future

Updated

18 years ago
Blocks: 67277

Comment 17

17 years ago
why do people not like my hidden autoscroll feature. you can scroll as fast or 
slow as you like without touching the mouse. i am marking this wont fix. ;) 
actually i think its a focus issue with the TEXTAREAs sucking up the mouse 
events even though the outer page captured the mouse. 
Status: REOPENED → ASSIGNED

Comment 18

17 years ago
The same thing happened to me, although it seemed like I pressed a strange
combination of buttons, then when the mouse was out of the range of the
scrollbar, it would scroll as if I were clicking on the bar, up and down with
the mouse.

That was a quick fix, though, just clicking around.  But now my right-click
button is disabled and so is MouseImp, in all other programs.  Everything else
(scroll wheel, etc) are still working ok.

I'm using 0.9.8 on Win2k. 

Comment 19

17 years ago
*** Bug 124630 has been marked as a duplicate of this bug. ***
Keywords: helpwanted

Comment 20

17 years ago
changing selection qa to tpreston.
QA Contact: blaker → tpreston

Comment 21

16 years ago
*** Bug 145354 has been marked as a duplicate of this bug. ***

Comment 22

16 years ago
I'm seeing this in Mozilla 1.1 Beta (Build ID: 2002072203) on MacOS X, I don't
think it was in 1.1 Alpha...

Comment 23

16 years ago
same as bug 157123 ?

Comment 24

16 years ago
Can still reproduce this using using FizzillaCFM/2002080508, but with slightly
different steps.

1. Access []
2. Quickly click+drag select in the content area, and move the mouse down so
that the cursor is on the Status Bar or even below the window entirely
3. Release the mouse

Notice Mozilla keeps scrolling. It's as though Mozilla missed the mouse up; if
you move the mouse cursor back up into the content area, you'll see scrolling
stop and the selection area decreasing.

Same bug, or different?

Comment 25

16 years ago
Not sure if this is related bug or same. I'm not using Apprunner, just simple
Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2b) Gecko/20021016
Mozilla
Under Mac OS X, on a page that needs to be scrolled, if I click in the
down-arrow widget at the end of the scrollbar, Mozilla frequently continues to
scroll after I let up on the mouse button. A singe click/release on the arrow
key (up or down) should move the page some "known"fraction of the distance and
then stop.

Similarly, clicking once in the scroll bar region itself moves the thumb toward
the point of clicking, and the thumb (often) then continues to move and move.

Clicking anywhere in the body of the browser screen (not in the scroll widgets)
will frequently stop the scrolling (often too far past the desired region, so
the game must begin anew)

Comment 26

16 years ago
Don't know if this will help (can always hope  ;), but I have had this "sticky
scrollbar" issue after the following sequence of events:

- Browser is in use
- Scrollbar is selected via the mouse, currently depressed (oh, poor thing  lol)
- another program takes the focus(*)
- scrollbar state remains as if selected, a click will return it to correct state.

(*) in my case, it is usually a DOS box, as I have a program scheduled to run
every 20 seconds to rid me of a certain nag window, it's supposed to run w/o
focus but that never works - have had this same issue with other win32 apps as
well though, not particular to newly spawning DOS sessions

NB: sorry for the "fluff-talk", I work in a school doing IT Support and the
habit of using "technical" terms makes people feel less stupid when they've been
on the frustrating end of a simple, simple problem.  :)

http://bugzilla.mozilla.org/show_bug.cgi?id=48037

Propose this bug be marked as a duplicate of 48037.

Comment 27

16 years ago
I've only noticed this problem in the Modern Theme only. Both in Mozzila (all)and
Netscape 7. Running OS 10.2.2 on iMac 400SE 512ram, iBook 600 640ram, B/W 400
512ram, Beige 266 768ram and on a G4 iMac 512ram running 10.1.5.

Comment 28

16 years ago
Don't know if this is related or a feature. If you click on an arrow to scroll,
the arrow is highlighted. If you move the pointer far enough away (while still
pressed), the scrolling stops and the arrow is no longer highlighted. When the
pointer is moved back over the arrow (mouse button still held down), the arrow
is highlighted, but scrolling does not continue.

I've noticed in other apps that scrolling does continue.

Comment 29

15 years ago
Created attachment 128207 [details]
related test case

I can reproduce this bug on today's Windows trunk build using Heikki's steps
(comment 11) but not necessarily the original steps. It's easier to let the
mouse up over the textarea if you scroll slowly by placing the mouse just
barely past the bottom of the content area.

I'm attaching another testcase I just made up. I think this is the same bug.
This version shows up when autoscrolling a scrollable textarea and the
scrollable content area containing it. The content area stops responding to the
mouse, and continues scrolling until it hits the bottom (and presumably doesn't
stop then).

This really does seem like a focus/capture problem (comment 17). And this bug
doesn't appear to me to be related to either of the candidate duplicate bugs,
bug 48037 and bug 157123.

Comment 30

15 years ago
I am getting unstoppable scrolling on Linux Moz 1.4. (Debian Sarge) I thought
this was fixed. Is it back?

Comment 31

13 years ago
WFM - I cant recreate this using steps in comment 0 (suite/seamonkey and FF 1.5)

Nor can I create the problem with Dan M's testcase comment 29.

Heikki, Greg, etc can anyone confirm?
Assignee: mjudge → selection
Status: ASSIGNED → NEW
QA Contact: tpreston

Comment 32

13 years ago
It's been ages since I've seen this one, too, and can't reproduce using #0 or #11 instructions.

Comment 33

13 years ago
closing WFM.
Status: NEW → RESOLVED
Last Resolved: 18 years ago13 years ago
Resolution: --- → WORKSFORME

Comment 34

13 years ago
reopening (momentarily?)
I can reproduce the steps in comment 24:
  click in the content area of this bug and drag downward
  release mouse button outside of content area (outside the window)
  Result:  scrolling continues until the bottom is reached

Is this now covered in a different bug?
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
This sounds a lot like bug 157123 and bug 301399. (Or rather, they sound like this.)

Comment 36

13 years ago
(In reply to comment #34)
> reopening (momentarily?)
> I can reproduce the steps in comment 24:
>   click in the content area of this bug and drag downward
>   release mouse button outside of content area (outside the window)
>   Result:  scrolling continues until the bottom is reached

brad, what platform and build (mac?)?  

I should have said I am windows. Perhaps Jeffrey Baker is also?


(In reply to comment #35)
> This sounds a lot like bug 157123 and bug 301399. (Or rather, they sound like
> this.)

Those are at least dups of each other. If this is determined to be mac-only then someone can pick one to get the dups.

Comment 37

13 years ago
Neither bug 157123 nor bug 301399 sounds correct to me.
Bug 157123 has to do with clicking in the arrows, not the content area.
Bug 301399 sounds like the mouse button is released in the content area.

I'm going to go with bug 119415.

Re-Resolving as worksforme.
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME
QA Contact: selection
Target Milestone: Future → ---
You need to log in before you can comment on or make changes to this bug.