When fastback is enabled and back button (or keyboard) is used, visited links are not marked as visited

RESOLVED FIXED in mozilla1.8beta4

Status

()

RESOLVED FIXED
14 years ago
10 years ago

People

(Reporter: phiw2, Assigned: bryner)

Tracking

({regression})

Trunk
mozilla1.8beta4
regression
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.8b3 -
blocking1.8b5 +
blocking-aviary1.5 +
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050507 Firefox/1.0+  (phiw13)
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050507 Firefox/1.0+  (phiw13)

Since the landing of bug 274784, when using the backbutton, a link that just has
been visited is not marked/displayed as visited.
Visit the test page, follow the link, and use the backbutton to come back. The
link will have still be focussed (a:focus); that is OK. Once it loses the focus
(clicking anywhere to shift the focus, it will still be blue (a:link), whereas I
expect it to be green (a:visited).
[Reloading the page, and the link will turn green.]

Sidenote - Opera 8beta for OS X turns the link green. Right now, I've no access
to a windows box to test Opera 8 win.

Reproducible: Always

Steps to Reproduce:
1.load test case
2.follow link (the top one is OK).
3.use backbutton or keyboard to step back to first page

Actual Results:  
the link has still focus (OK), once deselected, it displays as blue (the color
assigned to a:link).

Expected Results:  
Display the link as green (the color assigned by a:visited).

Both official nightly and my own build. New profile, empty cache for testing
purposes.
(Reporter)

Comment 1

14 years ago
Forgot to add: browser.sessionhistory.max_viewers is set to 5.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050506
Firefox/1.0+
I see this too, when bfcache is enabled.
Blocks: 274784
Status: UNCONFIRMED → NEW
Ever confirmed: true
Severity: major → normal
Summary: [regression] when using the back button (or keyboard), visited links are not marked as visited → when using the back button (or keyboard), visited links are not marked as visited

Comment 4

14 years ago
(In reply to comment #3)
> bug 78510 would probably fix this

Should this be marked as a dependency one way or the other?

Updated

14 years ago
Flags: blocking-aviary1.1?

Comment 5

14 years ago
This is only for workaround. Mark link visited as link is middle-clicked.

This patch has same problem as middle-clicking link; a link which actually
clicked is only marked as visited, other links which have same URI are still
shown as unvisited.

Comment 6

14 years ago
Also, just wondering, but if the same link is in other places on the same page,
those are not marked either, just the original. Thanks.

Comment 7

14 years ago
(In reply to comment #6)
> Also, just wondering, but if the same link is in other places on the same page,
> those are not marked either, just the original. Thanks.

I believe that's bug 78510.

Updated

14 years ago
Depends on: 78510
(Assignee)

Comment 8

14 years ago
This doesn't depend on 78510.  We can reresolve style on links when restoring a
page.
No longer depends on: 78510
(Assignee)

Updated

14 years ago
Blocks: 298293
(Assignee)

Updated

14 years ago
No longer blocks: 298293

Updated

14 years ago
Flags: blocking1.8b3?

Updated

14 years ago
Flags: blocking1.8b4+
Flags: blocking1.8b3?
Flags: blocking1.8b3-
Flags: blocking-aviary1.1?
Flags: blocking-aviary1.1+
Keywords: regression

Comment 9

14 years ago
At this risk of this being considered bugspam, is there anyway this can be fixed
for 1.8b3?  I realize the blocking flag has been minused, so will not nominate
again, but this does appear to be probably the single issue that are large
number of people have an issue with in the daily use of "blazingfastback".  

Assuming this cannont be fixed for 1.8b3, I think clearly documenting the issue
in release notes (for the 5% of people that read them) would be good
*** Bug 299869 has been marked as a duplicate of this bug. ***
*** Bug 301001 has been marked as a duplicate of this bug. ***
Summary: when using the back button (or keyboard), visited links are not marked as visited → When fastback is enabled and back button (or keyboard) is used, visited links are not marked as visited
(Assignee)

Comment 12

14 years ago
Targetting to match blocking status (and get off the
untargetted-fastback-dependencies list).
Target Milestone: --- → mozilla1.8beta4
*** Bug 302154 has been marked as a duplicate of this bug. ***

Comment 14

14 years ago
bryner, can you fix it the "right way" in the next week?  or should we take the
workaround?

/cb
Assignee: nobody → bryner

Comment 15

14 years ago
*** Bug 302431 has been marked as a duplicate of this bug. ***
*** Bug 303131 has been marked as a duplicate of this bug. ***

Comment 17

14 years ago
(In reply to comment #16)
> *** Bug 303131 has been marked as a duplicate of this bug. ***

Can someone mark this as fixed,
https://bugzilla.mozilla.org/show_bug.cgi?id=78510 has just been checked in and
fixes this bug

Updated

14 years ago
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Updated

11 years ago
Component: History: Session → Document Navigation
QA Contact: history.session → docshell
Attachment #387544 - Flags: review?(bzbarsky)
Comment on attachment 387544 [details] [diff] [review]
mochitest test case

Nice.
Attachment #387544 - Flags: review?(bzbarsky) → review+
You need to log in before you can comment on or make changes to this bug.