[FIXr]bookmarks toolbar missing in 2nd opened window, links in second window possibly cause crash

VERIFIED FIXED in mozilla1.8beta2

Status

()

P1
major
VERIFIED FIXED
14 years ago
14 years ago

People

(Reporter: Peter6, Assigned: bzbarsky)

Tracking

({fixed-aviary1.0.5, fixed1.7.9, regression})

Trunk
mozilla1.8beta2
fixed-aviary1.0.5, fixed1.7.9, regression
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.8b2 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050511
Firefox/1.0+ ID:2005051108

required, have Adblock 0.5.2+ installed

repro:
1.open FF and make sure the bookmarks toolbar is shown and contains bookmarks
2.open a second window and notice the bookmarks toolbar is empty
3.no errors in javascript console

this regressed between the:
20050510 11:08pdt (works) and 22:51pdt (fails) builds

checkins:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=PhoenixTinderbox&branch=HEAD&branchtype=match&filetype=match&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2005-05-10+10%3A29%3A00&maxdate=2005-05-10+22%3A12%3A00&cvsroot=%2Fcvsroot
(Reporter)

Comment 1

14 years ago
CC Bzbarsky 
could this have anything to do with Bug 292589 ?
(Assignee)

Comment 2

14 years ago
Possible, I suppose...  Really not sure why, though; where does adblock try to
load XBL from?
Flags: blocking-aviary1.0.4?
(Assignee)

Updated

14 years ago
Blocks: 292589
(Reporter)

Comment 3

14 years ago
(In reply to comment #2)
> Possible, I suppose...  Really not sure why, though; where does adblock try to
> load XBL from?

I don't know
also probably related:
if I press [reply] on bugzilla FF crashes
->TB5749989Z
i send TB5738996X this morning, probably same issue

i have the same problem on 2 other computers

(Assignee)

Comment 4

14 years ago
More interestingly, what does adblock block?  Could it be blocking chrome XBL or
something like that?
(Assignee)

Comment 5

14 years ago
Do we know the bugmail addresses for any adblock developers?  As far as I can
tell from their code they aren't blocking any chrome:// URIs or anything of type
OTHER, but I just want to make sure...
(Reporter)

Comment 6

14 years ago
(In reply to comment #5)
> Do we know the bugmail addresses for any adblock developers?  As far as I can
> tell from their code they aren't blocking any chrome:// URIs or anything of type
> OTHER, but I just want to make sure...
I disabled Adblock, but that does NOT help.
Only uninstalling solves both issues.

my filters (for what it is worth):
"*/ad.fidion.de/* 
*/ad/* 
*/ads* 
*/banner/* 
*/banners/* 
*adserver* 
*doubleclick.net* 
*eu.falkag* 
*fastclick* 
*paycounter* 
*specificclick* 
*valueclick* 
http://a372.g.a.yimg.com/* 
http://ad.fidion.de/oasisi-j.php?s=12&h=60&w=137
http://adblock.mozdev.org/settings.rf1.png 
http://extremetracking.com/t_s.gif http://forums.mozillazine.org/image/donate.png
http://free.grisoft.com/v5/css/marquee.js
http://home.kabelfoon.nl/~casaga/hetweer4.gif
http://home.kabelfoon.nl/~casaga/janvisser_r10.jpg
http://home.kabelfoon.nl/~casaga/logo.gif
http://home.kabelfoon.nl/~casaga/mediatv.jpg
http://home.kabelfoon.nl/~casaga/weerpagina.bmp
http://img.webring.com/r/d/davisvantageprow/navbarlogo
http://pagead2.googlesyndication.com/
http://pryan.org/mozilla/forums/images/smiles/*
http://pryan.org/mozilla/forums/templates/subSilver/images/logo_phpBB.gif
http://static.mozillazine.org/common/images/donate.png
http://store.mozillazine.org/forum_box/ http://us.geocities.com/js_source/div.js 
http://www.nos.nl/gfx/global/reclame/*
http://www.nos.nl/gfx/teletekst/TT_etalage.swf
http://www.on4kst.com/chat/new1.gif
http://www.mozilla.org/images/mozilla-banner.gif");

Comment 7

14 years ago
To add to this, you do not have to uninstall AdBlock. You can disable the
extension itself (instead of merely disabling AdBlock through its control panel)
and then restart Firefox. That method also fixes this issue... so it does indeed
appear to be an AdBlock related problem somehow.
(Reporter)

Comment 8

14 years ago
filed bug 293787 for the crash of comment #3

Comment 9

14 years ago
I'm gonna raise this to critical because, for me at least, on Windows and Mac
builds, when clicking on ANY link from the 2nd window (the window missing the
bookmarks bar), the browser crashes.

Again, disabling AdBlock via the extensions menu fixes this.
Severity: major → critical
Summary: bookmarks toolbar missing in 2nd opened window → bookmarks toolbar missing in 2nd opened window, links in second window cause crash
(Assignee)

Comment 10

14 years ago
Frankly, I have no idea what it is adblock is doing to not play nice here...  We
really need to get in touch with the adblock developers; again, does anyone know
how we can contact them?
Keywords: helpwanted
From http://aasted.org/adblock/viewtopic.php?t=3

It might be worth trying the following address:

henrik@aasted.org
Severity: critical → major

Comment 12

14 years ago
Modifying slightly since I've found some pages where it doesn't crash in the
second window when links are clicked. However, one that is CONSTANTLY
reproduceable is the forum page for the makers of SecureCRT. 

1) Go to the Vandyke homepage at www.vandyke.com.
2) Click the link for Vandyke Forums at the bottom left of the page. This will
open the page "http://forums.vandyke.com/index.php" in a second window.
3) Click on any link on this to enter one of the forums. Firefox will crash
immediately.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050511
Firefox/1.0+

As for the AdBlock devs, they have a page on mozdev.org, I've submitted a new
topic on their development forums. The post is located here:

http://adblock.mozdev.org/forum.html/no_wrap (can't find a way to link directly
to the post, so the topic title is: "AdBlock causing display bug on Firefox
nightly 05/11/05")

Hope this helps.

Updated

14 years ago
Summary: bookmarks toolbar missing in 2nd opened window, links in second window cause crash → bookmarks toolbar missing in 2nd opened window, links in second window possibly cause crash

Comment 13

14 years ago
Tim: For extensions like Adblock that do dynamic run-time XPCOM registration,
disabling through the Extension Manager is functionally equivalent to
uninstalling the extension, in the sense that (after a restart) none of the
extension's chrome (and, thus, code) is actually loaded.

bz: 
I'm 0.5 doesn't block anything, including chrome://*, by default. Because this
bug "works" even when Adblock is disabled, the buggy code is either (a) very
early in our shouldLoad() method, or outside the method entirely -- e.g. not
something being blocked as part of the nsIContentPolicy chain.

Can't comment on bug 292589 since I don't have security-viewing bits.

Almost exactly a year ago, there were somewhat similar problems when the
nsIContentPolicy interface changed and all calls to ::ShouldLoad() were being
dropped... except that fubared the whole browser, preventing any links (and most
chrome) from loading at all.

I'll look into this and see what's going on.

Updated

14 years ago
Assignee: nobody → henrik
(Assignee)

Comment 14

14 years ago
Ben, all bug 292589 did was make XBL binding loads do a content policy check. 
See
http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&file=nsXBLService.cpp&branch=&root=/cvsroot&subdir=mozilla/content/xbl/src&command=DIFF_FRAMESET&rev1=1.200&rev2=1.201
-- that's the full change for that bug...

I agree that there's nothing in the adblock code that should obviously cause
problems here, except perhaps if shouldLoad throws because it gets input it
doesn't expect.  If it does, that could cause issues, I would wager.

Note that this is the only code in the tree that calls ShouldLoad with
TYPE_OTHER as the type.  That should be OK, since blockTypes[contentType] will
just be undefined, and !undefined is true...
(Assignee)

Comment 15

14 years ago
And Tim, the bug on the crash is bug 293787, so I'm not sure why you raised the
severity on this one...
Depends on: 293787

Comment 16

14 years ago
Boris, apologies. I hadn't seen Peter's other bug at the time when I raised the
severity. That one does indeed seem to be the issue I'm experiencing. I was
going to downgrade the severity back to major when I added "possibly" to the
subject line, but it seemed someone (I'm guessing you) already had. Overzealous
I suppose.
I see this only with a new profile. And only if the bookmarks toolbar is on the
default location. With my bookmarks on the same bar as the menus I don't see this.
I see also that the Customize window in the second window is empty.

But I have none of these problems with my normal profile.
*** Bug 293910 has been marked as a duplicate of this bug. ***
(In reply to comment #12)
> As for the AdBlock devs, they have a page on mozdev.org, I've submitted a new
> topic on their development forums. The post is located here:
> 
> http://adblock.mozdev.org/forum.html/no_wrap (can't find a way to link directly
> to the post, so the topic title is: "AdBlock causing display bug on Firefox
> nightly 05/11/05")

Tim, you have to go to the main index then grab the link location from the
hyperlink pointing to your thread which is:
http://aasted.org/adblock/viewtopic.php?p=10559#10559

I don't know why Adblock's stubborn ass won't fix the forum's individual thread
view to correctly thread back the correct URL to the Address box. But then
again, they don't fix a lot of things...

FTCI (For the curiously inquisitive): Yes, that's my reply on that thread.
(Assignee)

Comment 20

14 years ago
OK, I know what's going on here... what a bloody mess.  :(
Assignee: henrik → general
Blocks: 293787
Component: Bookmarks → XBL
No longer depends on: 293787
OS: Windows 2000 → All
Priority: -- → P1
Product: Firefox → Core
QA Contact: bookmarks → ian
Hardware: PC → All
Summary: bookmarks toolbar missing in 2nd opened window, links in second window possibly cause crash → [FIX]bookmarks toolbar missing in 2nd opened window, links in second window possibly cause crash
(Assignee)

Updated

14 years ago
Assignee: general → bzbarsky
Flags: blocking1.8b2?
Flags: blocking-aviary1.0.5?
Flags: blocking-aviary1.0.4?
Keywords: helpwanted
Target Milestone: --- → mozilla1.8beta2
(Assignee)

Comment 21

14 years ago
Created attachment 183470 [details] [diff] [review]
Fix

jst, the long comment should pretty much explain what's going on.  I went for
this instead of trying to make LoadBindings deal with being reentered because
it just seemed much more straightforward and because even if I _did_ deal with
the binding thing here we'd still be handing out a partly-constructed wrapper
(since the second call to content policy finds the not-quite-PostCreated
wrapper in the relevant XPConnect hashtable).
(Assignee)

Updated

14 years ago
Attachment #183470 - Flags: superreview?(jst)
Attachment #183470 - Flags: review?(jst)

Updated

14 years ago
Flags: blocking1.8b3?
Flags: blocking1.8b2?
Flags: blocking1.8b2-
Flags: blocking1.8b2- → blocking1.8b2+
Comment on attachment 183470 [details] [diff] [review]
Fix

r+sr=jst
Attachment #183470 - Flags: superreview?(jst)
Attachment #183470 - Flags: superreview+
Attachment #183470 - Flags: review?(jst)
Attachment #183470 - Flags: review+
(Assignee)

Comment 23

14 years ago
Comment on attachment 183470 [details] [diff] [review]
Fix

Requesting approval on regression fix... should be pretty safe.  We need this
on branches too.
Attachment #183470 - Flags: approval1.8b2?
Attachment #183470 - Flags: approval1.7.9?
Attachment #183470 - Flags: approval-aviary1.0.5?
(Assignee)

Updated

14 years ago
Summary: [FIX]bookmarks toolbar missing in 2nd opened window, links in second window possibly cause crash → [FIXr]bookmarks toolbar missing in 2nd opened window, links in second window possibly cause crash
Comment on attachment 183470 [details] [diff] [review]
Fix

a=shaver for everywhere with the regression.
Attachment #183470 - Flags: approval1.8b2?
Attachment #183470 - Flags: approval1.8b2+
Attachment #183470 - Flags: approval1.7.9?
Attachment #183470 - Flags: approval1.7.9+
Attachment #183470 - Flags: approval-aviary1.0.5?
Attachment #183470 - Flags: approval-aviary1.0.5+
(Assignee)

Comment 25

14 years ago
Fixed trunk and both branches.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Flags: blocking-aviary1.0.5?
Keywords: fixed-aviary1.0.5, fixed1.7.9
Resolution: --- → FIXED
*** Bug 295822 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Flags: blocking1.8b3?
verified fixed using 200506170x-1.0.5 firefox builds on linux fc3 and mac os x
10.4.1. I've got Adblock installed and have various bookmarks in my bm toolbar:
opening another browser window displays the bm toolbar content fine.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.