Closed Bug 29475 Opened 20 years ago Closed 20 years ago

Download of unknown file type (ftp, http) causes crash

Categories

(SeaMonkey :: UI Design, defect, P3, blocker)

x86
Windows 98
defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 29360

People

(Reporter: aarons, Assigned: don)

References

()

Details

(Keywords: crash, regression)

on release feb 27 2000 -16 and release 08
Attempting to download the latest build will cause the following error

MOZILLA caused an invalid page fault in
module GKHTML.DLL at 017f:60265f27.
Registers:
EAX=00000000 CS=017f EIP=60265f27 EFLGS=00010202
EBX=012d1e40 SS=0187 ESP=0068f05c EBP=0068f198
ECX=0068f1a0 DS=0187 ESI=0068f1c0 FS=13df
EDX=0068f1a0 ES=0187 EDI=00000001 GS=0000
Bytes at CS:EIP:
8b 08 ff 91 94 00 00 00 f6 45 09 14 75 06 83 65 
Stack dump:
00000000 0068f1a0 01827920 0068f824 40000000 01828910 00000000 ffffff2e 
012d2290 00000001 6019ee18 6019ee81 012d2de8 00000000 0068f0a4 009a3930 

To reproduce from the mozilla page click more then click download latest build, 
then select the file ( i selected the win32.zip) the download window will 
appear at the same time the browser will crash. System is running win98SE
Seeing this too on Linux build 2000.02.27.09.  Click on download link on Mozilla
front page, file save dialog starts being drawn (outline and title bar only),
then segfault.  Trying XPApps.
Assignee: cbegle → don
Component: Browser-General → XPApps
Keywords: crash
QA Contact: asadotzler → paulmac
CC: rpotts (might be related to bug 23933), law (might be related to bug 20576).
Status: UNCONFIRMED → NEW
Ever confirmed: true
I misspoke: the crash happens when the unknown content type dialog appears, not
the file save dialog.  It happens on http: unknwon content as well, not just
FTP.  I think it stopped working about 2 days ago.
Keywords: regression
I see the same crash on Win95 with 02/25 build, it worked with builds before 
that.

There has already been a problem with unknown-file type window in bug 26248, 
cc'ing sairuh@netscape as in this bug mentioned.
sorry for the spam, I meant bug 26249 in former post.
Verifiying crash on Windows 2000 as well. Someone needs to change the OS 
component. How do you say Linux and Win32, but (Mac??)?
*** Bug 29490 has been marked as a duplicate of this bug. ***
*** Bug 27345 has been marked as a duplicate of this bug. ***
*** Bug 29492 has been marked as a duplicate of this bug. ***
Summary: file download causes crash → Download of unknown file type (ftp, http) causes crash

*** This bug has been marked as a duplicate of 29360 ***
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Verified dup.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.