Cannot set thunderbird as default mail application

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
14 years ago
10 years ago

People

(Reporter: jobst, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Although thunderbird *IS SET* to be my default mail application it comes up at
every start telling me its NOT.

I do not want to stop the dialog popping up in case something changes it, so
when I go into the option menu (general) and try to change it, I cannot set
thunderbird as default mail application, it comes up with a message box saying
that the registry key could not be set.

I have inlcuded my dump of the registry AND the dump when running "regmon" from
"www.sysinsternals.com" while I was doing the change.

My understanding is that all the registry values are correct and all registry
entries are ACCESSIBLE, i am running this as Administrator.



Reproducible: Always

Steps to Reproduce:
1.go to edit
2.go to option 
3.go to general
4.click on set thunderbirtd as default mail application
5. press ok
6. error appears
Actual Results:  
message box appears telling me its not working

Expected Results:  
some dialog box saying its done AND thunderbird NOT coming up saying it is NOT
the default application.


REGISTRY
########################################################################################################################
hkey_local_machine\software\clients\mail
    NoMailClient = 
    PreFirstRun = 
    = Mozilla Thunderbird
    Mozilla
        = Mozilla Mail
        DLLPath = E:\Mozilla\mozMapi32.DLL
        DefaultIcon
            = E:\Mozilla\Mozilla.exe,0
        InstallInfo
            HideIconsCommand = "E:\Mozilla\uninstall\MozillaUninstall.exe" /ua
"1.7.8 (en)" /hs mail
            IconsVisible = REG_DWORD 0x00000000
            ReinstallCommand = "E:\Mozilla\Mozilla.exe" -silent -nosplash
-setDefaultMail
            ShowIconsCommand = "E:\Mozilla\uninstall\MozillaUninstall.exe" /ua
"1.7.8 (en)" /ss mail
        protocols
            mailto
                = URL:MailTo Protocol
                shell
                    open
                        command
                            = E:\Mozilla\Mozilla.exe "%1"
        shell
            open
                command
                    = E:\Mozilla\Mozilla.exe -mail
    Mozilla Thunderbird
        = Mozilla Thunderbird
        DLLPath = E:\thunderbird\mozMapi32.DLL
        DefaultIcon
            = E:\thunderbird\thunderbird.exe,0
        InstallInfo
            HideIconsCommand =
"E:\thunderbird\uninstall\UninstallThunderbird.exe" /ua "1.0.2 (en)" /hs
            IconsVisible = REG_DWORD 0x00000000
            ReinstallCommand = "E:\thunderbird\thunderbird.exe" -silent
-nosplash -setDefaultMail
            ShowIconsCommand =
"E:\thunderbird\uninstall\UninstallThunderbird.exe" /ua "1.0.2 (en)" /ss mail
        protocols
            mailto
                = URL:MailTo Protocol
                URL Protocol = 
                DefaultIcon
                    = E:\thunderbird\thunderbird.exe,0
                shell
                    open
                        command
                            = E:\thunderbird\thunderbird.exe -compose "%1"
        shell
            open
                command
                    = E:\thunderbird\thunderbird.exe
            properties
                = Thunderbird &Options
                command
                    = E:\thunderbird\thunderbird.exe -options
    Netscape
        = Netscape Mail
        DLLPath = E:\netscape7\mozMapi32.dll
        DefaultIcon
            = E:\netscape7\NETSCP.EXE,0
        DefaultsIcon
            = E:\Netscape7\chrome\icons\default\messengerWindow.ico,0
        InstallInfo
            HideIconsCommand = "E:\Netscape7\uninstall\NSUninst.exe" /ua "7.1b1
(en)" /hs mail
            IconsVisible = REG_DWORD 0x00000000
            ReinstallCommand = "E:\Netscape7\Netscp.exe" -silent -nosplash
-setDefaultMail
            ShowIconsCommand = "E:\Netscape7\uninstall\NSUninst.exe" /ua "7.1b1
(en)" /ss mail
        protocols
            mailto
                = URL:MailTo Protocol
                URL Protocol = 
                shell
                    open
                        command
                            = E:\netscape7\NETSCP.EXE "%1"
        shell
            = 
            open
                = 
                command
                    = E:\netscape7\NETSCP.EXE -mail
    Outlook Express
        DLLPath = REG_EXPAND_SZ %ProgramFiles%\Outlook Express\msoe.dll
        = Outlook Express
        Envelope
            CLSID
                = {A08AF898-C2A3-11d1-BE23-00C04FA31009}
            CurVer
                = OutlookExpress.Envelope.1
        InstallInfo
            ReinstallCommand = REG_EXPAND_SZ
"%SystemRoot%\system32\rundll32.exe"
"%SystemRoot%\system32\shell32.dll",OCInstall ReinstallOE
            HideIconsCommand = REG_EXPAND_SZ
"%SystemRoot%\system32\rundll32.exe"
"%SystemRoot%\system32\shell32.dll",OCInstall HideOE
            ShowIconsCommand = REG_EXPAND_SZ
"%SystemRoot%\system32\rundll32.exe"
"%SystemRoot%\system32\shell32.dll",OCInstall ShowOE
            IconsVisible = REG_DWORD 0x00000000
        Protocols
            mailto
                = URL:MailTo Protocol
                EditFlags = REG_BINARY 0x00000004 0x00000002
                URL Protocol = 
                DefaultIcon
                    = REG_EXPAND_SZ %ProgramFiles%\Outlook Express\msimn.exe,-2
                shell
                    open
                        command
                            = REG_EXPAND_SZ "%ProgramFiles%\Outlook
Express\msimn.exe" /mailurl:%1
        shell
            open
                command
                    = REG_EXPAND_SZ "%ProgramFiles%\Outlook Express\msimn.exe" /mail

hkey_local_machine\software\classes\mailto
    = URL:MailTo Protocol
    URL Protocol = 
    DefaultIcon
        = E:\thunderbird\thunderbird.exe,0
    shell
        open
            command
                = E:\thunderbird\thunderbird.exe -compose "%1"

RUNNING REGMON WHILE DOING THE CHANGE
########################################################################################################################
1	13:08:31	thunderbird.exe:776	OpenKey	HKLM\Software\Clients\Mail	SUCCESS
Access: 0x2000000 	
2	13:08:31	thunderbird.exe:776	QueryValue
HKLM\Software\Clients\Mail\(Default)	SUCCESS	"Mozilla Thunderbird"	
3	13:08:31	thunderbird.exe:776	QueryValue
HKLM\Software\Clients\Mail\(Default)	SUCCESS	"Mozilla Thunderbird"	
4	13:08:31	thunderbird.exe:776	CloseKey	HKLM\Software\Clients\Mail	SUCCESS		
5	13:08:31	thunderbird.exe:776	OpenKey	HKLM\Software\Clients\Mail\Mozilla
Thunderbird\Protocols\mailto\shell\open\command	SUCCESS	Access: 0x2000000 	
6	13:08:31	thunderbird.exe:776	QueryValue	HKLM\Software\Clients\Mail\Mozilla
Thunderbird\Protocols\mailto\shell\open\command\(Default)	SUCCESS
"E:\thunderbird\thunderbird.exe -compose "%1""	
7	13:08:31	thunderbird.exe:776	QueryValue	HKLM\Software\Clients\Mail\Mozilla
Thunderbird\Protocols\mailto\shell\open\command\(Default)	SUCCESS
"E:\thunderbird\thunderbird.exe -compose "%1""	
8	13:08:31	thunderbird.exe:776	CloseKey	HKLM\Software\Clients\Mail\Mozilla
Thunderbird\Protocols\mailto\shell\open\command	SUCCESS

Comment 1

14 years ago
I have the same problems! I had similar problems also with netcape. There is
open a message (german):

Fehler [!]
0 : Deinstallation-Log-Verzeichnis nicht gefunden:
HKEY_LOCAL_MACHINE\Software\Mozilla Thunderbird\1.0.2 (en)\Uninstall\Unistall
Log Folder

Then a little part of a window-infoline with the Thunderbird logo, the min-, the
full- and the closer-icon opens (when thunderbird was not started) - and i have
to close the window first before i can work with Thunderbird.

Mozilla Thunderbird Version 1.0.2 (20050317)

Comment 2

13 years ago
I installed Thunderbird three times and have the same issue. THEN when mailto 
links are clicked in Firebird, Thunderbird will not launch, even after 
selecting the "Click to select Thunderbird as the Default mail application" msg 
box, which appears each time Tbird is opened. The Registry info is similar to 
that in the comments from other users below. V. 1.0.6 on WinXP, 512 DDR SDRAM, 
200GHD, Direcway Broadband and PeoplePC tested.  -CJ

Comment 3

13 years ago
*** Bug 288669 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 4

13 years ago
Work Around:

I started Outlook Express and upon query I made it the "default mail application".

I immediately closed Outlook and started Thunderbird and as soon as
thunderbird started I made it the default mail application again.

Since then I have never been asked again.

Comment 5

13 years ago
Workaround WFM. Thanks.

Comment 6

13 years ago
*** Bug 315967 has been marked as a duplicate of this bug. ***

Comment 7

13 years ago
Bug 314581 comment 17 provides a useful insight on a certain HKLM registry key; it seems that TB is not setting that correctly.

Comment 8

13 years ago
*** Bug 335799 has been marked as a duplicate of this bug. ***
QA Contact: general
Assignee: mscott → nobody

Comment 9

10 years ago
Jobst. Do you still see this?  (without the workaround)  dupe forward to bug 314581?

Comment 10

10 years ago
In Windows Vista, since installing, trying then removing Eudora, I cannot make Thunderbird the default email client, it always asks upon invocation, I click the Check button and check the always check box but it does not make any difference.  It always asks.
(Reporter)

Comment 11

10 years ago
(In reply to comment #9)
> Jobst. Do you still see this?  (without the workaround)  dupe forward to bug
> 314581?

I do not know ... as I said I have never been asked again and I do not know how to go back to the original "being asked".

Looking at all the other threads/bugs that relate to this issue as well as looking at all of those registry keys it seems that a lot has changed. 

I am currently running the version 2.00.18 and it seems that some of the
registry keys in question do not exist enymore (nor make any difference).

Sorry, I am not of much help.

Jobst
Since it's WFM for the reporter
->WFM

Brian: you might want to try setting some other app as default, then tb again. Or try reinstalling into another, empty folder.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.