Last Comment Bug 302211 - Need possibility to only show content/chrome entries in JS Console
: Need possibility to only show content/chrome entries in JS Console
Status: RESOLVED DUPLICATE of bug 1260877
:
Product: Toolkit Graveyard
Classification: Graveyard
Component: Error Console (show other bugs)
: Trunk
: x86 All
-- normal with 3 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on: 228205
Blocks: 490886
  Show dependency treegraph
 
Reported: 2005-07-26 10:04 PDT by Frank Wein [:mcsmurf]
Modified: 2016-06-29 11:02 PDT (History)
15 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description User image Frank Wein [:mcsmurf] 2005-07-26 10:04:48 PDT
Currently JS Console is being flooded by CSS Errors. This makes the JS Console
quite useless, we should add a way to only display content (as in pages from
http:// or ftp:// etc.),chrome or all types of messages in the JS Console.
Comment 1 User image Frank Wein [:mcsmurf] 2005-07-26 10:06:47 PDT
BTW: I already hacked a bit of code&UI up, result can be seen under
http://www.mcsmurf.de/mozilla/jsconsole1.gif
http://www.mcsmurf.de/mozilla/jsconsole2.gif
http://www.mcsmurf.de/mozilla/jsconsole3.gif
Patch will follow later, still needs some improvement.
Comment 2 User image Aaron Leventhal 2005-07-26 10:09:47 PDT
If you end up using a menubar, please make sure these go in the view menu.

If there is no menubar, please use accesskey mnemonics for:
All Content Chrome

I realize that's difficult to find one for the 2nd All button since A and l are
already used, so you could just make Content and Chrome into toggle buttons and
remove the 2nd "All" button. Or turn the 2nd button into "Any"

Also, if we end up with no menubar could you make the js toolbarbuttons all
class="tabbable" ?
Comment 3 User image Simon Bünzli 2005-07-26 16:20:45 PDT
If you just want to get rid of the CSS errors, you might be interested in bug
264162. Otherwise I can recommend you my Console Filter extension
(http://forums.mozillazine.org/viewtopic.php?t=264146) for debugging chrome -
it'll filter out anything you're not interested in (unfortunately it doesn't
work for Seamonkey, yet) - in case this bug gets wontfixed.
Comment 4 User image Peter van der Woude [:Peter6] 2005-08-29 13:23:46 PDT

*** This bug has been marked as a duplicate of 275265 ***
Comment 5 User image Frank Wein [:mcsmurf] 2005-08-29 13:34:58 PDT
This here is Content vs. Chrome, not JS vs. CSS
Comment 6 User image Alex Vincent [:WeirdAl] 2005-10-16 09:15:29 PDT
This can't be done until the console service is redesigned to allow for more
detailed information.
Comment 7 User image Peter van der Woude [:Peter6] 2005-10-16 09:34:37 PDT
see http://forums.mozillazine.org/viewtopic.php?t=318102 
Console² extension (which fixes this and another 30-ish bug)
Comment 8 User image Eyal Rozenberg 2006-04-11 11:25:44 PDT
Please comment on the relation between this bug and bug 260046.
Comment 9 User image Frank Wein [:mcsmurf] 2006-04-11 13:36:05 PDT
That bug is about URLs only, this bug here needs probably the redesign of the content service to work properly. What Console² does currently do to distinguish Chrome from Content works in 99% of cases, but not in all cases. There can be error messages that come from chrome/content, but have no URL in it.
Comment 10 User image (Unavailable until Apr 3) [:bgrins] 2016-06-27 07:46:55 PDT
The Error Console has been removed in favor of the Browser Console (see Bug 1278368), and the component is going to be removed.  If this bug is also relevant in the Browser Console, please reopen and move this into Firefox -> Developer Tools: Console.
Comment 11 User image Zack Weinberg (:zwol) 2016-06-27 09:42:40 PDT
I am mass-reopening and re-componenting every single one of the Toolkit:Error Console bugs that appear to have been closed without anyone even *glancing* at whether they were relevant to the Browser Console.

If you want to close a whole bunch of old bugs -- FOR ANY REASON -- it is YOUR RESPONSIBILITY to check EVERY SINGLE ONE OF THEM and make sure they are no longer valid.  Do not push that work onto the bug reporters.

(It's okay to close bugs that haven't been touched in years when they don't have enough information for you to figure out whether the problem is still relevant to the current software - the reporter probably isn't coming back to clarify.  But that is the ONLY situation where it is okay.)

(I'm going to have to do this in two steps because of the way the "change several bugs at once" form works.  Apologies for the extra bugspam.)
Comment 12 User image (Unavailable until Apr 3) [:bgrins] 2016-06-27 19:21:23 PDT
Matching bug for the browser console: 1260877

*** This bug has been marked as a duplicate of bug 1260877 ***

Note You need to log in before you can comment on or make changes to this bug.