Closed Bug 305649 Opened 14 years ago Closed 14 years ago

--enable-default-toolkit=cairo-gtk2 requires pango >= 1.8.0

Categories

(Core Graveyard :: GFX, defect, minor)

x86
Linux
defect
Not set
minor

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: mozilla_bugs, Assigned: roc)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b3) Gecko/20050713 SeaMonkey/1.0a
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b3) Gecko/20050713 SeaMonkey/1.0a

I've tried to build Linux Seamonkey with --enable-default-toolkit=cairo-gtk2
Apparently it requires --enable-pango (which is ok), but it barfs on Fedora Core
3 with pango-1.6.0:

nsFontMetricsPango.cpp: In member function `nsresult
nsFontMetricsPango::RealizeFont()':
nsFontMetricsPango.cpp:981: error: `pango_font_description_set_absolute_size'
undeclared (first use this function)
nsFontMetricsPango.cpp:981: error: (Each undeclared identifier is reported only
once for each function it appears in.)

pango_font_description_set_absolute_size() appeared only in pango-1.8, which
isn't that widespread yet in the main distros.
Can the requirements be lowered to pango >= 1.6, like the rest of --enable-pango?


Reproducible: Always
I see this too. I've only got pango 1.6.0 over here.
Possibly; that api was needed so that we could decouple our DPI setting from
pango's sniffing of the X DPI setting.  It isn't possible to do that with pango
pre-1.8.  FC4 at least has 1.8 ;)

We can possibly make this be an optional thing..
I may be totally off base as I don't know the true chain of dependency, but
looks like --enable-default-toolkit=cairo-gtk2 builds
thebes/nsSystemFontsGTK2.cpp, which in turn uses GetXftDPI(). It's under #ifdef
MOZ_ENABLE_XFT though...

Attached patch fixSplinter Review
This patch at lets you build and run on Pango 1.6. We'll still "do the right
thing" if Pango 1.8 is available.
Assignee: general → roc
Status: UNCONFIRMED → ASSIGNED
Attachment #193663 - Flags: superreview?(vladimir)
Attachment #193663 - Flags: review?(vladimir)
Well actually I haven't tested with Pango 1.8, but that's the intent :-)
Comment on attachment 193663 [details] [diff] [review]
fix

I hate that we have to do this, but it'll do for now.. thanks for the quick
patch.

r+sr=vladimir
Attachment #193663 - Flags: superreview?(vladimir)
Attachment #193663 - Flags: superreview+
Attachment #193663 - Flags: review?(vladimir)
Attachment #193663 - Flags: review+
It looks like that patch landed on August 24.  Is this fixed?
No, it's gotten even worse - cairo-gtk2 requires pango 1.10.0 now:

checking for pango >= 1.1.0... yes
checking _PANGOCHK_CFLAGS... -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include  
checking _PANGOCHK_LIBS...  -lpango-1.0 -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0  
checking for pango >= 1.10.0 pangocairo >= 1.10.0... Requested 'pango >= 1.10.0' but version of Pango is 1.6.0

This is on FC3, FC4 isn't better as it has pango 1.8.0.
Flags: blocking1.9a1+
Depends on: 322942
No longer the case; we're back to 1999 with 1.6!
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
No longer depends on: 322942
Er.. 1999?  1.6 first shipped in FC3, which shipped in November 2004.
Yes, the exact release date of pango-1.6.0 was 13 Sep 2004.
Status: RESOLVED → VERIFIED
Blocks: cairo-gtk2
No longer blocks: 322938
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.