Last Comment Bug 322938 - turn on thebes/cairo as default rendering back end on all primary platforms
: turn on thebes/cairo as default rendering back end on all primary platforms
Status: RESOLVED FIXED
[blocking1.9a1+]
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: x86 All
: -- normal with 4 votes (vote)
: ---
Assigned To: Vladimir Vukicevic [:vlad] [:vladv]
:
Mentors:
: uniscribe (view as bug list)
Depends on: 322942 323923 cairo-gtk2 323934
Blocks: 161179 pixels
  Show dependency treegraph
 
Reported: 2006-01-10 09:03 PST by Vladimir Vukicevic [:vlad] [:vladv]
Modified: 2014-04-26 02:22 PDT (History)
47 users (show)
pavlov: blocking1.9+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Vladimir Vukicevic [:vlad] [:vladv] 2006-01-10 09:03:59 PST
This is the tracking bug for making thebes/cairo the default back-end for linux, windows, and mac.  The current target for this is end of January (2006).
Comment 1 Boris Zbarsky [:bz] (Out June 25-July 6) 2006-01-10 09:18:20 PST
What's the plan for bug 305649?  If I read that bug correctly, then this won't run or compile on default pretty much anything Linux (up through and including FC4).
Comment 2 Mike Shaver (:shaver -- probably not reading bugmail closely) 2006-01-10 12:00:03 PST
I'm not that worried about the "won't compile" case prior to our release of Fx3, since developers can install whatever versions they want in alternate locations, or update their systems appropriately.

We should talk to Linux distro types and see what their plans are for providing pango updates to their supported distributions, for the start-of-2007 timeframe.  Copying Blizzard here, who else?
Comment 3 Vladimir Vukicevic [:vlad] [:vladv] 2006-01-10 12:13:06 PST
There's no compilation issue any more, though there will most likely be performance issues on non-recent X servers that we'll have to work through.  We're back to Pango 1.6 as the baseline, so it will compile and run on anything that's recognizable as modern linux.
Comment 4 Stuart Parmenter 2006-11-21 17:04:38 PST
finally.
Comment 5 Christopher Blizzard (:blizzard) 2006-11-22 07:44:34 PST
<borat>Niiiice</borat>
Comment 6 Simon Montagu :smontagu 2007-06-03 02:55:03 PDT
*** Bug 218887 has been marked as a duplicate of this bug. ***
Comment 7 JC Ahangama 2007-07-28 11:47:27 PDT
Simon,
Is the rendering problem of Pali (Classic Sinhala) related to this bug (fixed, of course) or different because it is essentially turning on Glyph Shaping for it though Pali is not a complex script being Latin-1 yet requires glyph rendering as the ligatures are in the OpenType Private area?
Microsoft's example here is interesting:
http://msdn2.microsoft.com/en-us/library/ms776501.aspx
I wonder if that has some bearing to this problem? Or, am I totally in the dark on what is going on with Pali?
Comment 8 Vladimir Vukicevic [:vlad] [:vladv] 2007-07-28 12:07:22 PDT
This is not even remotely the right bug for that question; please file a new bug for any issues with Pali.
Comment 9 Simon Montagu :smontagu 2007-07-31 12:50:53 PDT
(In reply to comment #7)
> Simon,
> Is the rendering problem of Pali (Classic Sinhala) related to this bug (fixed,
> of course) or different because it is essentially turning on Glyph Shaping for
> it though Pali is not a complex script being Latin-1 yet requires glyph
> rendering as the ligatures are in the OpenType Private area?

Turning on glyph shaping for Latin text is fixed by bug 387969. See http://kb.mozillazine.org/Browser.display.auto_quality_min_font_size

Note You need to log in before you can comment on or make changes to this bug.