When browser.tabs.autohide is enabled, toolbar customisation settings are ignored after restarting Firefox; extensions' icons are missing from the palette

RESOLVED FIXED in Firefox1.5

Status

()

defect
RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: pyromancer, Assigned: moz_bug_r_a4)

Tracking

({fixed1.8, regression})

unspecified
Firefox1.5
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.8b5 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050828 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050828 Firefox/1.0+

Starting from deer park branch official build 20050827, toolbar settings are
forgotten and it returns to default settings (back, forward, reload, close,
home, location, go, search).  All extension-defined icons are not visible from
the Customize dialog.  Changes to the toolbar are not retained between
executions.  I tried creating a new profile, but it had the same behavior.


Reproducible: Always

Steps to Reproduce:
1. Install branch official build 2005-08-27 or 2005-08-28
2. Observe results

Actual Results:  
toolbars reset to default, extension-icons previously on toolbar disappear, and
are not avalible in Customize dialog

Expected Results:  
left my toolbar settings alone! :-)

My configuration:
Generated Sun Aug 28 2005 23:28:19 GMT+0700 (CDT)
User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4)
Gecko/20050828 Firefox/1.0+
Build ID: 2005082806

Installed Extensions & Themes: (26)
- Adblock Plus 0.5.9.1: http://bene.sitesled.com/adblock.htm
- Aquatint 1.2.6: http://thecrayolakidd.deviantart.com/
- AutoLink 0.1: http://nowhere.net
- CustomizeGoogle 0.25: http://www.customizegoogle.com/
- CuteMenus 2 0.6.1: http://www.geocities.com/replysn/firefox.htm
- del.icio.us 0.5.7: http://delicious.mozdev.org/
- DOM Inspector 1.8b4: http://www.mozilla.org/projects/inspector/
- Extension Developer 0.2.2.20050505:
http://ted.mielczarek.org/code/mozilla/extensiondev/
- External Editor 0.5.2005081301: http://nullref.se/
- Feed Your Reader 1.2: http://projects.koziarski.net/fyr/
- Feedview 0.9.7: http://www.epigoon.com
- Foxylicious 0.4: http://dietrich.ganx4.com/foxylicious/
- Google Send to Phone 0.3:
http://toolbar.google.com/firefox/extensions/sendtophone/faq.html
- Google Toolbar for Firefox 1.0.20050803: http://www.google.com/
- Greasemonkey 0.5.1: http://greasemonkey.mozdev.org/
- Header Monitor 0.3.2: http://headermonitor.mozdev.org
- JavaScript Options 1.2.2:
http://www.blueprintit.co.uk/~dave/web/firefox/jsoptions/index.html
- Live HTTP Headers 0.10: http://livehttpheaders.mozdev.org/
- MR Tech Local Install 3.0.1: http://www.mrtech.com/extensions/
- Nightly Tester Tools 0.7:
http://www.blueprintit.co.uk/~dave/web/firefox/buildid/nightly.html
- Noia 2.0 (eXtreme) 2.88: http://kasteo.deviantart.com/
- Qute 2.1.4: http://quadrone.org/
- Reporter 1.8b4: http://reporter.mozilla.org/
- SpamCopSubmitAll 0.1: http://nowhere.net
- Tab Mix Plus Beta 0.2.4: http://tmp.gary.elixant.com
- Talkback 1.0+: http://talkback.mozilla.org/
Total Extensions & Themes = 26

Installed Plugins: (22)
- Adobe Acrobat: nppdf32.dll
- Adobe ESD Manager Plugin: NPAdbESD.dll
- Java(TM) 2 Platform Standard Edition 5.0: NPJava13.dll
- Java(TM) 2 Platform Standard Edition 5.0: NPJava14.dll
- Java(TM) 2 Platform Standard Edition 5.0: NPOJI610.dll
- Java(TM) 2 Platform Standard Edition 5.0: NPJava12.dll
- Java(TM) 2 Platform Standard Edition 5.0: NPJava11.dll
- Java(TM) 2 Platform Standard Edition 5.0: NPJava32.dll
- Java(TM) 2 Platform Standard Edition 5.0: NPJPI150.dll
- MetaStream 3 Plugin: npViewpoint.dll
- Microsoft® DRM: npdrmv2.dll
- Microsoft® DRM: npwmsdrm.dll
- Mozilla Default Plug-in: npnul32.dll
- QuickTime Plug-in 6.5.1: npqtplugin5.dll
- QuickTime Plug-in 6.5.1: npqtplugin4.dll
- QuickTime Plug-in 6.5.1: npqtplugin3.dll
- QuickTime Plug-in 6.5.1: npqtplugin2.dll
- QuickTime Plug-in 6.5.1: npqtplugin.dll
- RealPlayer Version Plugin: nprpjplug.dll
- RealPlayer(tm) G2 LiveConnect-Enabled Plug-In (32-bit) : nppl3260.dll
- Shockwave Flash: NPSWF32.dll
- Windows Media Player Plug-in Dynamic Link Library: npdsplay.dll
Do you see this in safe mode? http://kb.mozillazine.org/Safe_mode I'm almost
100% sure this is extension related, so if you don't see this fixed in safe
mode, you're probably not entering it properly.
Severity: major → normal
I'm not seeing this with a clean profile, nor with an extisting profile in safe
mode. (I am seeing it normally, though.)
Disabling Smart Middle Click fixed this for me. Oddly, that's not mentioned in
comment 0.

I'm marking this INVALID. Please reopen it if Firefox is actually at fault and
Smart Middle Click is just the trigger.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → INVALID
(In reply to comment #3)
> Disabling Smart Middle Click fixed this for me. Oddly, that's not mentioned in
> comment 0.
> 
> I'm marking this INVALID. Please reopen it if Firefox is actually at fault and
> Smart Middle Click is just the trigger.

I don't have SMC installed.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Did you try this in firefox's safe mode as Adam requested?
(In reply to comment #5)
> Did you try this in firefox's safe mode as Adam requested?

sorry guys... the culprit was Header Monitor 0.3.2
(http://headermonitor.mozdev.org).  I went and disabled all extensions and
re-enabled one at a time.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago14 years ago
Resolution: --- → INVALID
*** Bug 306672 has been marked as a duplicate of this bug. ***
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Summary: Toolbar settings ignored; custom icons missing → When browser.tabs.autohide is enabled, toolbar customisation settings are ignored after restarting Firefox; extensions' icons are missing from the palette
Extensions like Image Zoom, Titlebar Tweaks and Firesomething in combination
with browser.tabs.autoHide to false (the always visible first tab) are also
causing this kind of problems. Other problems are: not being able to close the
first tab or navigate through pages (buttons grayed out).
One of these three extensions in combination with browser.tabs.autoHide to false
and Toolbar Enhancements make also the Bookmarks Toolbar Items disappear.
I still have the issue after binary patching.

to restore my configuration I have to customize again, close firefox, delete
xpti.dat start firefox.

This workaround work on Windows XP, not on Linux (for 20050831 build, I'll test
the 20050901 tonight)

Generated Fri Sep 02 2005 09:47:19 GMT+0200
User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4)
Gecko/20050901 Firefox/1.0+
Build ID: 2005090106

Installed Extensions & Themes: (25)
- Adblock Plus 0.5.9.1: http://bene.sitesled.com/adblock.htm
- Add Bookmark Here 0.5.3: http://gorgias.de/mfe/
- All-in-One Gestures 0.16:
http://perso.wanadoo.fr/marc.boullet/ext/extensions-en.html
- Allow Right-Click 0.1.1: http://extensions.roachfiend.com
- BBCodeXtra 0.2.3: http://www.extenzilla.it/bbcodextra
- BlankLast 0.6: http://v2studio.com/k/moz/
- Canonical URL 0.1.2: http://www.google.com/search?q=Canonical%20URL
- ChromEdit 0.1.1.1: http://cdn.mozdev.org/chromedit/
- Disable Targets For Downloads 1.0: http://www.cusser.net
- DOM Inspector 1.8b4: http://www.mozilla.org/projects/inspector/
- Download Manager Tweak 0.6.6: http://dmextension.mozdev.org/
- Forecastfox 0.8.1.3: http://forecastfox.mozdev.org/
- Get jetable mail 0.4: http://www.jetable.org
- Gmail Notifier 0.5.1: http://www.nexgenmedia.net/extensions/
- Linky 2.6.0: http://gemal.dk/mozilla/linky.html?ver=2.6.0
- MediaPlayerConnectivity 0.4.0: http://membres.lycos.fr/sethnakht/
- Menu Editor 1.2: http://menueditor.mozdev.org/
- MR Tech Local Install 3.0.1: http://www.mrtech.com/extensions/
- ReloadEvery 0.6.1: http://reloadevery.mozdev.org/
- Reporter 1.8b4: http://reporter.mozilla.org/
- Statusbar Clock 1.7.1: http://www.cosmicat.com/
- Super DragAndGo 0.2.4: http://morphis.eu.org/
- Tabbrowser Preferences 1.2.7.1: http://216.55.161.203/theonekea/tabprefs/
- Talkback 1.0+: http://talkback.mozilla.org/
- undoclosetab 20041125.5: http://mozilla.dorando.at/
Total Extensions & Themes = 25

Installed Plugins: (14)
- Adobe Acrobat: nppdf32.dll
- Java(TM) 2 Platform Standard Edition 5.0 Update 4: NPJava32.dll
- Java(TM) 2 Platform Standard Edition 5.0 Update 4: NPJPI150_04.dll
- Java(TM) 2 Platform Standard Edition 5.0 Update 4: NPJava11.dll
- Java(TM) 2 Platform Standard Edition 5.0 Update 4: NPOJI610.dll
- Java(TM) 2 Platform Standard Edition 5.0 Update 4: NPJava12.dll
- Java(TM) 2 Platform Standard Edition 5.0 Update 4: NPJava13.dll
- Java(TM) 2 Platform Standard Edition 5.0 Update 4: NPJava14.dll
- MetaStream 3 Plugin: npViewpoint.dll
- Microsoft® DRM: npwmsdrm.dll
- Microsoft® DRM: npdrmv2.dll
- Mozilla Default Plug-in: npnul32.dll
- Shockwave Flash: NPSWF32.dll
- Windows Media Player Plug-in Dynamic Link Library: npdsplay.dll

(In reply to comment #8)
> Extensions like Image Zoom, Titlebar Tweaks and Firesomething in combination
> with browser.tabs.autoHide to false (the always visible first tab) are also
> causing this kind of problems.

I can confirm this.  When I disabled the Image Zoom extension I have installed
and restarted the browser, the problem went away.  By the sound of the comments
here, it sounds like a combination of things that may reproduce this bug and the
root cause has yet to be identified.

Has it occured to you guys that this *might* be being caused a conflicting
extension? Bugs with extensions are not Firefox's problem and should be taken up
with the maker of the extension. Can anyone reproduce this on trunk with a clean
profile?
(In reply to comment #11)
> Can anyone reproduce this on trunk with a clean profile?

Bug 306672 comment 2 sounded like a confirmation (on the 1.8 branch) to me,
which is why I reopened this bug. But if no-one can reproduce this without
extensions it ought to be resolved worksforme.
I've investigate a bit tonight and it seems it has nothing to do with which
extension are installed buit with the number of extension active : 4 or 5 makes
the bug happen for me.

it work on safe mode though. I'll try with a clean profile then reinstall one by
one all the extensions
Can anyone reproduce this in a /clean/ profile? If not this is INVALID.
(In reply to comment #14)
> Can anyone reproduce this in a /clean/ profile? If not this is INVALID.

This bug is kinda strange

I've started from a clean profile, then install extension one by one restarting
at each install.

I've done this by choosing randomly the extension in my extension list (see up
there). When reaching 4 or 5 extension, the toolbar started to reset. And once
it is reached, there no way to make the toolbar correct again (I've tried to
uninstall the last extension installed before the bug and no success).

It was with 20050903 Linux. I've noticed this bug with 20050826. I'm using
20050825 with no problem.
I forgot to mention that I don't have autohide on.
No, I can't reproduce this with a clean profile.
Most likely due to extensions that people have installed (or install). Please
reopen if you can reproduce in a clean profile with /no/ extensions.
Status: NEW → RESOLVED
Closed: 14 years ago14 years ago
Resolution: --- → INVALID
(In reply to comment #17)
> No, I can't reproduce this with a clean profile.

how many extension have you installed ? wich extensions ? whcih version of
firefox ? 

I can reproduce it with a clean profile from Windows and Linux. On windows I can
workaround the bug by customizing the toolbar again then close firefox, delete
xpti.dat.

On Linux I can't workaround the bug. It is really annoying.
*** Bug 307360 has been marked as a duplicate of this bug. ***
Another (partial) workaround: turn off auto-update of search engines under
advanced options. I had to disable a half-dozen extensions (or turn on
auto-hide) before doing this, now everything but Web Developer works, and I can
leave that pointless (for me) auto-hide last tab thing off.
I can reproduce with this extension in a clean profile.

Content of this extension is:
<overlay xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul">

<script>
document.getElementById("content");
</script>
</overlay>
This was caused by the fix for Bug 305828.

When a extension accesses tabbrowser element while loading browser.xul, the 
tabbrowser's constructor function is called immediately. Since the fix for Bug 
305828 landed, tabbrowser's constructor calls setStripVisibilityTo() when 
browser.tabs.autoHide pref is false.

And setStripVisibilityTo() accesses the menu items that are descendant elements 
of the toolbar. This access causes the toolbar's constructor to be called 
immediately. But, the toolbar's constructor can't get |currentset| attribute 
that holds customized states, since persistent attributes are not yet restored 
from localstore.rdf. Because of this, customized settings is ignored.

Also, setStripVisibilityTo() calls enterTabbedMode(). But, in this case, since 
the browser element is not yet initialized (i.e. browser.docShell is null), a 
exception occurs in setTabTitle(). Thus, the first tab can't have a progress 
listener. Because of this, user can't close the first tab.


I think there are two approaches to fix.
a) fix in extensions:
   Moving the code that accesses tabbrowser to onload event handler.
b) fix in tabbrowser.xml:
   Moving the code that could cause problems to the original place.
I can't reproduce Bug 305828. Could someone check if this fix doesn't break 
sessionsaver?
(In reply to comment #24)
> I can't reproduce Bug 305828. Could someone check if this fix doesn't break 
> sessionsaver?

I can confirm that this patch doesn't cause any problems with session saver 0.2.

Reopening bug based on comment 23.

Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Attachment #195538 - Flags: review?(vladimir)
(In reply to comment #21)
> Another (partial) workaround: turn off auto-update of search engines under
> advanced options.
 
This sounds like Bug 307558.
Assignee: nobody → moz_bug_r_a4
Status: REOPENED → NEW
Flags: blocking1.8b5?
OS: Windows XP → All
Hardware: PC → All
Version: unspecified → 1.5 Branch
I think this should be fixed in Firefox and not in the extensions since it
affects a lot of extensions.  Many extensions check for
"document.getElementById("content")" on browser window launch because they only
want to add onload events to the browser window.  I'd say over 90% of the people
will get hit by this if it is not fixed by the time 1.5 is released so I vote
for the patch.

I spent hours trying to figure out why my extension was causing problems in
Firefox 1.5B1, until I finally tracked down the browser.tabs.autohide = false,
document.getElementById("content") connection.

I was actually about to report the bug when I found this by searching.

BTW the bug seems to only affect the navigation toolbar.  The other toolbars
display normally.  The bug also disables the back and forward buttons.
Flags: blocking1.8b5? → blocking1.8b5+
Comment on attachment 195538 [details] [diff] [review]
Moving the code that could cause problems to the original place

r=vladimir
Attachment #195538 - Flags: review?(vladimir) → review+
Attachment #195538 - Flags: approval1.8b5?
I don't have cvs account. Could someone please check the patch in?
Let's get this landed on the trunk and resolve the bug so it can get a trunk
verification before branch approval evaluation. Thanks. 

Who can help with the landing here?
I will check this in in a couple of hours, if no one beats me to it.
Whiteboard: [checkin needed]
Trunk:
mozilla/toolkit/content/widgets/tabbrowser.xml; new revision: 1.109;
Status: NEW → RESOLVED
Closed: 14 years ago14 years ago
Resolution: --- → FIXED
Whiteboard: [checkin needed]
Target Milestone: --- → Firefox1.5
Version: 1.5 Branch → unspecified
Attachment #195538 - Flags: approval1.8b5? → approval1.8b5+
gavin, approval has been granted, could you please check in on 1.8 branch? Thanks.
1.8 Branch:
mozilla/toolkit/content/widgets/tabbrowser.xml; new revision: 1.103.2.6;

Thanks moz_bug_r_a4!
Keywords: fixed1.8
First, sorry for my english.
I have this bug too but it happens because there is double line in file
localstore.rdf in this:
<RDF:Description
RDF:about="engine://C%3A%5CProgram%20Files%5CMozilla%20Firefox%5Csearchplugins%5Cgoogle.src"
                   NS1:LastPingDate="1126674768" />
This line is doubled: NS1:LastPingDate="1126674768"
And in quotes there was another value. I deleted one line and it helped me.
(In reply to comment #35)
> I have this bug too but it happens because there is double line in file
> localstore.rdf <..>

Related to/duplicate of comment 26 -> bug 307558?
You need to log in before you can comment on or make changes to this bug.