Request for Outlook-style AutoPreview feature to see first few lines of messages

NEW
Unassigned

Status

Thunderbird
Mail Window Front End
--
enhancement
12 years ago
a year ago

People

(Reporter: Dan Kohn, Unassigned)

Tracking

(Depends on: 2 bugs)

Dependency tree / graph
Bug Flags:
blocking-thunderbird2 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

Outlook has an excellent feature (see attached screenshot) where it shows the
first few lines of the body of unread messages.  This is a complement, not an
alternative, to the preview pane, as it allows even quicker identification of
important messages and spam.  Any AutoPreview feature should be user selectable
to be used only for unread messages (my recommended default), for all messages,
or never.  This feature is similar to the request in bug 269264, but based on my
experience with Outlook, AutoPreview is well worth implementing.

Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

12 years ago
Created attachment 194882 [details]
Screenshot of Outlook's AutoPreview feature

This shows AutoPreview for new messages, but not read ones.

Comment 2

12 years ago
Seems like a valid RFE to me. See also Suite bug 198615.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk

Comment 3

12 years ago
Something for thunderbird 2.0 maybe?
Flags: blocking-aviary2?

Updated

12 years ago
Flags: blocking-firefox2? → blocking-thunderbird2?

Comment 4

12 years ago
we've already done something similar for Thunderbird 2 via tooltips and the new mail alert. We aren't going to block 2 on adding this preview text to the thread pane too. 
Flags: blocking-thunderbird2? → blocking-thunderbird2-

Comment 5

12 years ago
howdy y'all,

[1] my tb info ...
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.2) Gecko/20060308 Thunderbird/1.5.0.2 Mnenhy/0.7.4.666 - Build ID: 2006030803

[2] since i don't care for the msg pane [aka = preview pane] i would find the ability to see a snippet from each msg in the thread pane VERY handy. even without the tweak to make it show only for certain msg states - like read/unread - seeing the 1st few lines would help rather a lot.

i have looked at the tooltip version of this and find it not very helpful cuz i hafta hover over a msg to see the tooltip.

take care,
lee

Comment 6

12 years ago
How about doing one line for a start ?

Comment 7

12 years ago
Bug 312940 has implemented a new alert format for notifying of new messages, which includes a line from the new message.

Bug 314124 has implemented a tooltip-style popup when hovering over a folder with new messages, which shows the same information.

Bug 335310 requests an Outlook-like multi-line display, but not specifically 
for previewing message text.

Comment 8

12 years ago
(In reply to comment #7)
> Bug 335310 requests an Outlook-like multi-line display, but not specifically 
> for previewing message text.
> 
howdy mike,

while 335310 [how do i make that a link?] is asking for "subject, sender, date, and spam status" to be displayed in a multi-line threadpane display.

what this ref seems to be asking for is the one-line that is already shown PLUS a snippet of the text of the msg. one, two, or three lines of the msg shown under the row of items for that msg.

this seems VERY different to me.

take care,
lee


Comment 9

12 years ago
(In reply to comment #8)
> while 335310 [how do i make that a link?] 

Bugzilla automagically creates links if you write the word bug and a number after it.

Comment 10

12 years ago
It sounds to me (original filer of 335310) that there are two issues:

1) The ability to display messages in message list using more than one line per message item. Perhaps by making message display/column/layout be a configurable sub-view in itself.

2) The ability to make one of the things being displayed for a message (in message list) include the first X lines/words/characters of the message text.

The second feature really doesn't make too much sense until you have the first feature, but they are separate, distinct features -- each add a different kind of value.

Comment 11

12 years ago
Created attachment 223650 [details]
Gmail Screen Shot

Just like to add, based on what I understand:

1. There's a need of the end user: a more efficient way of managing multiple spam mails.

2. It should require a min. number of clicks to see (some content of) a max number of mails, so that he could mark them as a group (to junk or unjunk or delete)

3. The "outlook like" feature may be a solution. (I'm not familiar)

4. I think google's gmail also has a solution. 
(eg. See attached screen shot. I can confirm and delete 4 mails at one go: Without clicking to make it appear on preview, without hovering over; I just need one line of content to decide, to multi-select, then delete forever.)

5. The problem here is probably to determine which is the easiest to implement solution, so that this need can be met with smallest programming effort ?

Just a contribution to the discussion
-kokwei-

PS. Why I need this ? see my post http://forums.mozillazine.org/viewtopic.php?p=2268031
spam filter is good, but I still cannot avoid the need to read the many spam every other day :-(

Comment 12

12 years ago
A simple, programmable solution would be best I think. E.g.

<email-name> - <subject>\<snippet>

would produce:

Arthur Smith - Test email
Just a quick test email...

or

<email-full>\<subject>

Arthur Smith (asmith@example.com)
Test email

That way, everyone would be happy(ish) instead of arguing over the exact format. If we have to go with a fixed format, I'd prefer something like the latter.

PS. Is there a guide to compiling Thunderbird for Windows? If I could build the thing, I'd contribute code myself.
> PS. Is there a guide to compiling Thunderbird for Windows? If I could build the

http://developer.mozilla.org/en/docs/Build_Documentation

Comment 14

12 years ago
Okay, thanks. So looking at it, modifications would need to be made to the list display gadget (control or whatever) to allow for multiple lines. It's not as simple as adding \n into the strings. Also, a method for extracting the first line of an email must be created, to avoid the snippet being "Hi Paul,"

Comment 15

11 years ago
Created attachment 245385 [details]
A better view of the Outlook column display
see also bug #359462, an rfe about the zimbra style of doing this.
Depends on: 359462

Comment 17

11 years ago
(In reply to comment #16)
> see also bug #359462, an rfe about the zimbra style of doing this.

I guess Seth meant bug 364090.

oops, yes.
Depends on: 364090
No longer depends on: 359462
QA Contact: front-end

Comment 19

11 years ago
Isn't this a dupe of bug 213945?

Comment 20

11 years ago
Agreed.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 213945

Comment 21

11 years ago
(In reply to comment #20)
bug 213945 talks only about improving vertical view, autopreview (if implemented) would be an additional option of which this bug is about (see first few lines of messages).
This clearly is not a duplicate of that bug.

Both summaries, description and screenshots are clear, except the third screenshot here, that is pointless.

Bug 213945 is about the message headers view, this bug is about message body preview.

Bug 213945 request that the headers view should be multiline:
sender, size and date on the first and subject on the second line, for instance.
So it would require less horizontal view on the middle column of the vertical layout.
Take a look here:
https://bugzilla.mozilla.org/attachment.cgi?id=258111

This bug request that the first few lines or the first few words of the message body to appear on the 'headers view'.
Take a look here:
https://bugzilla.mozilla.org/attachment.cgi?id=194882


Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 23

10 years ago
Please consider  more recent (and intense) work of bug 213945

the preview is attacked also
see https://bugzilla.mozilla.org/attachment.cgi?id=307013
and from c 6 there, this is also treated , but c33 states some split to that bug that made me not dupe this.

Updated

10 years ago
Depends on: 213945

Updated

9 years ago
Assignee: mscott → nobody
Status: REOPENED → NEW

Comment 24

6 years ago
howdy y'all,

apple just updated their mail app to include this. lookee ...

http://pogue.blogs.nytimes.com/2011/07/21/a-roar-for-mac-os-x-lion-e-mail/
"The Inbox now shows you the first couple of lines of the message, which is much more helpful than seeing only the subject line."

take care,
lee

Comment 25

6 years ago
It would also be nice, if there would only be a second line for showing the subject and in the first line there could be shown the main infos like on the second Outlook screenshot "A better view of the Outlook column display".

But in the way it is until now, the 3 column view uses too much space for nothing and can't really good used if you didn't have an ultra-wide display. It would also be nice if there would be an add-on for such things. But there is also nothing for this. :-(

Updated

4 years ago
See Also: → bug 890457
You need to log in before you can comment on or make changes to this bug.