Last Comment Bug 307415 - Input removed from document is not removed from form properties
: Input removed from document is not removed from form properties
Status: RESOLVED DUPLICATE of bug 841442
:
Product: Core
Classification: Components
Component: DOM: Core & HTML (show other bugs)
: Trunk
: All All
: -- normal with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 373322 412529 449225 460955 736291 (view as bug list)
Depends on: 100499
Blocks: 718420
  Show dependency treegraph
 
Reported: 2005-09-07 13:00 PDT by Mike Caines
Modified: 2013-09-06 01:51 PDT (History)
19 users (show)
Ms2ger: in‑testsuite?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
testcase (934 bytes, text/html)
2005-09-07 13:01 PDT, Mike Caines
no flags Details

Description Mike Caines 2005-09-07 13:00:49 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050903 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050903 Firefox/1.0+

If an input is removed from the document, it still remains as a property of the
form, but NOT as a property of form.elements. The behaviour should be identical.

Reproducible: Always

Steps to Reproduce:
1. remove an input that is a descendant of a form

Actual Results:  
form.inputName still holds a reference to the removed input

Expected Results:  
form.inputName is updated to undefined
Comment 1 Mike Caines 2005-09-07 13:01:42 PDT
Created attachment 195176 [details]
testcase
Comment 2 Mike Caines 2005-09-07 13:07:43 PDT
This behaviour is evident in Firefox 1.04 on OSX
Comment 3 Aiko 2005-09-07 13:22:07 PDT
This is quite similar to bug 100499, same cause?
Comment 4 Gérard Talbot 2007-04-24 01:33:30 PDT
Bug 377413 is very similar to this bug.
Comment 5 Garrett Smith 2008-09-06 19:43:36 PDT
*** Bug 449225 has been marked as a duplicate of this bug. ***
Comment 6 Garrett Smith 2008-09-06 19:43:53 PDT
*** Bug 412529 has been marked as a duplicate of this bug. ***
Comment 7 Garrett Smith 2008-09-06 19:44:14 PDT
*** Bug 373322 has been marked as a duplicate of this bug. ***
Comment 8 Randeep Walia 2008-09-09 13:27:42 PDT
I observe this behavior on Firefox 2.0.0.16 on Windows. Holla.
Comment 9 Jesse Ruderman 2008-10-22 18:54:51 PDT
*** Bug 460955 has been marked as a duplicate of this bug. ***
Comment 10 Jesse Ruderman 2008-10-22 18:56:14 PDT
I can reproduce this bug using Firefox trunk on Mac.
Comment 11 Riccardo Pelizzi 2011-11-13 13:09:18 PST
I hope I won't surprise anybody if this bug is still present as of 9.0a2 :-)
Comment 12 Tim (fmdeveloper) 2012-03-16 16:03:14 PDT
*** Bug 736291 has been marked as a duplicate of this bug. ***
Comment 13 Alice0775 White 2013-09-05 22:54:26 PDT
I cannot reproduce the problem in Firefox24.0b8 and later.


Fixed window(m-i)
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/5458a7880db5
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20130619 Firefox/24.0 ID:20130619062021
Fixed:
http://hg.mozilla.org/integration/mozilla-inbound/rev/259e68f8843d
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20130619 Firefox/24.0 ID:20130619072522
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=5458a7880db5&tochange=259e68f8843d

I guess this is fixed by Bug 841442
Comment 14 :Ms2ger 2013-09-05 23:57:07 PDT

*** This bug has been marked as a duplicate of bug 841442 ***

Note You need to log in before you can comment on or make changes to this bug.