OPML import should respect folder structure as represented by outline tree.

RESOLVED FIXED

Status

MailNews Core
Feed Reader
--
enhancement
RESOLVED FIXED
12 years ago
6 years ago

People

(Reporter: Pontus Freyhult, Unassigned)

Tracking

({testcase})

Trunk
testcase
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; sv-SE; rv:1.8b4) Gecko/20050909 Firefox/1.4
Build Identifier: Tb 1.4

When exporting to OPML, the folder structure seems to be represented by
outline-containers, this structure is ignored.

Reproducible: Always

Steps to Reproduce:
1. Create a non-flat structure in a News & Blogs account
2. Export
3. Remove feeds (or change to another News & Blogs account)
4. Import
Actual Results:  
All feed folders are in the account root.

Expected Results:  
Folder structure should be conserved.

Comment 1

12 years ago
*** Bug 307862 has been marked as a duplicate of this bug. ***

Comment 2

12 years ago
-> NEW
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All

Updated

12 years ago
Assignee: mscott → sayrer

Updated

12 years ago
Status: NEW → ASSIGNED

Comment 3

12 years ago
Just a note: it seems that EXPORTING does respect folder structure.  If you add feeds and create folders so that there is some hierarchy, and export OPML, the folder structure is evident.  But if you then create a new account and IMPORT that same OPML, it doesn't respect the hierarchy.

Comment 4

12 years ago
*** Bug 338632 has been marked as a duplicate of this bug. ***

Updated

11 years ago
Assignee: sayrer → nobody
Status: ASSIGNED → NEW

Comment 5

10 years ago
I will take a look this weekend and perhaps implement this feature. Please let me know soon if somebody is already working on this so I don't waste effort.

Comment 6

9 years ago
I confirm it's still not implemented in 3.0 alpha 2.
It's pity that so easy thing takes years to be fixed. :(
Duplicate of this bug: 458170

Comment 8

9 years ago
Odd to see this open since 2005. It's all about XML parsing and creating some subfolders according to OPML groups! It should have straight forward implementation. Hope to see this fixed before v3.0 goes final!

Updated

9 years ago
Component: RSS → Feed Reader
Product: Thunderbird → MailNews Core
Duplicate of this bug: 577116

Comment 10

7 years ago
(In reply to comment #8)
> Hope to see this fixed before v3.0 goes final!

Well, that didn't happened of course :-)

Are bugs related to TB's feed reader currently on a low priority? as of 3.1.x - the feed reader is extremely basic and IMO isn't really useful.

Updated

6 years ago
Hardware: x86 → All
Version: unspecified → Trunk

Comment 11

6 years ago
Created attachment 579634 [details]
Test OPML file with sub-outilne

Here are a test file with sub-directory in feeds (sub-outlines) in order to test importation. Please note that OPML export keeps this structure while the export flattern all.
Attachment #579634 - Attachment mime type: application/octet-stream → text/x-opml
Keywords: testcase

Updated

6 years ago
Depends on: 721517

Updated

6 years ago
Depends on: 750292

Comment 12

6 years ago
fixed in Bug 750292.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.