Remove autofill build-id for non-browser products on guided enter bug page

RESOLVED FIXED

Status

()

bugzilla.mozilla.org
General
RESOLVED FIXED
13 years ago
7 years ago

People

(Reporter: gekacheka, Assigned: gerv)

Tracking

Details

(Reporter)

Description

13 years ago
The guided bug page autofills the build-id with the userAgent from the browser.  

This is only appropriate for the browser products (firefox/seamonkey/camino).

For non-browser products (thunderbird, sunbird), the build-id of the browser
does not accurately report which version of the non-browser product they are
using, and discourages users from supplying the build id because the field
already looks filled.

Steps to reproduce:

Guided bug page for Thunderbird
https://bugzilla.mozilla.org/enter_bug.cgi?product=Thunderbird&format=guided

Guided bug page for Sunbird
https://bugzilla.mozilla.org/enter_bug.cgi?product=Calendar&format=guided

Actual results:  Build id field is filled with BROWSER user agent string

Expected results:  Build id field is blank

Note: the guided help page inserts two lines like the following into the bug
description:

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10)
Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10)
Gecko/20050716 Firefox/1.0.6

Leaving the Build Id field blank will only leave the build-id line blank, and
the user-agent line will still contain the browswer info, so this change does
not risk losing any clues from the browser build id.
Assignee: justdave → gerv
There's a patch for this attached to bug 308950.

Gerv

Comment 2

11 years ago
*** Bug 356356 has been marked as a duplicate of this bug. ***
Wayne: what do you mean by "a workaround rather than a fix"? How would you fix it instead?

Gerv
This should now do the right thing in CVS Bugzilla (see bug 308950).

Gerv
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Component: Bugzilla: Other b.m.o Issues → General
Product: mozilla.org → bugzilla.mozilla.org
You need to log in before you can comment on or make changes to this bug.