Closed Bug 309293 Opened 15 years ago Closed 14 years ago

Provide trademark-/copyright-free logos and artwork for free software distributions (like Debian)

Categories

(Calendar :: Sunbird Only, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: sipaq, Assigned: mattwillis)

Details

(Keywords: fixed1.8.1)

Attachments

(12 files, 5 obsolete files)

39.84 KB, image/svg+xml
Details
13.20 KB, image/png
Details
21.63 KB, image/png
Details
299 bytes, image/png
Details
7.68 KB, image/png
Details
60.59 KB, application/octet-stream
Details
21.99 KB, image/png
Details
264.06 KB, application/octet-stream
Details
7.47 KB, application/octet-stream
Details
23.37 KB, image/png
Details
90.41 KB, image/png
Details
78.17 KB, patch
cmtalbert
: first-review+
benjamin
: second-review+
beltzner
: approval1.8.1+
Details | Diff | Splinter Review
Currently the Sunbird logo and its associated artwork (Icons) is copyright by
Mark Carson. It is not yet trademarked, but it probably will be in the future.

Therefore we should provide free alternatives for free software distributions
like Debian. Perhaps just a Calendar artwork without the surrounding Sunbird
(similar to the way the free icons for Firefox are made).

Mark, is that possible for you?
Refer to http://markcarson.com/MarkCarson/Asp/SunbirdLogo.asp for current
statement regarding the Sunbird logo. My understanding is that the logo (unlike
the theme) should not be triple licensed (MPL/GPL/LGPL) as this would reduce the
branding rights of the Mozilla Foundation/Corporation. If the assertions on my
website are inadequate, please have someone with the legal department of the
Mozilla Foundation or Mozilla  Corporation contact me directly:

Mark Carson
94-444 Punono Street
Mililani, HI 96789 USA
Mark@MarkCarson.com 
1-808-625-0443
Regardind calendar only logo (to avoid Sunbird trademark issues), yes this is
very possible. I will prepare a calendar only logo in various sizes and will
post on my website and will advise when completed (probably a couple of days).
Calendar logo (for trademark free distribution) in SVG format. I will later
prepare PNG bitmaps at various sizes. Hereby licensed under the MPL/GPL/LGPL.
Original copyright, Mark L. Carson 2005.
Calendar logo (for trademark free distribution) in PNG format. Size is 256x256
Hereby licensed under the MPL/GPL/LGPL. Original copyright, Mark L. Carson
2005.
Other image sizes and license statements may be found here:

http://markcarson.com/MarkCarson/Asp/Sunbird.asp

http://markcarson.com/MarkCarson/Asp/SunbirdLogo.asp
(In reply to comment #1)
> Refer to http://markcarson.com/MarkCarson/Asp/SunbirdLogo.asp for current
> statement regarding the Sunbird logo. My understanding is that the logo 
> (unlike the theme) should not be triple licensed (MPL/GPL/LGPL) as this would 
> reduce the branding rights of the Mozilla Foundation/Corporation. If the 
> assertions on my website are inadequate, please have someone with the legal 
> department of the Mozilla Foundation or Mozilla Corporation contact me 
> directly:

This is exactly what I meant with with my bugreport, but thanks for clearing
this up.
Calendar Logo images, icons and trademark-free & MPL/GPL/LGPL statements are now
completed on my website:
http://markcarson.com/MarkCarson/Asp/SunbirdIcons.asp#calendar
Feel free to upload into bugzilla any of the Calendar images/icons required. If
additional items are needed, please let me know.

Mark@MarkCarson.com
I have revised calendar logos and icons (PNG, PSD, ICO files) on my website,
ready for check-in. These are the trademark free versions which can be with
Debian, etc.

http://markcarson.com/MarkCarson/Asp/SunbirdIcons.asp#calendar
Mark, maybe you can add some kind of bird to the triple-licensed calendar logos?
Anyway, thanks for your commitment on this.
Alexander Sack's request to:
"...add some kind of bird to the triple-licensed calendar logos"

and Simon Paquet's original request:
"...just a Calendar artwork without the surrounding Sunbird"

are at odds. My understanding was that the calendar logo should follow along the
lines of the community logo for Firefox (the object without the animal, the
globe only for Firefox, the calendar only for Sunbird).

I'm hesitant to create a calendar logo with a bird as it might be preceived as a
2nd generation Sunbird logo which would just confuse the trademark issue rather
than clarify it.
Should this be closed now or is further work needed?
I would think so ... yes! Please add the free artwork to the build tree in such a way, that the non-free icons are replaced during build with the free ones unless you pass --official-branding.

In addition, please make it easier for distributors to remove the trademarked artwork by placing all of it only under other-licesens/branding/sunbird.

Of course, if all this is done already, feel free to close the bug!
Attached image Composited about image with tri-li logo (obsolete) —
Taking from Mark Carson to coordinate the task of getting these graphics in to the tree, and making Sb use _them_ by default.

Thanks Mark for the icon!
Status: NEW → ASSIGNED
Assignee: Mark → mattwillis
Status: ASSIGNED → NEW
My proposal to separate the tri-licensed (tri-li) and "trademarkable" branding elements is to create two new directories

/mozilla/calendar/sunbird/base/branding - for all tri-li elements
/mozilla/calendar/sunbird/base/officialBranding - for all trademarkable elements

The "branding" dir follows what Ff and Tb are doing.
This way, once MoFo gets the trademark stuff settled, the "officialBranding" could move to /mozilla/other-licenses/branding/sunbird easily.

Mostafah indicated in IRC that this plan sounds okay, but it would be preferrable to move immediately to /mozilla/other-liceness... rather than move twice.

He also requested signoff on the plan from mvl and dmose.
Status: NEW → ASSIGNED
Until now the logo and the associated artwork has not been trademarked and I know of no plans to do so, since involves some legal work and money.

I would definitely vote for plan A, i.e. moving to mozilla/calendar/sunbird/base/officialBranding first
(In reply to comment #15)
> Until now the logo and the associated artwork has not been trademarked and I
> know of no plans to do so, since involves some legal work and money.
> 
> I would definitely vote for plan A, i.e. moving to
> mozilla/calendar/sunbird/base/officialBranding first
> 

A "de facto" trademark is an unregistered one that is is use and stated to be a trademark. United States Patent and Trademark registration costs start at $325 US (http://www.uspto.gov/teas/eTEASimportantnotice.htm#NoRefund). Mozilla Foundation/Corporation has some rights by simply using a non-infringing de facto trademark. Since I will only license the artwork (bird with calendar) to Mozilla, I can help enforce, via copyight law, that the logo is not used for other purposes/programs. So my suggestion is that, regardless of government trademark registration, that MoFo/MoCo treat it like the trademark it is and place the image files in an appropriate folder structure.
Attachment #216480 - Attachment mime type: image/svg+xml → image/SVG
Attachment #196817 - Attachment is obsolete: true
Attachment #216480 - Attachment is obsolete: true
Will go in /mozilla/calendar/base/branding/
Attachment #216253 - Attachment is obsolete: true
Attachment #216934 - Flags: first-review?(jminta)
Attachment #196818 - Attachment is obsolete: true
Will go in /mozilla/calendar/base/branding/
Attachment #216935 - Flags: first-review?(jminta)
Will go in /mozilla/calendar/base/branding/

You won't be able to see this image in Bugzilla as it's just white
Attachment #216936 - Flags: first-review?(jminta)
The paths for the images above are wrong.

They should be:
/mozilla/calendar/sunbird/base/branding
Comment on attachment 216934 [details]
Tri-licensed "About" image

Note that current code expects this to be about-sunbird.png, not about.png.

r=jminta for these and other icons, but let's make sure we have a final decision about where they should go before checking them in.  I don't want to be moving them around.
Attachment #216934 - Flags: first-review?(jminta) → first-review+
Attachment #216935 - Flags: first-review?(jminta) → first-review+
Comment on attachment 216936 [details]
About credits footer image (white gradient with alpha so text "fades in")

In my testing, the words faded out a bit too high (under the icon itself).  Not sure if that was by design but it looked a bit odd.  Can you look into that? r=jminta with or without that though.
Attachment #216936 - Flags: first-review?(jminta) → first-review+
(In reply to comment #23)
> (From update of attachment 216934 [details] [edit])
> Note that current code expects this to be about-sunbird.png, not about.png.

I've got a patch for that, but I was holding off pending the final location of these things :)
Matthew,
while you are working on this: Could you create a high resolution png icon (non-branded and branded) too? Something similar to what is done in Bug 261679 for Firefox and Bug 262265 for Thunderbird.
(In reply to comment #26)

Sure.
(In reply to comment #26)
> Matthew,
> while you are working on this: Could you create a high resolution png icon
> (non-branded and branded) too? Something similar to what is done in Bug 261679
> for Firefox and Bug 262265 for Thunderbird.
> 

Icons (.ICO), PNGs and PSDs have been available on my website for some time. You are welcome to grab and check-in what you need from there: http://markcarson.com/MarkCarson/Asp/SunbirdIcons.asp
Attachment #217208 - Flags: first-review?(jminta)
Attachment #217221 - Flags: first-review?(jminta)
Comment on attachment 217221 [details]
icon64 (used in dialogs)

/mozilla/calendar/sunbird/base/branding/icon64.png
/mozilla/calendar/sunbird/app/macbuild/sunbird.icns
Attachment #217223 - Flags: first-review?(jminta)
/mozilla/calendar/sunbird/app/mozicon128.png
Attachment #217226 - Flags: first-review?(jminta)
/mozilla/calendar/sunbird/app/sunbird.ico
Attachment #217229 - Flags: first-review?(jminta)
/mozilla/calendar/installer/windows/Header.bmp
Attachment #217232 - Flags: first-review?(jminta)
PNG version (so it's under the attachment limit) of
/mozilla/calendar/installer/windows/Watermrk.bmp
Attachment #217233 - Flags: first-review?(jminta)
Comment on attachment 217208 [details] [diff] [review]
changes to build using generic images by default

Providnig trademark-free artwork is one thing, using them by default is something completely different, and needs a whole lot more discussion. Don't just check this patch in!
Comment on attachment 217208 [details] [diff] [review]
changes to build using generic images by default

Wow, apologies for not looking at this sooner, but this is *definitely* not me for review.  Over to mvl.
Attachment #217208 - Flags: first-review?(jminta) → first-review?(mvl)
Comment on attachment 217221 [details]
icon64 (used in dialogs)

rs=jminta on these, since I can't do proper testing for mac icons or windows installer stuff.
Attachment #217221 - Flags: first-review?(jminta) → first-review+
Attachment #217223 - Flags: first-review?(jminta) → first-review+
Attachment #217226 - Flags: first-review?(jminta) → first-review+
Attachment #217229 - Flags: first-review?(jminta) → first-review+
Attachment #217232 - Flags: first-review?(jminta) → first-review+
Attachment #217233 - Flags: first-review?(jminta) → first-review+
Comment on attachment 217208 [details] [diff] [review]
changes to build using generic images by default

Looks like we'll be using /mozilla/other-licenses/branding/sunbird after all, so this will need to be reworked. Pulling r?
Attachment #217208 - Attachment is obsolete: true
Attachment #217208 - Flags: first-review?(mvl)
Checked in /mozilla/calendar/sunbird/branding/about.png
Checked in /mozilla/calendar/sunbird/branding/aboutCredits.png
Checked in /mozilla/calendar/sunbird/branding/aboutFooter.png
Checked in /mozilla/calendar/sunbird/branding/icon64.png

Waiting on copyright stuff and 0.3a2 to land others 
So, i've talked with dmose and lilmatt.
the idea is to make sure we are not loosing the sunbird trademark even before we get it.
Also, we want to make sure that official builds are easy to reconize from contributers builds.
So, i'm sold. Go for it.
including bsmedberg only for the configure.in change
Attachment #228973 - Flags: second-review?(benjamin)
Attachment #228973 - Flags: first-review?(jminta)
Attachment #228973 - Flags: second-review?(benjamin) → second-review+
I've read through the latest version of the patch and talked with lilmatt about his decisions. It looks good to me. However, I was not able to build the changes, since much of it is mac specific, and I do not have a mac available.
Attachment #228973 - Flags: first-review?(jminta) → first-review?(cmtalbert)
Comment on attachment 228973 [details] [diff] [review]
build using generic branding by default


Moving first review to Clint per IRC discussion with jminta.
Attachment #228973 - Flags: first-review?(cmtalbert) → first-review+
Comment on attachment 228973 [details] [diff] [review]
build using generic branding by default

+#ifdef MOZ_USE_GENERIC_BRANDING
+% content branding %content/branding/ xpcnativewrappers=yes
OK, rob_strong convinced me that the right solution here is to leave this on, but add a comment noting that setting this bit hould be superfluous.

r=jminta with that comment.
patch checked in on trunk

Once all is stable and looks okay, we'll go for branch approval.
Comment on attachment 228973 [details] [diff] [review]
build using generic branding by default

a181 requested for configure.in change.
Attachment #228973 - Flags: approval1.8.1?
Comment on attachment 228973 [details] [diff] [review]
build using generic branding by default

a=drivers, enjoy your non-official-brandingness on the branch!
Attachment #228973 - Flags: approval1.8.1? → approval1.8.1+
(In reply to comment #50)
> (From update of attachment 228973 [details] [diff] [review] [edit])
> a=drivers, enjoy your non-official-brandingness on the branch!

Checked in on MOZILLA_1_8_BRANCH

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.