cannot start compose window in running instance from commandline

RESOLVED DUPLICATE of bug 312154

Status

--
major
RESOLVED DUPLICATE of bug 312154
13 years ago
12 years ago

People

(Reporter: stefan_blobner, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; HP-UX 9000/785; en-US; rv:1.8b4) Gecko/20050909 Firefox/1.4
Build Identifier: Thunderbird version 1.5 Beta 1 (20050920)

in 1.0.6 I had an instance of Thunderbird running and could call 'thunderbird
mailto:' from the commandline to open a mail compose window of the running
instance. I'm using this to get a compose window with a keyboard shortcut.

this doesn't work in 1.5b1 any more, but instead there's a window coming up,
saying 'Thunderbird is already running, but is not responding. To open a new
window, you must first close the existing Thunderbird process, or restart your
system'. when I confirm this, the new process returns with 'Gtk-CRITICAL **:
file gtkmain.c: line 582: assertion `main_loops != NULL' failed.'


there's documentation on the '-remote' feature available:
http://www.mozilla.org/docs/command-line-args.html
http://www.mozilla.org/unix/remote.html
but this also doesn't work (and it even has disappeared from the '-h' help page).
'thunderbird -remote "mailto()"' just returns 'Error: Failed to send command: No
response included'

Reproducible: Always
(Assignee)

Comment 1

13 years ago
dupe of Bug 281847?
(Reporter)

Comment 2

13 years ago
the issue still exists in 1.5 Beta 2.

only the behaviour is a bit different. this time the commandcall 'thunderbird
mailto:' simply hangs and never comes back.
(Reporter)

Comment 3

13 years ago
still reproducable in Thunderbird 1.5RC1: there's a window coming up, saying 'Thunderbird is already running, but is not responding. To open a new window, you must first close the existing Thunderbird process, or restart your system'.

Comment 4

13 years ago
I can verify this on Solaris. And it's not only affecting Tbird but Ffox as well. Tested version is Tbird/Ffox 1.5 RC1. To me this should be considered as a blocker for 1.5.

Comment 5

13 years ago
Still reproducible in Firefox 1.5 RC2/Solaris:
Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
(Reporter)

Comment 6

13 years ago
still reproducable on Thunderbird 1.5rc2

Comment 7

13 years ago
I strongly believe this is a dupe of bug #312154. Work is in progress on that one.
*** Bug 332684 has been marked as a duplicate of this bug. ***

Comment 9

13 years ago
(In reply to comment #7)
> I strongly believe this is a dupe of bug #312154. Work is in progress on that
> one.

This bug is solved by the fix of bug #312154 and should be closed.
(Reporter)

Comment 10

13 years ago
I verified it in Firefox 1.5.0.3 and Thunderbird 1.5.0.2 and it works ok on both. the only thing left would be the online help that doesn't mention a word about the '-remote' option. it'd be cool if that could be fixed as well.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 312154
You need to log in before you can comment on or make changes to this bug.