Need an option to hide completed tasks in the todo-list

RESOLVED FIXED in Lightning 0.5

Status

Calendar
Lightning Only
RESOLVED FIXED
13 years ago
12 years ago

People

(Reporter: Joey Minta, Assigned: Joey Minta)

Tracking

unspecified
Lightning 0.5

Details

Attachments

(3 attachments, 2 obsolete attachments)

(Assignee)

Description

13 years ago
I checked off 'study for test', so I want lightning to stop bugging me about it.
(Assignee)

Comment 1

13 years ago
Created attachment 197649 [details] [diff] [review]
add checkbox+property

This patch adds a checkbox to the todo-overlay and adds the necessary property
to the todo-list.  It makes completed tasks hidden by default, for better or
worse.	It's 1 click to change that, so I'm not too concerned about which is
more intuitive.
Assignee: shaver → jminta
Status: NEW → ASSIGNED
Attachment #197649 - Flags: first-review?(dmose)

Comment 2

13 years ago
jminta: Can you attach a screenshot of what this looks like?
(Assignee)

Comment 3

13 years ago
Created attachment 198509 [details]
screenshot

Shows how the todo-list looks with the option both checked and unchecked.

Comment 4

13 years ago
Given how little vertical space we have, I'm wondering if it might not make more
sense to put this option on a context menu for that tab.  That would be less
discoverable, however.  Beltzner, any thoughts on this?

Updated

13 years ago
Attachment #197649 - Flags: first-review?(dmose)
(Assignee)

Comment 5

13 years ago
(In reply to comment #4)
> Given how little vertical space we have, I'm wondering if it might not make more
> sense to put this option on a context menu for that tab.  That would be less
> discoverable, however.  Beltzner, any thoughts on this?

Another option I'm considering is to try to link everything in the tabbox.  That
is, the filter option in the 'Agenda' tab would have a 'Completed tasks'
checkable option that would control the task-list tab (and of course the tasks
shown in the agenda).  Additionally, checking/unchecking calendars in the
calendar list would control the agenda/task-list.

The disadvantage of this is that some options for filters affecting the current
tab are hidden in unselected tabs.  The advantage is that we have single sources
of control on these options, avoiding complexity/spending screen real estate for
controlling the same option in different areas.

(see also bug 293201)

Updated

13 years ago
QA Contact: shaver → lightning

Comment 6

13 years ago
Whichever way this is solved, I think the default should be to hide completed tasks. I am waisting much more space on completed tasks than I would on, say, the proposed checkbox. 

I suggest that for now this be made a Tools-->Options-->Lightning option which can in the future be also toggled via a checkbox or any of the other suggested methods.  As a user, I really don't want to have to delete all my completed tasks: I like to marvel at what I was able to acheive. On the otherhand, with all the completed tasks in view, the todo pane is completely useless for me. So I think something should be made soon to make this pane usable.
(In reply to comment #4)
> sense to put this option on a context menu for that tab.  That would be less
> discoverable, however.  Beltzner, any thoughts on this?

As long as completed tasks don't disappear the moment you check them, I think putting this option on a context menu is fine. Perhaps do something where, once marked as completed, the tasks remain in the list until the next session. So, render them as completed, and then on shutdown flip whatever bit is used to hide them.

Comment 8

12 years ago
So it's been three months since the last comment on this bug; has there been any change in status?

It sounds like a patch has been proposed. Could it be added to the builds, at least for now? Or has it been already?

Personally, I think adding the 'hide completed' box would be just fine. It's simple, intuitive, and other todo list applications do it this way. 

Comment 9

12 years ago
I'm nominating this for blocking because it seems to be a rather large problem, and because a patch may already be available. Having completed items cluttering the display, especially in lightning, make the todo list all but unusable.
Flags: blocking0.3?
(Assignee)

Comment 10

12 years ago
We totally need to do *something* here, although I'm not yet sure what it is.  Please re-nominate when there is a clear plan, with UI-approval (The original patch seems to have been rejected on UI grounds).  Until such a plan exists, this can't block 0.3.
Flags: blocking0.3? → blocking0.3-
Whiteboard: [cal-ui-wanted]

Comment 11

12 years ago
I think one problem is that this patch was never really rejected, at least not in the record here. From my reading it seems as though people questioned the approach, but the questions were never explored, so there was no finality and the patch hung.

In any case, is there some process for UI approval? In my uninformed, outsider opinion it seems that this bug would be driven to close fairly quickly if there was only some momentum.
(Assignee)

Comment 12

12 years ago
(In reply to comment #11)
> In any case, is there some process for UI approval? 
For smaller ui-proposals, it's sufficient to simply right up a proposal in a bug comment, and then change the status-whiteboard to include [cal-ui-review needed].  For larger proposals, you should start a thread in mozilla.dev.apps.calendar.  One of the problems is that all of calendar devs are pretty pakced with 0.3 stuff already.  If you wanted to take up the job of creating this proposal, that'd be most helpful.
Whiteboard: [cal-ui-wanted] → [
(Assignee)

Updated

12 years ago
Whiteboard: [ → [cal-ui-wanted]

Comment 13

12 years ago
I have several hundreds completed tasks made with the calendar extension. Since lightening occupies  quite small space, it would be embarassing not to have the ability to hide the completed task.

Could you include this feature for the final 0.3 release?
Comment on attachment 197649 [details] [diff] [review]
add checkbox+property

Submitting this as is for UI-review as an interim solution.

It's clear from 0.3 user feedback that this is missed in Lightning, so I'd vote to put this in rather than wait until we come up with a better solution.
Attachment #197649 - Flags: ui-review?(dmose)
Whiteboard: [cal-ui-wanted] → [cal-ui-review needed]
My other thought would be to move this to a menu item (similar to "Workweek days only") or to a preference.

Comment 16

12 years ago
(In reply to comment #15)
> My other thought would be to move this to a menu item (similar to "Workweek
> days only") or to a preference.

The problem with setting it as a preference is that sometimes it's good to be able to switch back and forth between modes. That's why the checkbox is a good thing. I propose that "hide completed" functionality is somewhat unique, and so a checkbox is justified.
*** Bug 356827 has been marked as a duplicate of this bug. ***

Comment 18

12 years ago
please add that checkbox. without it the only way to make the vew cleaner to delete all completed item which means data lost.
Comment on attachment 197649 [details] [diff] [review]
add checkbox+property

Got ui-review+ from dmose in IRC to take this change until we come up with something better.

Joey,
Could you make sure this is unbitrotted and ready for review?
Attachment #197649 - Flags: ui-review?(dmose) → ui-review+
Whiteboard: [cal-ui-review needed]
Target Milestone: --- → Lightning 0.5
(Assignee)

Comment 20

12 years ago
Created attachment 242624 [details] [diff] [review]
unbitrotted

bitrotting sucks.  I'm assuming the old patch still works, once it applies, so I didn't test.
Attachment #242624 - Flags: second-review?(dmose)
Attachment #242624 - Flags: first-review?
(Assignee)

Updated

12 years ago
Attachment #242624 - Flags: first-review? → first-review?(lilmatt)
Comment on attachment 242624 [details] [diff] [review]
unbitrotted

>Index: calendar/lightning/content/todo-list-overlay.xul
>===================================================================
> <vbox id="todo-tab-panel" flex="1">
>+  <checkbox id="completed-tasks-checkbox" label="Show Completed tasks" 
>+            persist="checked" oncommand="toggleCompletedTasks()" />

Nit: the label needs moved into an entity in order to be localizable.
I'm split on whether we should reuse the Sunbird one or not. I'll leave that decision to you.

r=lilmatt with that fixed.
Attachment #242624 - Flags: first-review?(lilmatt) → first-review+
Comment on attachment 242624 [details] [diff] [review]
unbitrotted

Moving r2 to ctalbert per dmose
Attachment #242624 - Flags: second-review?(dmose) → second-review?(cmtalbert)

Comment 23

12 years ago
Comment on attachment 242624 [details] [diff] [review]
unbitrotted


This is a great patch. I just have two nits:
In todo-list-overlay.xul there is a space at the end of this line:
>+  <checkbox id="completed-tasks-checkbox" label="Show Completed tasks" 

And there is a space at the end of this line in todo-list.js:
>+    document.getElementById("calendar-todo-list").showCompleted = 

Nicely done!
r+
Attachment #242624 - Flags: second-review?(cmtalbert) → second-review+
Created attachment 244035 [details] [diff] [review]
as checked in
Attachment #242624 - Attachment is obsolete: true
Attachment #197649 - Attachment is obsolete: true
Patch checked in on MOZILLA_1_8_BRANCH and trunk.

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 26

12 years ago
it's not working properly:
When I check a box next to a task (show completed tasks is unchecked) the task is still visible. I have to check 'show completed tasks' and then uncheck it to hide it
(Assignee)

Comment 27

12 years ago
(In reply to comment #26)
> it's not working properly:
> When I check a box next to a task (show completed tasks is unchecked) the task
> is still visible. I have to check 'show completed tasks' and then uncheck it to
> hide it
> 
This is intentional.  The idea that data would disappear immediately after performing an action like that seemed less-than-ideal.

Comment 28

12 years ago
I thought it would work like in Sunbird...

Comment 29

12 years ago
Joey, I respectfully disagree; should I open a new bug for discussion?

Yes, it may be startling for data to disappear from view immediately, but then it's extremely unintuitive for the control to perform otherwise. The box is called hide completed, and yet with this behavior it's not hiding the completed items. Perhaps one compromise would be to have the item fade out over the course of a few seconds.
(Assignee)

Comment 30

12 years ago
(In reply to comment #29)
> Joey, I respectfully disagree; should I open a new bug for discussion?
Please do.  I tend to agree with the fading out as a reasonable compromise.  An alternative task-list proposal I made several months ago included a 'Recently Completed' section, that would also make these tasks easy found.

Comment 31

12 years ago
I wonder why you all are trying to reinvent the wheel...

Why don't you simply use existing code from Sunbird?
I just played around a week (without any existing knowledge about XUL programming) and integrated "unfinder.js" and "unifinderToDo.js" into Lightning.

Additionally this brings the search functionality for events (back) to Lightning...

For anyone who is interested, I will attach a first screenshot.

Comment 32

12 years ago
Created attachment 256603 [details]
Lightning in Sunbird-Look

Updated

12 years ago
Duplicate of this bug: 371251
You need to log in before you can comment on or make changes to this bug.