When reading message, other "to" addresses are matched to address book in case-sensitive fashion

RESOLVED DUPLICATE of bug 129393

Status

Thunderbird
Mail Window Front End
--
minor
RESOLVED DUPLICATE of bug 129393
13 years ago
9 years ago

People

(Reporter: AJS, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)
Build Identifier: version 1.0.6 (20050716)

When reading a message from someone else to myself and others, it looks like 
Thunderbird tries to match up the other addresses on the "to" line with those 
in my address book.  If they are in my address book, then it just shows me the 
recipient's name, as well as a tooltip the actual email address, rather than 
the whole thing.  This is a nice feature, since it makes the "to" list more 
readable.

The problem I am having with this is that the matching to the address book is 
apparently case-sensitive.  So if I have "john@company.com" in my address 
book, but someone sends a message to "John@Company.Com" (as well as myself), 
then it's NOT matched up.  Furthermore, I am prompted to add "John" to my 
address book, which then gives me two separate entries with the SAME ADDRESS 
(different only in upper/lower case).

I would like to see the address book matching done in a case-INsensitive 
manner, so that more addresses are resolved, and I don't end up with duplicate 
Address Book entries.

Aside: even when the address *is* matched, I am still offered the option "Add 
to Address Book..." when clicking on a resolved email address.  Shouldn't this 
be more along the lines of "View in Address Book", to indicate that the 
address already exists, and that I don't need to add it again?  As it is, 
there's no way for me to know which ones I should add and which ones I should 
not.

Reproducible: Always

Steps to Reproduce:
1. add JDOE@company.com to your address book.  Use name "John Doe".
2. Send a message to yourself as well as jdoe@company.com


Actual Results:  
Read the message and notice that it does not say "John Doe" in the "to" line, 
but rather shows the email address

Expected Results:  
Should see the name from the Address Book, since "JDOE@company.com" is there, 
and this email was to "jdoe@company.com"

Also, i am prompted to add this address to my address book, when in fact it is 
already there.

Comment 1

13 years ago
(In reply to comment #0)
> I would like to see the address book matching done in a case-INsensitive 
> manner, so that more addresses are resolved, and I don't end up with duplicate 
> Address Book entries.

Duplicate of bug 305499 -> Core bug 129393?
 
> Aside: even when the address *is* matched, I am still offered the option "Add 
> to Address Book..." when clicking on a resolved email address.  

Related to Suite bug 131571?
(Reporter)

Comment 2

13 years ago
Yes, these are both dups, it seems.  Sorry, I *did* search for dup on the 
first one, but somehow did not turn this one up.  The "aside" one, you are 
right -- it's covered in the referenced bug.  Thanks again.

*** This bug has been marked as a duplicate of 129393 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
To the best of my knowledge this bug still exists in the main code.  To get it
fixed please go to bug 129393 and click the vote button to raise its level of importance.
You need to log in before you can comment on or make changes to this bug.