[MacOS X] No visual drag and drop feedback for toolbar bookmarks

RESOLVED DUPLICATE of bug 235243

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 235243
13 years ago
13 years ago

People

(Reporter: Andreas Wuest, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

When dragging an URL over the bookmark toolbar there is no visual feedback.

Two cases can be distinguished:

  * Dragging an URL over an empty space or an already existing bookmark: a
vertical bar should be displayed in order to know in which place the bookmark
would end up if dropped at this place.

  * Dragging an URL over a bookmark folder: the bookmark folder should be
highlighted exactly as when one would hover over it with the mouse pointer (not
dragging anything). Of course, after a short period of time, the folder should
expand, in order to be able to place the dragged URL in a specific place inside
the folder or even in a subfolder, but this is already covered in bug #299185.

As for now, none of that works. Please note that this is not an enhancement,
since this works on the other platforms.

Reproducible: Always

Steps to Reproduce:
1. Drag an URL from the location bar over the bookmark toolbar
2. No indicators are shown where this bookmark would be placed when dropped
Actual Results:  
No visual feedback at all.

Expected Results:  
See the two cases listed in this bug summary.

theme: Firefox default theme.
(Reporter)

Comment 1

13 years ago
Uhm, I guess I better reassign this bug to Core::Drag and Drop.
Component: General → Drag and Drop
Product: Firefox → Core
Version: unspecified → 1.8 Branch
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051005
Firefox/1.4.1 ID:2005100516

WFM in Windows, nothing changed using the default theme.
(Reporter)

Updated

13 years ago
Blocks: 237584

Updated

13 years ago
Blocks: 235243
(Reporter)

Comment 3

13 years ago
(In reply to comment #2)

> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051005
> Firefox/1.4.1 ID:2005100516
> 
> WFM in Windows, nothing changed using the default theme.

Of course it works for you on Windows, that's why this bug is tagged [MacOS X]
because on MacOS X it does NOT work (see also e.g. bug #300598).

THIS is a MacOS X SPECIFIC problem (and has also been confirmed by further MacOS
X users).
Component: Drag and Drop → Bookmarks
Product: Core → Firefox
Version: 1.8 Branch → unspecified
QA Contact: general → bookmarks
This is a dupe, bug 235243 is not fixed on any platform for the bookmarks
toolbar (but it works for the menu, which is a separate bug.

Splitting off a new bug when there is an existing bug that isn't resolved is not
productive.

*** This bug has been marked as a duplicate of 235243 ***
No longer blocks: 235243, 237584
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.