Open Bug 311948 Opened 15 years ago Updated 4 years ago

Stop button always enabled in separate message view windows (and non-functional)

Categories

(Thunderbird :: Mail Window Front End, defect)

defect
Not set

Tracking

(Not tracked)

People

(Reporter: awuest, Unassigned)

References

(Blocks 1 open bug)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1

When viewing an email message in a separate window, the stop button keeps being
enabled, although the message has long been downloaded from the IMAP server and
displayed. Pressing the button to stop whatever action there is still ongoing
(or more likely, not ongoing), does not do anything, and even after that the
button does not change to state disabled (at least after stopping whatever it
is, the button should get disabled... Althoug there nothing really is to stop,
because message downloading has alredy been completed).

Thunderbird 1.4.1 aka 1.5 beta 2.

Reproducible: Always

Steps to Reproduce:
1. Open an email in a separate window
2. Wait until completely downloaded and displayed

Actual Results:  
Stop button keeps being activated.

Expected Results:  
Stop button should get disabled after download of message is complete.
Just to clarify, I am talking about the stop button on the toolbar in the
separate message view window, not the button in the main window.
Version: unspecified → 1.5
Confirming.

Thunderbird 20051010 
Windows XP SP2
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: MacOS X → All
Hardware: Macintosh → All
QA Contact: front-end
Assignee: mscott → nobody
I guess it's supposed to stop a get mail. There's bug 239616 about that not working though.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091204 Thunderbird/3.0

This is also a problem for the main Thunderbird window.  Various users have reported in <news://news.mozilla.org:119/mozilla.support.thunderbird> that the Stop button is totally non-functional.  "TB was doing nothing...I clicked the Stop button...TB stopped doing nothing."  And when Thunderbird is doing something, the Stop button still stops nothing.  

Changing the Summary accordingly.
Summary: Stop button in "view mail window" always enabled → Stop button always enabled and is non-functional
Version: 1.5 → Trunk
Duplicate of this bug: 506078
Duplicate of this bug: 550430
The "Stop" button in the main window of Thunderbird 3.1.6 does not function. 

The "Stop" button in the main window does function properly, stopping the current transfer, in Thunderbird, version 2.0.0.24 (Windows XP, SP3).  However, it has not functioned in TB3.x since its inception.  (Perhaps this information could prove helpful to anyone fixing this deficiency
in TB3.x.)

It is a function that I find useful with sufficient frequency that I have been
forced to stop using TB3.x and have reinstalled TB2.0.0.24.

Time marches on!  Why has this bug gone unresolved for so long?
The "Stop" button in the main window of Thunderbird 3.1.6 does not function. 

The "Stop" button in the main window does function properly, stopping the current transfer, in Thunderbird, version 2.0.0.24 (Windows XP, SP3).  However, it has not functioned in TB3.x since its inception.  (Perhaps this information could prove helpful to anyone fixing this deficiency
in TB3.x.)

It is a function that I find useful with sufficient frequency that I have been
forced to stop using TB3.x and have reinstalled TB2.0.0.24.

Time marches on!  Why has this bug gone unresolved for so long?
Duplicate of this bug: 579576
Blocks: 579576
This bug is not actionable. The summary is way too general and will invite all sorts of useless confirmations. The summary does not match parts of the description in comment 0 (again, general vs. specific, e.g. IMAP). The description in itself is inconsistent between introductory description and STR (Imap vs. general). The current summary is wrong in that, at least for POP on TB9, main message window, the stop button is *not* always enabled (this part wfm, but didn't check the actual stop function, and can't check for IMAP). Per comment 1, it is however always enabled when viewing a message *in a separate window* (confirmed for pop msg on tb9). I think best would be to dissect what's left, see if we have bugs for that, or write up a clean bug from scratch, then close this.

comment 4 is duplicate of bug 579576 (regression of tb3.1), which is fixed. but as wayne correctly points out, this bug cannot be a dupe of bug 578576 because this was filed years before TB3/TB3.1.

Because of "always enabled in separate window", this does not look like dupe of bug 239616, either.
Blocks: 239616
Summary: Stop button always enabled and is non-functional → Stop button always enabled in separate message view windows (and non-functional)
You need to log in before you can comment on or make changes to this bug.