Last Comment Bug 313565 - Menus are broken, showing e.g. "File (UNDEFINED)", Regression after Checkin for Bug 312278
: Menus are broken, showing e.g. "File (UNDEFINED)", Regression after Checkin ...
Status: VERIFIED FIXED
: fixed1.8, regression
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: x86 All
: -- major with 1 vote (vote)
: ---
Assigned To: Brendan Eich [:brendan]
: Brendan Eich [:brendan]
:
Mentors:
: 313608 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-23 23:10 PDT by Tobias Fischer
Modified: 2005-10-26 01:52 PDT (History)
8 users (show)
dveditz: blocking1.8rc1+
bob: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Tobias Fischer 2005-10-23 23:10:28 PDT
This was an Regression from Checkin for Bug 312278.

All Menus are broken, showing an "(UNDEFINED)" behind the Menu-Entry.

Add an link to Screenshot from Hartmut Figge (thanks to him), who see this first:

http://www.triffids.de/pub/screenshot/men2.png

Creature-Build 2005102318 was in this way o.k., 2005102320 is broken.
Comment 1 Heinrich Witt 2005-10-23 23:47:41 PDT
The same in the branch-builds.
Comment 2 Jesse Ruderman 2005-10-24 00:00:10 PDT
Confirmed using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051023 Firefox/1.5.
Comment 3 Brendan Eich [:brendan] 2005-10-24 00:16:20 PDT
The regressing checkin, to jsstr.c, mistyped the bug it was addressing, which was not bug 312278, but bug 313276.

/be
Comment 4 Brendan Eich [:brendan] 2005-10-24 00:19:14 PDT
Fixed post haste.  Sorry for the trouble.

/be
Comment 5 Hartmut Figge 2005-10-24 02:08:57 PDT
(In reply to comment #4)
> Fixed post haste.

Yes, this bug doesn't show up in my just compiled seamonkey/1.1a.
Comment 6 Tobias Fischer 2005-10-24 02:22:52 PDT
Yes, mark this as verified=fixed now (using the Comet-Tinderbox-Builds). Think this was fixed on Windows too, but unfortuneately Creature is just on fire at Mo. ;-(

Thanks for your fast response Brendan. I have only seen the Checkin for Bug 312278 in Bonsai, not for 313276?
Comment 7 Tuukka Tolvanen (sp3000) 2005-10-24 08:35:57 PDT
*** Bug 313608 has been marked as a duplicate of this bug. ***
Comment 8 Brendan Eich [:brendan] 2005-10-24 09:37:04 PDT
(In reply to comment #6)
> Thanks for your fast response Brendan.

No thanks to me for my fast introduction of the bug :-/.  If I'm fast enough next time, no one will notice :-).

> I have only seen the Checkin for Bug
> 312278 in Bonsai, not for 313276?

I pasted the wrong bug # into my checkin comment.

/be

Note You need to log in before you can comment on or make changes to this bug.