long <PRE style="overflow:auto;"> formatted text fails to render, causes scroll problems

RESOLVED DUPLICATE of bug 215055

Status

()

RESOLVED DUPLICATE of bug 215055
13 years ago
5 years ago

People

(Reporter: mennis, Unassigned)

Tracking

({testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

Text which is fomatted as <PRE> fails to render after 1091 lines when certain css are applied.

Reproducible: Always

Steps to Reproduce:
1.Go to above URL
2.
3.

Comment 1

13 years ago
The server is not accessible.  Can you attach the testcase here?  Use the 'Create a New Attachment' link.
Summary: long <PRE> formatted text fails to render → long <PRE> formatted text fails to render
(Reporter)

Comment 2

13 years ago
Created attachment 200742 [details]
A zip file of the html and css files.

Hope this is useful.  I din't know how else to provide it.
Created attachment 200753 [details]
"minimal" testcase

This testcase is based on the original URL provided by the reporter.

Basically, all this contains is a large amount of text contained within <pre style="overflow:auto;">. Removing the "overflow:auto" resolves the problem.

For me, this not only does not render, but also when I try to scroll up and down, after a short while the scrillbar freezes, and the entire browser window becomes unusable (the view area does not refresh even when switching to other tabs).
This might be a duplicate of bug 111561 via bug 160483, although the symptoms are a bit different.

Also, I forgot to mention: I'm seeing this with:
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20051018 Firefox/1.6a1
(as well as recent 1.8 branch builds).
Keywords: testcase
OS: Windows XP → All
Hardware: PC → All
Summary: long <PRE> formatted text fails to render → long <PRE style="overflow:auto;"> formatted text fails to render, causes scroll problems
Version: unspecified → Trunk
Hmmm - when loading my testcase from bugzilla, the content does initially appear to render, but resizing the window or scrolling down causes it to vanish.

Also, I currently can't reproduce bug 111561 / bug 160483, so either the URL they're pointing to changed (neither has an attached testcase), or this is not really a duplicate.

I'm moving this to Core/Layout, and CCing bz (which will probably tell us this is a dupe ;-)
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
Yeah, this is a dup about widgets not being able to be bigger that 16bits coordinate-wise (so at most 32000 twips tall).
Whiteboard: DUPEME

Comment 7

13 years ago
"Minimal" testcase confirmed on 2 builds:
Mozilla/5.0 (Windows; U; Windows NT 5.0; ru-RU; rv:1.7.2) Gecko/20040808
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

If style overflow:auto or overflow:scroll applied to any block container (not only to pre) without height limitation, but with large amount of text, scroll down after some moment causes fail of rendering this text. E.g., 700kb text fails to render on ~20%. Scroll up resumes rendering.

Comment 8

13 years ago
Read my comment above.
We read it the first time.

Comment 10

13 years ago
Created attachment 217565 [details]
testcase-overflow.html

I've got a similar problem. See the attached testcase.
After opening the page and scrolling down (with keyboard, mouse wheel or scrollbar), suddenly the page gets completely black.
Removing the overflow:auto or the margin:0 fixes the problem.

Is this the same bug I'm hitting?
(In reply to comment #10)
>
> Is this the same bug I'm hitting?
> 

Yes.
*** Bug 334933 has been marked as a duplicate of this bug. ***

Comment 13

12 years ago

*** This bug has been marked as a duplicate of 215055 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.