Closed Bug 313764 Opened 17 years ago Closed 17 years ago

Firefox does not restart after update

Categories

(Toolkit :: Application Update, defect)

x86
Windows XP
defect
Not set
critical

Tracking

()

VERIFIED FIXED
mozilla1.8rc1

People

(Reporter: nthomas, Assigned: darin.moz)

References

Details

(Keywords: verified1.8)

Attachments

(4 files)

Steps to reproduce:

1. Download the win32 build from http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2005-10-24-23-mozilla1.8/
I used the zip for convenience.
2. Manually check for updates
3. Download update & restart

I saw the updater UI appear very briefly then Firefox does not restart. Testing on other platforms would be useful.
Flags: blocking1.8rc1?
Forgot to say: If Firefox is restarted manually then the update has been applied successfully. It just fails to restart as designed.
I can confirm this for the installer, too. Already noticed this when updating to 20051024.

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051025 Firefox/1.5 ID:2005102503
Also happens when you select 'later' - clicking on icon to open Firefox after update is downloaded installs the update but fails to launch Firefox.
Darin, could this be fallout from the updater changes?  I noticed Firefox wasn't restarting yesterday in my tests so maybe related to changes we took on 10/21?

Scott, did Thunderbird restart after you updated 10/21 to 10/22?
Also saw this with 10/24 nightly going to 10/25 nightly on windows.  Selected check for updates from help menu.  Updater ran but FF did not restart.  Manual restart after update worked fine and FF was updated to latest build.
Darin can you take a look?
Assignee: nobody → darin
Severity: normal → critical
Status: NEW → ASSIGNED
I can also reproduce this.  Investigating....
This is happening under WIN/XP on Trunk and branch.

Firefox and Thunderbird both.
Version: 1.5 Branch → unspecified
I can reproduce this as well in Firefox when going from 10/24 to 10/25. Note: I had to manually delete my updates\0 directory before attempting to upgrade because the 10/24 build doesn't have the fix for Bug 313623. The update.log file shows what appears to be a completed patch. The last comment in the log is "succeeded calling QuitProgressUI".

With the 10/24 Windows Thunderbird build, I am unable to update. I get an error "Failed (Unknown Reason)". Maybe the partial hasn't been pushed out to all the mirrors yet for Thunderbird. 

Chase, Thunderbird was restarting properly for me yesterday when I was going from 10/21 to 10/22 while investigating 313623. 
Flags: blocking1.8rc1? → blocking1.8rc1+
Confirming that Linux seems not to be affected by this bug. Chase just fixed the missing update info for Linux and a couple of OS X builds of the last few days.

I was able to update from 2005102104 thru to the respin 2005102510 with only the non-empty updates/0/ to contend with. Restarted automatically after each update applied. 
FYI the Thunderbird nightly update is now available on the mirrors and it to is exhibiting the restart problem. (updating from 10/24 to 10/25)
Attached patch v1 patchSplinter Review
This turned out to be something really stupid.  The fix is trivial.
Attachment #200777 - Flags: review?(benjamin)
What this a fallout of bug 312360? (Just out of curiousity)
Comment on attachment 200777 [details] [diff] [review]
v1 patch

yeah. .. ;-)
Attachment #200777 - Flags: review?(benjamin)
Attachment #200777 - Flags: review+
Attachment #200777 - Flags: approval1.8rc1+
fixed-on-trunk, fixed1.8
Status: ASSIGNED → RESOLVED
Closed: 17 years ago
Keywords: fixed1.8
Resolution: --- → FIXED
First reports are (4x) it's still NOT working on Firefox branch (20051025-10 to 20051025-14).
Peter:  you won't be able to verify the fix until the next update.  the bug was in the "old" copy of firefox that is being updated.
Have seen 3 reports that during upgrade of Firefox branch (20051025-14 to 20051025-19), it DOES restart now. 
After the auto-update and manual restart, my firefox told me, the update was installed sucessfully and I have to restart firefox - So one manual restart and one that finally worked was needed, not only one manual restart...
Verified fix.  I had yesterday mornings 2005-10-25-04-mozilla1.8 build installed. Since there were several builds yesterday it updated to each one. The first couple failed to restart. The last couple updates, including the one to 10-26 build restarted automatically as expected. Since the fix for this bug didn't go in until after the first respins. I think what I saw is expected.  You need a build after the fix went in to update to a later-than-that build to see the fix in action.
Status: RESOLVED → VERIFIED
Keywords: fixed1.8verified1.8
Keywords: qawanted
*** Bug 314145 has been marked as a duplicate of this bug. ***
I'm not sure if this belongs here or in a new bug, I'll
post it here since the symptoms are identical.

I'm still getting restart problems, most recently updating
from 28 October to 29 October. I've verified this with a clean
unzip and clean profile.  Here's what I've done:

(0) Running Windows XP. Here is my post-update UA string:
    Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051029 Firefox/1.5 ID:2005102903
    Rename old firefox and Mozilla (profile) directories.

(1) Download the 28-04 October build and unzip it (creating a new
directory). Change app.update.channel to nightly using a text editor
(before first launch of FF).

(2) Launch from Windows (quick start toolbar). Don't import anything.
      Normal startup.

(3) Help -> Check for Updates -> Download & Install Now>> 
    -> ..downloaded and verified. -> Restart Firefox Now.
      Brief appearance (less than a second) of what could be updater
      progress window but no restart.

    Copied update to update_1.log. (I'll attach these.)

(4) Launch from Windows.
      Got "Software Update Failed." dialog.
    Click OK
      28 October build launches.
    Exit.
    No change to update.log since copy.

(5) Launch from Windows.
      Software update progress window shows progress but then FF does not
      restart and there is no firefox process.
    Copied update.log to update_2.log.

(6) Launch from Windows.
      Normal launch of 29 October build.
Attached file last-update.log
(In reply to comment #22)

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051028 Firefox/1.5 ID:2005102804

Updated and restarted as expected for me from a fresh profile. I've attached the log.

One thing I noticed, however, is that fix for bug 313963 has not yet landed on the branch. If you start from an empty directory then you shouldn't get a new last-update.log file at all (due to that bug), so I'm betting that your "clean unzip" isn't actually clearing the firefox folder. Something in your folder is causing the patch to fail... but then you would expect a restart regardless...

One thing you didn't mention: in step 4 did you download/apply the full update?
(In reply to comment #25)
> (In reply to comment #22)

> One thing I noticed, however, is that fix for bug 313963 has not yet landed on
> the branch. 

> If you start from an empty directory then you shouldn't get a new
> last-update.log file at all (due to that bug), so I'm betting that your "clean
> unzip" isn't actually clearing the firefox folder. Something in your folder is
> causing the patch to fail... but then you would expect a restart regardless...

First, I never said that I got a last-update.log, just update.log. I renamed the existing /Program Files/firefox directory to something else and then did the unzip, so there's no chance of something remaining.

> One thing you didn't mention: in step 4 did you download/apply the full update?

I'm guessing it's an incremental update since I did it some time after the nightly was available and because the download was quick.



> One thing you didn't mention: in step 4 did you download/apply the full update?
> 
Comment on attachment 201281 [details]
last-update.log

Do you also this behaviour with a new profile ?
Attachment #201281 - Attachment mime type: application/octet-stream → text/plain
(In reply to comment #27)
> (From update of attachment 201281 [details] [edit])
> Do you also this behaviour with a new profile ?

Assuming you mean me, I get it with a new profile and an existing one. In the steps from Comment 22 I renamed the ../Application Data/Mozilla directory, forcing FF to create a new one.

> Updated and restarted as expected for me from a fresh profile.

Yes, new profile here too :)
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.