Scrollbar disappears when disclosure triangle shows many headers in msg pane

RESOLVED DUPLICATE of bug 223132

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 223132
13 years ago
13 years ago

People

(Reporter: Travis Risner, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Thunderbird 1.0.7 (20050923)

My mail provider adds lots of header lines (e.g. 13) to each message.  Using the three pane view works fine when only the one line for headers is showing.  However, if I click the disclosure tringle, there are so many header lines that they fill up the pane.  This means that I cannot see the remaining header lines, nor any of the message itself.

It appears that TB does not expect so many header lines and assumes that displaying them in a fixed block will be sufficient.  Perhaps the header block should also have a scroll bar or, when disclosed, the header lines should be added to the scroll area of the message text.

Workarounds - Several.  1. Move the separator bar up so all header lines can be displayed.  2. Double-click on message to dispay it in a separate window.  3. Change font size.  4. Change mail providers.   8-)

I scanned for a previous bug report on this without success.  

Reproducible: Always

Steps to Reproduce:
1. Receive a message with lots of headers.
2. Select the message for viewing in the three-pane view.
3. Click on the disclosure triange to display the message headers.
4. If necessary, move the separator bar down so not all headers are visible.

Actual Results:  
Once this condition is reached, neither the remaining headers nor the message are reachable.

Expected Results:  
A scroll bar should appear (or remain accessible) so the rest of the headers and the message can be reached.

Mac OS X 10.4.2.

Probably a problem on all platforms, but I cannot verify that.

Comment 1

13 years ago
In Seamonkey, bug 56825 (scroll the envelope bubble independently), and bug 9942 (scroll it with the message body).

In Thunderbird, bug 222312 (scroll the envelope bubble independently).  There's a workaround in that bug.

I'm duping this to 223312 because it's similar enough, and because I think Thunderbird should have at least one of these bugs open until it's fixed, at least for tracking.

*** This bug has been marked as a duplicate of 223312 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
OS: MacOS X → All
Hardware: Macintosh → All
Resolution: --- → DUPLICATE

Updated

13 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 2

13 years ago
Bug 223132.

There's no place like home, there's no place like home, there's no place like home...

*** This bug has been marked as a duplicate of 223132 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.