Closed Bug 314474 Opened 17 years ago Closed 17 years ago

Hang on pop-up menus, drop downs with history and sub-menu

Categories

(Firefox :: Shell Integration, defect)

PowerPC
macOS
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 298502

People

(Reporter: bfowler, Unassigned)

References

()

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051025 Firefox/1.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051025 Firefox/1.5

When typing into a form with an active drop-down history (such as Google),
when using a pop-up menu, or rarely when mousing over a sub-menu (or
the region that it will appear in) from the main menu-bar, Firefox will
hange with a Spinning Pizza Wheel Of Doom.

A normal force-quit get control back, bit this is tiresome, and I have been
using Camino 0.84 for the last several months which is not affected, except
when I need the Webdeveloper toolkit

Reproducible: Sometimes

Steps to Reproduce:
1. Pull down a menu with sub-menu (such as bookmarks)
2. Use the mouse to open and close a sub-menu
3. On the second or third time you try to open the sub-menu, the
hang happens.

Alternatively, type into Google (the page, not the Cmd-K box) a search
that you have used before. Firefox will drop down the previous search(es).
As you edit or type, Firefox will hang about one time in four.

I am fairly sure that I have seen this with a fresh profile, but I will
try again.

Actual Results:  
Hang with Spinning Pizza Wheel Of Doom, white box where menu should be drawn.
I can sometimes avoid the problem using arrow keys to navigate menus (to
avoid mousing over the trigger area), though this will sometimes evince
it when opening a sub-menu for the second time. I am careful to remember
what I have typed to anticipate Firefox's history appearing.

Expected Results:  
Menu should appear, Firefox should be responsive

MacOS Jaguar 10.2.6

This has been going on for months, and I thought that it was something in my
setup, but it is also present in the latest Beta.

I can't understand why I haven't seen any other reports, but search using
terms like 'hang' and 'drop' shows nothing like this. It is hardly likely to 
be a serious problem if nobody else is getting it.

Bug 311702 "Crash on site using Virtools plug-in 
[@nsQueryInterface::operator]"

has nsMacWindow::Resize( ) in the stack, but it is not the same.

Stack to follow.
Attached file Backtrace
The frames below nsMacWindow::Resize(int, int, int, int) () are probably
coming from the Mac OS X libraries
In order to see the hang appear using a new profile, I copied my existing
'bookmarks.html' file to it (this is what I had done when I had
check for the bug in the Firefox beta back on the 10th October),
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051030 Firefox/1.5 ID:2005103021

I don't see this in Windows, certainly not the autofill problem.
The bookmarks menu problem looks a little bit like Bug 306426. The bug has many appearances.
Thank you. I am not surprised that this is not seen on the windows
platform.

The appearance of my bug is quite different to the movie. There is no
incorrect flickering; the box, view or frame that would appear is cleared
to white and the rainbow cursor appears.

The lock-up/infinite loop is probably within the Mac OS compositing code,
and of course, might be specific to a very small range of OS versions and
possibly Apple's bug.
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20051106 Firefox/1.6a1

This Fox, build on Tiger does not have the problem when run on Mac OS
10.4.3 (Tiger), but does on 10.2.6 (Jaguar). Perhaps my comment 4 (OS
version specific) does in fact apply.
Ben, does bug 312713 look like the same issue?
Yes, the description matches. Particularly, the Spinning Pizza Wheel of
Doom. 

The characteristic is that the drop down for completion partially appears - the
view for it is cleared to white.

See Bug 312713 comment 6 .

In the case of Bug 312713 "hang when I attempt to do google search for tv 
guide and type the letters tv", I suspect that the hang appears when the letters
match a previous string, and does not when they don't.

You can certainly dup this bug against your earlier report, and I suspect that
a fix for it would fix this one.
(In reply to comment #5)
> Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20051106
> Firefox/1.6a1
> 
> This Fox, build on Tiger does not have the problem when run on Mac OS
> 10.4.3 (Tiger), but does on 10.2.6 (Jaguar). Perhaps my comment 4 (OS
> version specific) does in fact apply.

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20051106 Firefox/1.6a1

This Fox, build on Tiger does not have the problem when run on Mac OS
10.3.9 (Panther)

There is (one) similar message on the povray news server, and this:
http://www.cocoabuilder.com/archive/message/cocoa/2004/4/14/104179
which is very distantly related, if at all.
I have been getting exactly this problem, especially when filling in the Google window.  I guessed that it had something to do with an excessively large number of saved items to look through.  I did (Firefox > Preferences > Privacy > Saved Forms > Clear Save Form Data Now) and it hasn't re-occurred yet.  

I went to the Deerpath path hoping it would not happen and it still did.

Mac OS X 10.2.8 Jaguar
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051107 Firefox/1.5
Mac OS X 10.2.8 Jaguar

OK - I tried to nail down an exact sequence which results in problem - but can't.  But is does happen with annoying frequency.

I have only tried this at www.google.com in the main search box.
It generally seems to happen when there are entries in the field that match what you are typing.
It usually comes in after the second character is typed.
I even did a backspace/delete on the value that Google puts in when a new screen is displayed.  When I got back to two characters displayed - it locked up!

"Locked up" means a spinning beachball.  In the past I have walked away for an hour - but it still was spinning - I have to use Force Quit from the dock to escape.
(In reply to comment #9)
> I have been getting exactly this problem, especially when filling in 
> the Google window.  I guessed that it had something to do with an 
> excessively large number of saved items to look through.  ...
> 
> Mac OS X 10.2.8 Jaguar

I hate to be an abominable No man, but I really do not think that
that is likely.

There certainly have been problems with mork when the .dat files get
large, but I don't think that I have seen any with my own eyes since 
2003.

If you look at my comment 5 and comment 8 , you will see that my
guess is that Apple's code can deadlock in Jaguar, but not later
releases of their operating system. It is quite possible that this is 
fixable (I think that I first saw it in May) in the sense that we might
be able to avoid calls that evince this problem.

Like you, I was hoping that it was not going to be in DeerPark ...
(In reply to comment #10)
> Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051107
> Firefox/1.5
> Mac OS X 10.2.8 Jaguar
> 
> I have only tried this at www.google.com in the main search box.
> It generally seems to happen when there are entries in the field that match
> what you are typing.
> It usually comes in after the second character is typed. ...

See comment 6 , that is Bug 312713 "hang when I attempt to do google search 
for tv guide and type the letters tv".

(Firefox has just told me that it has downloaded version 1.5).
Dup of Bug 298502 "[10.2] empty pulldown menu and Firefox hangs (regression 
after bug 282940)"

*** This bug has been marked as a duplicate of 298502 ***
No longer blocks: 319747
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
I've got 10.2.8 running with Firefox 1.5 and have experienced this only when trying to load a live bookmark.  Mainly, it happens when I try to access the bookmark shortly after I've already successfully accessed it.  If I wait a few minutes, without trying to access it, I can click it and no Pizza Wheel of Doom shows.

So it appears I have to wait a few minutes between accessing it.  Hope this helps, as I've gone back to using Safari for now.

PBG4 OSX 10.2.8 550Mhz/256RAM.
I agree with your comments, but this is a True Bill, and is a Dup as 
acknowledged.

There is a candidate fix actually checked in for that bug, and is quite 
possible that this one is now fixed, I certainly haven't seen it recently, 
though I try to avoid evincing it, so that may not count for much!

Unless you need Firefox for web development, or you just like knowing that
you compiled your Applications and thus have constructive knowledge of their
sources, then Safari is going to be a better bet for most Mac Users at the 
moment.

If you have time, you might want to download the next 'bug fix' release of
Firefox.
You need to log in before you can comment on or make changes to this bug.