Closed Bug 314934 Opened 14 years ago Closed 14 years ago

undo / redo work *only* via menu, not via ctrl-z / ctrl-y

Categories

(Calendar :: Sunbird Only, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: weymar, Assigned: robin.edrenius)

References

Details

Attachments

(1 file, 3 obsolete files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051025 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051025 Firefox/1.5

Delete an event or events. Ctrl-Z to undo. Nothing happens. Edit > Undo, and event(s) reappear as expected. Ditto subsequent Ctrl-Y to redo deletion: Nothing happens. Edit > Redo, and event disappears again.

Reproducible: Always

Steps to Reproduce:
1. Delete event
2. Ctrl-Z to undo. Nothing happens.
3. Edit > Undo. Event reappears.
4. Ctrl-Y to redo deletion. Nothing happens.
5. Edit > Redo. Event disappears again.
6. Edit > Undo to get your event back!

Actual Results:  
Ctrl-Z & Ctrl-Y do nothing.

Expected Results:  
Ctrl-Z should = Edit > Undo.
Ctrl-Y should = Edit > Redo.
Confirming on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051101 Mozilla Sunbird/0.3a1
Status: UNCONFIRMED → NEW
Ever confirmed: true
I'll try and fix this.
Status: NEW → ASSIGNED
Assignee: mostafah → robin.edrenius
Attachment #201750 - Flags: first-review?(jminta)
Attached patch v2 - fix aligning (obsolete) — Splinter Review
The aligning was bad in the old one.
Attachment #201750 - Attachment is obsolete: true
Attachment #201752 - Flags: first-review?(jminta)
Attachment #201750 - Flags: first-review?(jminta)
Comment on attachment 201752 [details] [diff] [review]
v2 - fix aligning

r=jminta, but I think 0.3a1 tagging is supposed to happen today, so this probably won't make it in that build.  We'll get it in as soon as possible in the 0.3a2 cycle.
Attachment #201752 - Flags: first-review?(jminta) → first-review+
In http://lxr.mozilla.org/mozilla/source/calendar/resources/content/calendar.xul#154
the key binding for redo is different depending on OS system. In one case it would be Ctrl+Y in the other case it would be Ctrl+Shift+Z.

Do we need this here too? (Don't know what the default redo key e.g. on MacOs is. I only know that I would expect Ctrl+Y on Windows.)
(In reply to comment #6)
> In
> http://lxr.mozilla.org/mozilla/source/calendar/resources/content/calendar.xul#154
> the key binding for redo is different depending on OS system. In one case it
> would be Ctrl+Y in the other case it would be Ctrl+Shift+Z.
> 
> Do we need this here too? (Don't know what the default redo key e.g. on MacOs
> is. I only know that I would expect Ctrl+Y on Windows.)
> 

The relevant info here is in bug 258258.  From what i can understand of the comments there, the variations were introduced to avoid conflicts with SeaMonkey.  mvl might be able to clarify further though.

*** Bug 315374 has been marked as a duplicate of this bug. ***
*** Bug 315376 has been marked as a duplicate of this bug. ***
Comment on attachment 201752 [details] [diff] [review]
v2 - fix aligning

OK, I looked into this some more, regarding comment #6.  I realized that the shift+ctrl+z for redo is actually the standard key-binding for most redo events in linux programs.  In order to remain consistent with that, we should include the #ifdef here that are mentioned in comment #6.  redrenius, can you spin a new patch?
Attached patch Add ifdef (obsolete) — Splinter Review
Adding the ifdef.
Attachment #201752 - Attachment is obsolete: true
Attachment #202091 - Flags: first-review?(jminta)
Comment on attachment 202091 [details] [diff] [review]
Add ifdef

If you add an #ifdef, you should also add an #endif
(Again, this makes me wonder if patches are tested before they are submitted...)
Attachment #202091 - Flags: first-review?(jminta) → first-review-
(In reply to comment #12)
> (From update of attachment 202091 [details] [diff] [review] [edit])
> If you add an #ifdef, you should also add an #endif
> (Again, this makes me wonder if patches are tested before they are
> submitted...)
> 

I usualy test them, however, since I am building on windows I'm not sure how to test this (when the #ifdef is for linux).

A new patch is coming in a few minutes.
Attached patch Add #endifSplinter Review
Adding #endif
Attachment #202091 - Attachment is obsolete: true
Attachment #202102 - Flags: first-review?(jminta)
Severity: enhancement → normal
OS: Windows XP → All
Hardware: PC → All
Version: unspecified → Trunk
(In reply to comment #13)
> I usualy test them, however, since I am building on windows I'm not sure how to
> test this (when the #ifdef is for linux).

Just tryin to build would have given an error message on all platforms, because there is a syntax error.
Comment on attachment 202102 [details] [diff] [review]
Add #endif

r=jminta
Attachment #202102 - Flags: first-review?(jminta) → first-review+
patch checked in
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Verified on Windows with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20051108 Mozilla Sunbird/0.3a1+. Ctrl+Z and Ctrl+Y are working now.
*** Bug 325466 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.