Closed Bug 315929 Opened 19 years ago Closed 19 years ago

xpidl.exe needs libidl and glib libraries built for .Net 2005/MSVC++ 8.0

Categories

(Core :: XPCOM, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: ronny.perinke, Assigned: dbradley)

References

()

Details

Attachments

(6 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8) Gecko/20051110 Firefox/1.5 (Sephiroth/AXP)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8) Gecko/20051110 Firefox/1.5 (Sephiroth/AXP)

glib and libIDL used for VC71-based builds are not binary compatible with the
MSVC++ .net 2005 compiler, so it crashes.

I have created a set of new binaries compiled with MS Visual Studio 2005 Express Edition and new patches based on those for VC 7.0 (bug #123743).


The second problem is, that all exe files will crash during the build process because the corresponding .manifest files are missing (not copied with their binary)

Reproducible: Always

Steps to Reproduce:
1. build with MSVC++ 2005
2.
3.
Summary: xpidl.exe needs libidl and glib libraries built for .Net 2005/MSVC++ 8.0 and its manifest file → xpidl.exe needs libidl and glib libraries built for .Net 2005/MSVC++ 8.0
WONTFIXing this in favor of bug 242870
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → WONTFIX
No longer blocks: 323931
Component: xpidl → XPCOM
QA Contact: pschwartau → xpcom
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: