Switch all trunk/1.9 Windows tinderboxes to using VC8 instead of VC6

RESOLVED FIXED

Status

Release Engineering
General
RESOLVED FIXED
13 years ago
5 years ago

People

(Reporter: Stuart Parmenter, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
VC6 is old and doesn't build parts of cairo correctly and we need to move away from it.  We need this to happen before we can turn the cairo builds on by default on the trunk.  For additional reasons, see bug 298066 (switch to VC7.1) which this bug obsoletes.
(Reporter)

Comment 1

13 years ago
*** Bug 298066 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

13 years ago
Depends on: 323936
(Reporter)

Updated

13 years ago
Component: Build Config → Build & Release
Product: Core → mozilla.org
Summary: Switch Windows builds to using VC8 instead of VC6 → Switch trunk/1.9 Windows production builds to using VC8 instead of VC6
Version: Trunk → other
Assignee: nobody → chase
QA Contact: build-config → chase
(Reporter)

Updated

13 years ago
Depends on: 323941
No longer depends on: 323936
Does bug 249782 block this?
One of 323936 or this should probably be dup'd (or, at least, I can't tell how they're different)

Bug 315929 has patches for libIDL and the other gunk we need to get xpidl going.
Depends on: 315929

Updated

13 years ago
Depends on: 242870
No longer depends on: 315929

Comment 4

13 years ago
Mass reassign of open bugs for chase@mozilla.org to build@mozilla-org.bugs.
Assignee: chase → build
(Reporter)

Comment 5

13 years ago
this is done on gaius. needs to be done on the rest of the windows tinderboxes for thunderbird, sunbird, etc.

we can probably drop pacifica from the main Firefox tree in the next couple weeks.
(Reporter)

Comment 6

13 years ago
*** Bug 323936 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

13 years ago
Summary: Switch trunk/1.9 Windows production builds to using VC8 instead of VC6 → Switch all trunk/1.9 Windows tinderboxes to using VC8 instead of VC6

Updated

12 years ago
Depends on: 334456

Comment 7

12 years ago
creature (SeaMonkey trunk) is another candidate that's still running VC6 and needs to be replaced with a VC8 configuration/box.
Blocks: 343053

Comment 8

12 years ago
Voting for this for Lightning bug 343053.

Comment 9

12 years ago
I'm marking this fixed.

We have win2k3/VC8 ref tinderboxen for this, gaius[-vm] has vc8, and sea-win32-tbox (the VM) has VC8. There's also a trunk Win32 tbox waiting for Thunderbird.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 10

12 years ago
(In reply to comment #9)
> I'm marking this fixed.
> 
> We have win2k3/VC8 ref tinderboxen for this, gaius[-vm] has vc8, and
> sea-win32-tbox (the VM) has VC8. There's also a trunk Win32 tbox waiting for
> Thunderbird.
>
Not so fast. 343053 is still dependent. 

Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.