If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Add Lightning buttons to Thunderbird toolbar by default

VERIFIED INVALID

Status

Calendar
Lightning Only
VERIFIED INVALID
12 years ago
10 years ago

People

(Reporter: dmose, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
In addition to packaging the images, we may want to add some or all of these buttons to the toolbar by default.
(Reporter)

Comment 1

12 years ago
*** Bug 315961 has been marked as a duplicate of this bug. ***

Comment 2

12 years ago
Created attachment 205479 [details] [diff] [review]
overlay customizeToolbar.xul

All of the actual packaging, etc already seems to be in place.  If I drag a button to the toolbar, then a nice icon shows up without a problem.  The only bug I found was that icons don't show up inside the actual customize toolbar window.  This patch adds an overlay to that xul file so that the css rules can be applied.
Assignee: nobody → jminta
Status: NEW → ASSIGNED
Attachment #205479 - Flags: first-review?(dmose)
(Reporter)

Comment 3

12 years ago
Comment on attachment 205479 [details] [diff] [review]
overlay customizeToolbar.xul

I'd suggest switching from <overlay></overlay> to <overlay/>.  r=dmose with or without that change.
Attachment #205479 - Flags: first-review?(dmose) → first-review+

Comment 4

12 years ago
Comment on attachment 205479 [details] [diff] [review]
overlay customizeToolbar.xul

patch checked in, leaving bug open for adding buttons to the toolbar by default.  Suggestions as to what those buttons should be?

Comment 5

12 years ago
Setting this back to default to try and unload a bit of my assigned bugs.  Anyone interested in working on the remaining part of this should look at http://forums.mozillazine.org/viewtopic.php?t=189667 (scroll down several comments).
Assignee: jminta → nobody
Status: ASSIGNED → NEW
Whiteboard: [good first bug]

Comment 6

12 years ago
(In reply to comment #5)
> Setting this back to default to try and unload a bit of my assigned bugs. 
> Anyone interested in working on the remaining part of this should look at
> http://forums.mozillazine.org/viewtopic.php?t=189667

Joey, what do you think of this: 
http://forums.mozillazine.org/viewtopic.php?p=1105811#1105811
(Reporter)

Comment 7

12 years ago
(In reply to comment #6)
> (In reply to comment #5)
> > Setting this back to default to try and unload a bit of my assigned bugs. 
> > Anyone interested in working on the remaining part of this should look at
> > http://forums.mozillazine.org/viewtopic.php?t=189667
> 
> Joey, what do you think of this: 
> http://forums.mozillazine.org/viewtopic.php?p=1105811#1105811
> 

While that poster's logic is reasonable, the number of people who customize their toolbar is likely to be exceedingly small (ie only a fraction of power users).  I would suggest that the case to optimize for is the vast majority / non power-user.  So if we think that discoverability / convenience is given a good enough boost by putting it in the toolbar by default (and I kinda suspect it is), I think leaving the power users to tweak anything they don't like is the right thing to do.
(Reporter)

Comment 8

12 years ago
This shouldn't really block 0.1; the current state may be ugly, but it's usable.
No longer blocks: 298366

Comment 9

11 years ago
Update summary to reflect remaining issues.
Summary: icons for lightning toolbar icons should be packaged → Add Lightning buttons to Thunderbird toolbar by default

Comment 10

11 years ago
*** Bug 356828 has been marked as a duplicate of this bug. ***
Depends on: 327780
This bug is invalid with checkin of patch from bug 371916. -> Nominating for marking INVALID.
Whiteboard: [good first bug]

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID

Updated

10 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.