RSS title's with trailing spaces or newlines causes invalid folder names

RESOLVED DUPLICATE of bug 547543

Status

MailNews Core
Feed Reader
RESOLVED DUPLICATE of bug 547543
13 years ago
6 years ago

People

(Reporter: Nathan Dove, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051110 Firefox/1.5
Build Identifier: Thunderbird 1.5 (20051110)

The RSS folder names derived from titles with trailing spaces/newlines cause various problems, including headers with invisible contents, and invisible headers with invisible contents.

Reproducible: Always

Steps to Reproduce:
1. Click "Manage Subscriptions"
2. Add "http://rss.thesmokinggun.com/rss.asp"
3. Click OK

Actual Results:  
"Downloading feed articles" appears to download articles. When finished, headers are visible, but contents are not.

Expected Results:  
"The Smoking Gun" browseable in "News & Blogs" folder.

Should probably become a dependent of 124287 ("Problems with folders having names with illegal characters").

Comment 1

13 years ago
Worksforme, Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051109 Thunderbird/1.5 ID:2005110904

Comment 2

13 years ago
This could be a Windows-only bug; it's also failing for me with 1.6a1-1109, Win2K.  Like bug 315600 and bug 297569, there's an exception thrown while parsing the feed, but this error occurs in a different spot.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → Windows 2000
Version: unspecified → Trunk

Updated

13 years ago
Assignee: mscott → sayrer

Updated

11 years ago
Assignee: sayrer → nobody

Comment 3

10 years ago
I'm also seeing problems with feeds that contain spaces and newlines in their title tags (eg. all the blogs from CNET, like http://www.news.com/8300-13772_3-52.xml).

This is with TB 2.0.0.14 (Windows).

A folder is created, and correctly displays the headers and articles (so not the problem above), but the folder name contains spaces (ugly) and bug 291293 kicks in if you try to rename the folder (ie. you get duplicate folders afterwards).

If I can't find a bug that mentions the malformed folder name, I'll create a new one and reference this.

Updated

9 years ago
Component: RSS → Feed Reader
Product: Thunderbird → MailNews Core

Comment 4

6 years ago
fix in bug 547543.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 547543
You need to log in before you can comment on or make changes to this bug.