Closed Bug 316731 Opened 16 years ago Closed 16 years ago

Form submitted twice; second time empty

Categories

(Core :: DOM: Core & HTML, defect)

1.8 Branch
x86
Linux
defect
Not set
major

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: mahaveer_m, Unassigned)

References

Details

User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322)
Build Identifier: Mozilla/5.0 rv:1.8 Firefox/1.5

Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8)
Gecko/20051107 Firefox/1.5

I have a form (method : doPost) which when I submit, the doPost is executed first and then the doGet method is also invoked. This looks similar to mozilla bug 209375 but since I saw it in Firefox, I am raising a separate issue.

Reproducible: Always

Actual Results:  
The method doGet is also invoked.

Expected Results:  
The method doPost alone should have got executed.
*** Bug 316741 has been marked as a duplicate of this bug. ***
*** Bug 316722 has been marked as a duplicate of this bug. ***
*** Bug 316803 has been marked as a duplicate of this bug. ***
*** Bug 316804 has been marked as a duplicate of this bug. ***
Far and away the most common way to get that is to return a page which includes either an <img src=""> or a background-image:url(), both of which are not "empty" but refer to the current URL, so we request it again asking for image types. But if we can't see the URL, and we can't see the HTML, there's exactly zero chance that we can fix it or debug it.
Assignee: nobody → form-submission
Component: Form Manager → HTML: Form Submission
Product: Firefox → Core
QA Contact: form.manager → ian
Version: unspecified → 1.8 Branch
I'm seeing this consistently with the following;

<form method="post" action="foo">
  <img src=""/>
  ...
</form>

the form gets posted twice and is empty the second time.  If the <img src=""/> is removed from the form, everything works fine
The one in the form isn't likely to be the problem, it's the one in "foo", which tells us that after we POST to "foo" and get a page with <img src="">, which resolves to <img src="foo"> because src="" is a relative URI, we should again GET "foo" with our give-us-images Accept: header.

Anyway, without the original reporter's URL or testcase HTML, this is WFM (or maybe invalid, who can tell?): we're doing the right thing with src="", painful as it is.
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → WORKSFORME
*** Bug 333641 has been marked as a duplicate of this bug. ***
Component: HTML: Form Submission → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.