Closed Bug 318757 Opened 17 years ago Closed 17 years ago

clicking on an <a><img ismap></a> focuses the image (makes it scroll into view, changing the coordinates sent to the server in certain cases)

Categories

(Core :: Layout, defect)

1.8 Branch
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 288945

People

(Reporter: ron1872, Unassigned)

References

()

Details

(Keywords: regression, testcase)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.8) Gecko/20051111 Firefox/1.5

These are geocaching (GPS) maps of the Netherlands. Probably you should first register before entering! If you click in 'Kaart van Nederland' and look at the left side you can a link 'Niet gevonden caches'. Please click here. Point (dont't click!!) on one particular dot and look at the id in the end of the URL. Now click on the same dot. The map will jump a few hundred southwards and look at the id in the URL. At has changed a lott, while it should be the same!! The problem has been noticed by all Firefox users on this site, who updated to 1.5. With 1.0.7 we had no problems with the maps and IE also no problems. Problem reported to the www.geocaching.nl website. They checked and also reported the difference on the map. The maps and software are running now for two years without problems. This should be a bug in 1.5.


Reproducible: Always

Steps to Reproduce:
1. see information in the 'details' field.
2.
3.
Hmm, what's happening is that the image is taking focus once it's clicked on, which causes it to fully scroll into view, and causes the mouse coordinates to change. I think this is a case that the fix for bug 250858 (which was checked in on the branch) didn't handle (FindImageMap only finds "real" image maps, not <img ismap>s, apparently).

(I also couldn't find where GetUseMap is actually defined... maybe LXR is broken, it only shows one hit)
Severity: major → normal
Status: UNCONFIRMED → NEW
Component: View Source → Layout
Ever confirmed: true
OS: Windows XP → All
Product: Firefox → Core
QA Contact: view.source → layout
Hardware: PC → All
Version: unspecified → 1.8 Branch
Summary: zooming in a map will result a map a few hundred miles south → clicking on an <a><img ismap></a> focuses the image (makes it scroll into view, changing the coordinates sent to the server in certain cases)
So this isn't a problem in current trunk builds (at least not for me).
I think this would be fixed if the fix for bug 105894 got into the 1.8 branch.
Depends on: 105894
Keywords: testcase
Ah, this is in fact a duplicate of bug 288945, I see now.

*** This bug has been marked as a duplicate of 288945 ***
Status: NEW → RESOLVED
Closed: 17 years ago
No longer depends on: 105894
Resolution: --- → DUPLICATE
Marking bug 318757 as a duplicate of on earlier bug from April 2005 means that it will be solved or whatever? In the meantime it will remain as an irritating bug for us, so we have to downgrade to 1.0.7 and missing the excellent option of auto updating from the 1.5 version!
Ron, see bug 105894, it currently has blocking1.8.0.1 ?
If the question mark changes into a +, then it will mean it gets fixed in the 1.8.0.1 release (which would be the next update of Firefox1.5).
It's a pitty that the patch is still not there! Today I tried to downgrade to 1.0.7. This is impossible, I had a complete crash on FF!! Removed everything related on FF and did a new install of 1.0.7, but still no result. Only possibility is opening FF start>>Mozilla Firefox (safe mode).

Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
This bug is a duplicate, please don't reopen it. The patch has not yet been checke into any product branches, so isn't in any releases.

*** This bug has been marked as a duplicate of 288945 ***
Status: REOPENED → RESOLVED
Closed: 17 years ago17 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.