Closed Bug 318817 Opened 14 years ago Closed 13 years ago

bookmark keyword and description annotations

Categories

(Firefox :: Bookmarks & History, defect, P4)

defect

Tracking

()

RESOLVED FIXED
Firefox 3

People

(Reporter: bryner, Assigned: dietrich)

References

Details

(Whiteboard: [Fx2-parity] description work moved to bug)

Attachments

(1 file)

 
Priority: -- → P2
At the same time, make sure that they have a decent name in the UI, like "shortcuts" or something else less easily confused with tags/folders/categories. 

-> Joe Hughes, load balancing. 
Assignee: brettw → joe
I'm going to toss this back to brian for the back end. I don't think this requires much, not even anything on the api, since access can be done using the anno-svc api. Joe can wire up the fe. 

Also brian, can you store an annotation for "description" ?
Assignee: joe → bryner
Summary: implement bookmark keywords → bookmark keyword and description annotations
Target Milestone: --- → Firefox 2 alpha1
*** Bug 317836 has been marked as a duplicate of this bug. ***
Assignee: bryner → brettw
Attachment #212031 - Flags: review?(bugs)
Comment on attachment 212031 [details] [diff] [review]
Patch and importing (no creation)

r=ben@mozilla.org
Attachment #212031 - Flags: review?(bugs) → review+
First patch is on trunk and branch. We still need descriptions, so keeping open at a lower priority.
Priority: P2 → P4
Target Milestone: Firefox 2 alpha1 → Firefox 2 beta1
*** Bug 328485 has been marked as a duplicate of this bug. ***
Hmm, bookmark keywords don't seem to be working for me in a 3/2 build; the import seems to have happened fine (checked via inspecting the database), but they don't have any effect when used in the urlbar -- I just get the default i'm-feeling-lucky search.
(In reply to comment #8)
> Hmm, bookmark keywords don't seem to be working for me in a 3/2 build; the
> import seems to have happened fine (checked via inspecting the database), but
> they don't have any effect when used in the urlbar -- I just get the default
> i'm-feeling-lucky search.
> 

I've been seeing that for the past few days too.
My 20060227 FF trunk build has working keywords and working bookmark properties. Each nightly I've built since then does not have functional keywords OR bookmark properties.

Help?
Upping priority due to freshly broken shortcuts.
Priority: P4 → P1
The keywords should be working again. Still no creation UI, but they will be imported and used.
Priority: P1 → P4
Do we need to re-import our bookmarks.html (by deleting bookmarks_history.sqlite), thus *losing any bookmarks we've added since Places landed*, or were keywords imported (into: bookmarks_history.sqlite ?) but just didn't work until this bug was/is fixed?
(In reply to comment #13)
> Do we need to re-import our bookmarks.html (by deleting
> bookmarks_history.sqlite), thus *losing any bookmarks we've added since Places
> landed*, or were keywords imported (into: bookmarks_history.sqlite ?) but just
> didn't work until this bug was/is fixed?

If your profile was created before the first patch for this landed (15/02) then you will have to reimport. The recent non-workage of this merely stopped them working and they worked fine again afterwards.


(In reply to comment #14)
> they worked fine again afterwards.

If by "they" you meant "keywords", then they don't work on today's trunk nightly. Did you mean "they *import* fine?

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060306 Firefox/1.6a1
(In reply to comment #15)
> If by "they" you meant "keywords", then they don't work on today's trunk
> nightly. Did you mean "they *import* fine?

Yes I mean the keywords. They work fine for me, but they will only work if they were imported by using places for the first time from a build after the initial checkin of this.
To clarify: if your bookmarks.html had keywords and was imported since this feature landed (15 Feb) then your bookmarks_history.sqlite will have those keywords. The frontend code for using the keywords became broken, and then was fixed, but at all times they should have been imported properly. If you run with a build since I fixed the frontend (6 Mar) then they should work.
(In reply to comment #17)
> If you run
> with a build since I fixed the frontend (6 Mar) then they should work.

Confirmed. Keywords are functioning again in trunk build from 20060307 WinXP.
(In reply to comment #18)
> (In reply to comment #17)
> > If you run
> > with a build since I fixed the frontend (6 Mar) then they should work.
> 
> Confirmed. Keywords are functioning again in trunk build from 20060307 WinXP.
> 

The imported keywords are working fine on Branch (03/08), but the "Post" type keywords, which are working perfectly on Fx1.5 are not working right... the keywords along with the search terms are performing a Google Lucky Search.
> The imported keywords are working fine on Branch (03/08), but the "Post" type
> keywords, which are working perfectly on Fx1.5 are not working right...

I just filed bug 329842 for this.
(In reply to comment #1)
>like "shortcuts"
>
Thought it was a whole new feature for fanatic keyboards users, a key combination to call a certain bookmark. :D
Blocks: 329936
It'd be handy to have a column for shortcuts aka keywords. Or something nicer, since that column would be useless for history and folders. Maybe append shortcuts in parenthesis to bookmarks titles?
Target Milestone: Firefox 2 beta1 → Firefox 3 alpha2
Assignee: brettw → nobody
filed bug 372161 for the description-annotation part of this bug.
Whiteboard: [Fx2-parity] → [Fx2-parity] description work moved to bug
Blocks: 370099
No longer blocks: 329936
Depends on: 372161
Target Milestone: Firefox 3 alpha2 → Firefox 3
Assignee: nobody → dietrich
marking fixed b/c this bug's remaining issues have been spun-off (bug 329842, bug 372161) and each block bug 370099 individually.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.