places-based bookmarks blockers

VERIFIED FIXED in Firefox 3 alpha5

Status

()

Firefox
Bookmarks & History
VERIFIED FIXED
11 years ago
8 years ago

People

(Reporter: mano, Unassigned)

Tracking

({meta})

Trunk
Firefox 3 alpha5
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

tracker for bugs which block turning on places-based bookmarks on trunk.
Depends on: 364644
Depends on: 371074

Updated

11 years ago
Depends on: 363634
Depends on: 371076
Depends on: 371077
Depends on: 357316
Depends on: 365405
Depends on: 371798
Depends on: 371814

Updated

11 years ago
Depends on: 371926
Depends on: 318817
Depends on: 332965
Depends on: 329842
Depends on: 371827
Depends on: 369887
Depends on: 335512
Depends on: 373719
Depends on: 373721
Depends on: 374139

Updated

11 years ago
Depends on: 371219

Updated

11 years ago
Depends on: 375297

Comment 1

11 years ago
It looks to me like bug 374528 is a dupe of this meta. This one is the only one with all the important dependencies set, but that one is set to block bug 374945 (Fx 3 Places meta).

Updated

11 years ago
Depends on: 375417
(In reply to comment #1)
> It looks to me like bug 374528 is a dupe of this meta. This one is the only one
> with all the important dependencies set, but that one is set to block bug
> 374945 (Fx 3 Places meta).
> 

This bug is for tracking bugs that must be fixed before Places bookmarks are turned on by default. Bug 374528 is about backup/restore. How is it a dupe?

Comment 3

11 years ago
Sorry, I misinterpreted what that bug was about.
Depends on: 329281
Depends on: 375629
Depends on: 375108
Target Milestone: Firefox 3 → Firefox 3 alpha4
Depends on: 376253
Depends on: 373862
Depends on: 375665
Depends on: 376581
Depends on: 376726
Depends on: 371800

Updated

11 years ago
Depends on: 334669
No longer depends on: 376581
Depends on: 377066

Updated

10 years ago
No longer depends on: 373862
Depends on: 377500

Updated

10 years ago
No longer depends on: 334669

Updated

10 years ago
No longer depends on: 363634

Updated

10 years ago
No longer depends on: 371926
Depends on: 372161
Depends on: 378904
Depends on: 378921
Depends on: 372508
Depends on: 379211
Depends on: 379986
No longer depends on: 372161
No longer depends on: 372508
No longer depends on: 371074
No longer depends on: 369253
Target Milestone: Firefox 3 alpha4 → Firefox 3 alpha5
Depends on: 380317

Updated

10 years ago
No longer depends on: 329842

Updated

10 years ago
Depends on: 380246
No longer depends on: 380246
Depends on: 329842
Depends on: 380689
Created attachment 264940 [details] [diff] [review]
turn it on
Attachment #264940 - Flags: review?(mconnor)
No longer depends on: 337855
Depends on: 380011
Depends on: 380979
Depends on: 380801
Depends on: 380990
Depends on: 381042
Blocks: 380997
Blocks: 380996
nsNavBookmarks::InitDefaults is behind the MOZ_PLACES_BOOKMARKS define, so doesn't get called when sidegrading from non-bookmarks to bookmarks.

when turning on bookmarks, we need to bump the schema version, in order to trigger a full re-initialization of the bookmarks tables.
Depends on: 380999
Depends on: 381129
Depends on: 381145
Depends on: 381052
Depends on: 381208
we realized that we don't need to bump the schema (even though I did for bug #371827)

in nsBrowserGlue.js, we have code that checks the browser.places.importBookmarksHTML pref.  if true, we'll force a migration.

that pref defaults to true, and is only set to false after the import succeeds (in nsBrowserGlue.js)

note, that code in nsBrowserGlue.js is behind #ifdef MOZ_PLACES_BOOKMARKS, running the trunk the first time will migrate you, even if the schema version matched.
Comment on attachment 264940 [details] [diff] [review]
turn it on

let's do it
Attachment #264940 - Flags: review?(mconnor) → review+
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Updated

10 years ago
Depends on: 331307

Updated

10 years ago
Depends on: 381280
No longer depends on: 381280

Updated

10 years ago
Depends on: 381405
No longer depends on: 381405

Updated

10 years ago
Depends on: 385498
No longer depends on: 385498
Marking it as verified to get off QA resolved plate and because we're using Places bookmarks now.
Status: RESOLVED → VERIFIED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.