Closed Bug 318935 Opened 14 years ago Closed 14 years ago

Add support for List Headers

Categories

(Thunderbird :: Message Compose Window, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 45715

People

(Reporter: mrsoto, Assigned: mscott)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

Hello,

One recurrent subject posted in lists is how to change list behavior to 
allow Thunderbird to works with lists. The mountain remain in the same 
place so Mahoma should move.

According to the RFC 2369 (http://www.ietf.org/rfc/rfc2369.txt) list 
servers will send header that identify the list, here examples from 
Debian lists:

X-Mailing-List: <debian-user-spanish@lists.debian.org> archive/latest/123444
X-Loop: debian-user-spanish@lists.debian.org
List-Id: <debian-user-spanish.lists.debian.org>
List-Post: <mailto:debian-user-spanish@lists.debian.org>
List-Help: 
<mailto:debian-user-spanish-request@lists.debian.org?subject=help>
List-Subscribe: 
<mailto:debian-user-spanish-request@lists.debian.org?subject=subscribe>
List-Unsubscribe: 
<mailto:debian-user-spanish-request@lists.debian.org?subject=unsubscribe>


The problem exists because Thunderbird does not recognize this kind of 
headers and all reply goes directly to senders.

I believe and others too that Thunderbird should:
	a) reply to list or new reply-to-list button
	b) support digest mails and allow to reply individual mails
	c) allow html only
	d) assign "to:" according to the list. I suppose "X-Apparently-To:" should be.

It is impossible to customize or replace headers using filters which may be an option until Thunderbird support Lists

Later,
Manuel Soto

Reproducible: Always

Steps to Reproduce:
1.reply to a list


Actual Results:  
The message is composed using: account's mail and to message originator not to list


Expected Results:  
Message composed w/:
from: X-Apparently-To. Account email if missing
to: list-post
see bug 223129, but only mentions unsubscribe/help functions

reply-to-list is bug 45715, but doesn't rely on these headers (although they would make it easier to detect a list).

*** This bug has been marked as a duplicate of 45715 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.