[TEXT] first letter style looks wrong

RESOLVED WORKSFORME

Status

()

Core
Layout
P3
normal
RESOLVED WORKSFORME
18 years ago
17 years ago

People

(Reporter: Sander van Rijnswou, Assigned: Shanjian Li)

Tracking

Trunk
mozilla1.0
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Select Debug->Viewer Demos->#0 basic styles

Looking at  'Pseudo-Elements test', the second paragraph, the 'F' of
'First letter style is ..' appear about 2 cm to low.

Its probably the <P id=letter>

Comment 1

18 years ago
-> style system
Assignee: rickg → pierre
Component: HTML Element → Style System
QA Contact: petersen → chrisd

Updated

18 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Solaris → All
Hardware: Sun → All

Comment 2

18 years ago
It's not 2cm too low: the style says "float: left" which means that the top of 
the letter should be aligned to the top of the first line.  However I agree that 
it is still displayed a little bit too low, especially on Windows but this is 
covered in bug 23844. See my testcase there.


*** This bug has been marked as a duplicate of 23844 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 3

18 years ago
Verified dup of #23844
Status: RESOLVED → VERIFIED

Comment 4

18 years ago
My mistake: given the screen snapshot sent by the reporter, this bug should nt 
have been closed as dup. Bug 23844 describes a problem where the alignment of the 
first letter isn't correct. This bug shows that the first letter has a wrong 
style.

The screen snaphot can be found at:
  http://bugzilla.mozilla.org/showattachment.cgi?attach_id=6785

Below are some comments about the present problem that Erik and myself wrongfully 
put in bug 23844:


------- Additional Comments From pierre@netscape.com 2000-03-22 05:50 -------

Erik, it looks like we do the measurement correctly but we display the letter 
using the default font and size. Weird...



------- Additional Comments From erik@netscape.com 2000-03-22 13:07 -------

Hi Pierre, thanks for looking into it. It sounds like a problem in the layout
engine. I've noticed that Kipp kept a number of different fonts lying around,
one "normal" one, one for small caps, etc. So maybe he's using the right font
for measurement, and the wrong font for drawing?

Re-assigning to Pierre for now. Please re-assign to somebody who knows that part
of the layout engine (or currently owns it: SteveC?).

Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---

Comment 5

18 years ago
Reassigned to buster. CCd erik & myself.
Assignee: pierre → buster
Status: REOPENED → NEW
Component: Style System → Layout

Comment 6

18 years ago
Note: the same reporter filed another bug related to font metrics on Unix. See 
bug 32846.

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → M18

Comment 7

18 years ago
redistributing bugs across future milestones, sorry for the spam
Target Milestone: M18 → M19

Comment 8

18 years ago
Erik: this looks like a [TEXT] bug.  I knew if I left it lying around long 
enough, it's find it's way back to you :)
If I've misunderstood what's going on here, please assign it back to me.
Assignee: buster → erik
Status: ASSIGNED → NEW
Summary: first letter style looks wrong → [TEXT] first letter style looks wrong

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 9

18 years ago
Mark it as M24 for now.
Target Milestone: M19 → M24

Comment 10

18 years ago
Is this caused by 27164?
Netscape's standard compliance QA team reorganised itself once again, so taking 
remaining non-tables style bugs. Sorry about the spam. I tried to get this done 
directly at the database level, but apparently that is "not easy because of the 
shadow db", "plus it screws up the audit trail", so no can do...
QA Contact: chrisd → ian

Comment 12

17 years ago
I think this one is important. A lot of magazine use these kind of style in the 
beginning of the article. If we want to have a good CSS support, we should 
implement this one right.
Mark this as P2 and moz1.0
Target Milestone: --- → mozilla1.0

Comment 13

17 years ago
erik resign. reassign all his bug to ftang for now.
Assignee: erik → ftang
Status: ASSIGNED → NEW

Comment 14

17 years ago
shanjian- can you help this one ?
Assignee: ftang → shanjian
(Assignee)

Comment 15

17 years ago
I could not see any font problem in recent build. The alignment problem is 
still there (21616). I will track that one.  
Status: NEW → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.