If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Fix various printpreview issues when scaling / changing orientation

RESOLVED FIXED

Status

()

Toolkit
Printing
RESOLVED FIXED
12 years ago
11 years ago

People

(Reporter: Ian Neal, Assigned: Ian Neal)

Tracking

(Blocks: 1 bug, {fixed1.8.1})

Trunk
fixed1.8.1
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

12 years ago
Whilst working on bug 311028 I spotted the following issues:
* Unnecessary redraws eg clicking on Portrait twice
* Page numbers not being reset when scaling / changing orientation
* Page total not being recalculated when scaling / changing orientation
(Assignee)

Comment 1

12 years ago
Created attachment 206550 [details] [diff] [review]
Some simple fixes patch v0.1 (Checked in trunk & 1.8 branch)

Fixes the issues mentioned above
Assignee: nobody → iann_bugzilla
Status: NEW → ASSIGNED
Attachment #206550 - Flags: second-review?
Attachment #206550 - Flags: first-review?(mscott)
(Assignee)

Updated

12 years ago
Attachment #206550 - Flags: second-review? → second-review?(mconnor)

Updated

12 years ago
Attachment #206550 - Flags: first-review?(mscott) → first-review+

Updated

12 years ago
Attachment #206550 - Flags: second-review?(mconnor) → second-review+
Whiteboard: [checkin needed]
(Assignee)

Comment 2

12 years ago
Comment on attachment 206550 [details] [diff] [review]
Some simple fixes patch v0.1 (Checked in trunk & 1.8 branch)

Checking in (trunk)
printPreviewBindings.xml;
new revision: 1.24; previous revision: 1.23
done
Attachment #206550 - Attachment description: Some simple fixes patch v0.1 → Some simple fixes patch v0.1 (Checked in trunk)
(Assignee)

Updated

12 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Whiteboard: [checkin needed]
Blocks: 205783
*** Bug 331584 has been marked as a duplicate of this bug. ***

Comment 4

12 years ago
*** Bug 332560 has been marked as a duplicate of this bug. ***
Ian: can you ask for approval and land this on the 1.8 branch? I think it'd be a good patch to get into Firefox 2.
(Assignee)

Comment 6

11 years ago
Comment on attachment 206550 [details] [diff] [review]
Some simple fixes patch v0.1 (Checked in trunk & 1.8 branch)

Should be a good fix for Fx 2.0
Attachment #206550 - Flags: approval-branch-1.8.1?(mconnor)

Updated

11 years ago
Attachment #206550 - Flags: approval-branch-1.8.1?(mconnor) → approval-branch-1.8.1+
Whiteboard: [checkin needed (1.8 branch)]
(Assignee)

Comment 7

11 years ago
Comment on attachment 206550 [details] [diff] [review]
Some simple fixes patch v0.1 (Checked in trunk & 1.8 branch)

Checking in (1.8 branch)
printPreviewBindings.xml;
new revision: 1.21.2.3; previous revision: 1.21.2.2
done
Attachment #206550 - Attachment description: Some simple fixes patch v0.1 (Checked in trunk) → Some simple fixes patch v0.1 (Checked in trunk & 1.8 branch)
(Assignee)

Updated

11 years ago
Keywords: fixed1.8.1
Whiteboard: [checkin needed (1.8 branch)]
*** Bug 347122 has been marked as a duplicate of this bug. ***
*** Bug 345442 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.