Changing print preview scale/orientation doesn't change current page number/total number of pages

RESOLVED FIXED

Status

()

--
minor
RESOLVED FIXED
16 years ago
a year ago

People

(Reporter: xavier.loup, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.8b5 -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.4b) Gecko/20030507

In print preview mode, the text field containing the current page number is not
updated if you change the scale of the preview.

Reproducible: Always

Steps to Reproduce:
1. Open a big web page (for example: freshmeat.net)
2. Go in print preview mode
3. Choose a scale of 100 %
4. Go to the last page of the print preview (page 21 for me)
5. Change the scale to 50%

Actual Results:  
Current page number is 21, but there are only 8 pages.
Previous and next page buttons don't work.

Expected Results:  
Current page number should be 1.
Previous and next page buttons should work.

This bug can be reproduced in Mozilla FireBird.
(Reporter)

Comment 1

15 years ago
This bug can be easily reproduced with mozilla 1.4 (windows only).

Comment 2

15 years ago
Reproduced on build 2004030409
Mozilla/5.0 (Windows; U; Win98; en-US; rv:) Gecko/20040304

Confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

15 years ago
*** Bug 228823 has been marked as a duplicate of this bug. ***

Comment 4

15 years ago
*** Bug 251554 has been marked as a duplicate of this bug. ***
Confirming with the latest stable release of Firefox, Mozilla/5.0 (Windows; U;
Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2
The total number of pages on the toolbar also remains the same, as informed on
dupe Bug 251554.

Comment 7

14 years ago
*** Bug 262133 has been marked as a duplicate of this bug. ***

Comment 8

14 years ago
According to duplicate bug 262133 this also applies to Linux.
Severity: normal → minor
OS: Windows NT → All
Hardware: PC → All
Summary: Changing the scale of the print preview doesn't change the current page number → Changing print preview scale doesn't change current page number/total number of pages
*** Bug 267775 has been marked as a duplicate of this bug. ***
*** Bug 284541 has been marked as a duplicate of this bug. ***

Comment 11

14 years ago
Confirming with the latest stable release of Firefox,
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225
Firefox/1.0.1
*** Bug 287549 has been marked as a duplicate of this bug. ***
Summary: Changing print preview scale doesn't change current page number/total number of pages → Changing print preview scale/orientation doesn't change current page number/total number of pages
*** Bug 284236 has been marked as a duplicate of this bug. ***
*** Bug 302282 has been marked as a duplicate of this bug. ***

Comment 15

13 years ago
*** Bug 303439 has been marked as a duplicate of this bug. ***

Comment 16

13 years ago
Confirming on Firefox 1.0.7

Comment 17

13 years ago
confirmed on 1.5b1 and 1.8 branch from today. This is pretty broken
functionality.  The "page setup" allows you to change these settings correctly.
 At the very least, the scale and orientation  should be removed from the
toolbar (until it can be fixed) if it cannot be fixed for 1.5 release.

Flags: blocking1.8b5?
Too late to get to what this bug is actually about, there's a separate bug on
the scaling/orientation bits.
Flags: blocking1.8b5? → blocking1.8b5-

Comment 19

13 years ago
Dup of bug 184537?
*** Bug 312647 has been marked as a duplicate of this bug. ***
*** Bug 312854 has been marked as a duplicate of this bug. ***
QA Contact: sujay

Comment 22

13 years ago
Probably dupe, marking such.

*** This bug has been marked as a duplicate of 184537 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
*** Bug 184537 has been marked as a duplicate of this bug. ***
*** Bug 275795 has been marked as a duplicate of this bug. ***
*** Bug 255926 has been marked as a duplicate of this bug. ***
*** Bug 315397 has been marked as a duplicate of this bug. ***
Status: REOPENED → NEW
*** Bug 317976 has been marked as a duplicate of this bug. ***

Comment 28

13 years ago
By marking bug 184537 a duplicate of this one I belive you have lost some of the details of this defect.

This bug (205783) says that if you change the print preview scale or orientation, then the current page number does not change.

bug 184537 says that, if you actively scroll up or down while in print preview view, the 'current page' number does not update to reflect the page actually in view.

These are different (but likely related) bugs.

Related to bug 205783 I note that, in print preview, the total page count does not change if you chagne the print preview scale or page orientation ... didn't see a bug for this, but it must be in there somewere.

Perhaps this calls for a metabug?
This is rather a case of bug 184537 being misunderstood, then, since the bugs duped to it really should have been duped here. Since you're the reporter I think you're in the best position to know what's right :). I'll reopen bug 184537, but mark it as an enhancement request. No "meta bug" is required, you can use queries for that.

To be clear:
This bug:   Page count not updated when changing settings
bug 184537: Current page number not updated when scrolling (and adjusting settings)

Comment 30

13 years ago
Confirming this bug still in latest release: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

Current and total page numbers need to be refreshed after a scale or orientation change.

Comment 31

13 years ago
WFM.

Windows XP SP1
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060201 Firefox/1.6a1

Comment 33

13 years ago
Yes, this does seem to be fixed on the trunk (given the description in comment 29). Very nice!
-> FIXED by bug 321153.
Status: NEW → RESOLVED
Last Resolved: 13 years ago13 years ago
Depends on: 321153
Resolution: --- → FIXED
*** Bug 340533 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.