Closed Bug 322522 Opened 16 years ago Closed 9 years ago

Lightning: Automatically deliver nightly updates

Categories

(Calendar :: Build Config, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: BesTo, Unassigned)

References

Details

(Keywords: meta)

Hey.

Seems I cant stay on top with lightning-development via extension-manager.
It seems there will never shown new nightly-builds of lightning in the ext-mgr.
Can somebody change this ???
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: cant stay on top with lightning via extension-mgr → need update channels (nightly & versioned) for lightning
Depends on: 348066
We used the EM's upgrade functionality to migrate many Lightning 0.1 users to 0.3. Therefore IMO the "versioned" part of this bug is complete.

Since Lightning is an extension, not a standalone app, "update channels" don't really apply. We could again use the EM's upgrade functionality, but that would require us to create a new update.rdf file for each nightly update to Lightning. 

Perhaps this could be done separately from the "official Lightning", and you'd download the "nightly Lightning" version, which would ping ftp.m.o/.../lightning/nightly/latest-*/update.rdf for updates (instead of where the official one does.)

I'm not sure I like the idea of forking development like that, but it's one way to get this functionality by leveraging the stuff we already have.
Severity: normal → enhancement
Summary: need update channels (nightly & versioned) for lightning → Lightning: Automatically deliver nightly updates
Duplicate of this bug: 398780
You can also use the Lightning Nightly Updater extension for this.
<https://addons.mozilla.org/thunderbird/addon/4623>
You could also "Make Lightning a "real" extension" as in Bug 398780 – , or better still, merge the Lightning code right into Thunderbird, but this would be the next best thing.
(In reply to comment #4)
> You could also "Make Lightning a "real" extension" as in Bug 398780

Lightning is a "real" extension in all aspects. Every release is available via the automatic extension update system is Thunderbird. If you don't believe this just install Lightning 0.3.1 and check for updates.

But in contrast to other extension you can download a nightly build for testing on your own risk. Most other extension don't offer this and you see only the released versions. It seems to me that you mixed up this.
Duplicate of this bug: 414073
(In reply to comment #5)
> (In reply to comment #4)
> > You could also "Make Lightning a "real" extension" as in Bug 398780
> 
> Lightning is a "real" extension in all aspects. Every release is available via
> the automatic extension update system is Thunderbird. If you don't believe this
> just install Lightning 0.3.1 and check for updates.
> 
> But in contrast to other extension you can download a nightly build for testing
> on your own risk. Most other extension don't offer this and you see only the
> released versions. It seems to me that you mixed up this.


I guess you are right. Better still would be to eliminate it as an extension entirely, and make it part of the core code.

Component: Lightning Only → Build Config
QA Contact: lightning → build
(In reply to comment #3)
> You can also use the Lightning Nightly Updater extension for this.
> <https://addons.mozilla.org/thunderbird/addon/4623>

No longer working for latest Miramar and corresponding Nightly.
Boy, I forgot all about this bug. In this day and age, can't this functionality just be built in once and for all? For that matter, the entire Lightning functionality should just be integrated into Thunderbird.  There is a bug for that:
Bug 401779 - Integrate Lightning Into Thunderbird by Default and Ship Thunderbird with Lightning Enabled
I think we should give this bug another try. It shouldn't be *that* hard, just a matter of correct automation. Here's the plan:


* Provide an update.php script somewhere (live.formerly-known-as-mozillamessaging.com ?)
* Give this script all needed parameters:
  - OS, ABI, update channel (=nightly), build id of current build

* Generate an update.rdf that only shows updates if a newer nightly is available.

* Make buildbots provide information about completed nightly builds to this script, so it can update its version info, update hash, etc.


gozer, any ideas on where we could host this?
Wouldn't it be enough to take the _existing_ Lightning Nightly Updater add-on and make it up-to-date so that it knows the current Thunderbird/Seamonkey versions and corresponding branches / ftp server paths of Lightning?
Yes, that would be swell and a quick fix, unfortunately I can't reach the author. Using the addons manager would be much better integrated and doesn't require an extra extension.
Especially for those of you whom I just emailed, some more information about update hashes:

We don't need an update hash if the referenced location is also a https server. I'm not sure all mozilla mirrors are required to support https, and #build also thinks not.

If they don't need to support https then its too bad, as them doing so would make things so much easier.
Ok, I filed some dependent bugs to get this rolling. Hope it helps!
Keywords: meta
(Mostly note to self)


Passing these parameters gets us everything we will ever need, this is what AMO gets:

reqVersion=%REQ_VERSION%&id=%ITEM_ID%&version=%ITEM_VERSION%&maxAppVersion=%ITEM_MAXAPPVERSION%&status=%ITEM_STATUS%&appID=&appVersion=%APP_VERSION%&appOS=&appABI=&locale=&currentAppVersion=%CURRENT_APP_VERSION%&updateType=%UPDATE_TYPE%&compatMode=%COMPATIBILITY_MODE%

This is the minimum set needed:

appABI=%APP_ABI%&appOS=%APP_OS%&locale=%APP_LOCALE%&appVersion=%APP_VERSION%&appID=%APP_ID%
We will also need to pass the buildID if we don't want to provide update every time they are checked (even if its already at the latest version)
(In reply to Philipp Kewisch [:Fallen] from comment #13)
> We don't need an update hash if the referenced location is also a https
> server. I'm not sure all mozilla mirrors are required to support https, and
> #build also thinks not.

Update here: ftp.mozilla.org should always be https capable, while releases.mozilla.org will never be. As long as we only serve nightly builds, we should be fine.
Duplicate of this bug: 458255
Where can this get marked "high priority", to go along with DMosedale's request for that on https://bugzilla.mozilla.org/show_bug.cgi?id=458255#c1  ?

Thank you.
Everything is set up of nightly updates, waiting on tomorrow's nightlys to see if it works.
Blocks: 401779
Blocks: 516026
This is FIXED, nightly updates are now working.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
This is great! Unfortunately, we nightly testers/users have no way of verifying if it's working because there is no way to see the exact version of Lightning (i.e. the build-date). All we see (in the Add-on Manager / More) is "Lightning 1.8a1" - No date! Perhaps the nightly builds should show a more detailed UA...
(In reply to Philipp Kewisch [:Fallen] from comment #21)
> This is FIXED, nightly updates are now working.

(In reply to Peter Lairo from comment #22)
> This is great! Unfortunately, we nightly testers/users have no way of
> verifying if it's working because there is no way to see the exact version
> of Lightning (i.e. the build-date). All we see (in the Add-on Manager /
> More) is "Lightning 1.8a1" - No date! Perhaps the nightly builds should show
> a more detailed UA...

I can no longer test Beta builds, because I do need to have this working. If Lightning were integrated into the email client, even if optional with checkbox at install time, it would be FAR easier to work with, and there would be no need to check what synchronizes and what doesn't. I use Thunderbird 19 or 20 at home, where I don't need a calendar, but cannot do this on a production work machine. It is too bad, as this would otherwise be a good test-bed for Mozilla development. I am sure there are hundreds, if not thousands or maybe even tens of thousands others in the same boat.
You need to log in before you can comment on or make changes to this bug.