"edit as new" makes message plain text if mail didn't contain richtext

RESOLVED DUPLICATE of bug 78794

Status

RESOLVED DUPLICATE of bug 78794
13 years ago
13 years ago

People

(Reporter: emmanuel.touzery, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

When you click "edit as new" on a mail that didn't use HTML controls (bold, italics, fonts, pasted images etc), you get a "plain text" compose window, that doesn't allow you to enter HTML. If the mail on which you clicked "edit as new" did contain HTML controls, you get a normal, HTML-enabled compose window.

I would like that "edit as new" doesn't rely on the contents of the mail to make the compose window richtext/plaintext but use the same rules than when you click "new mail" in the application (i don't know those rules).

Reproducible: Always

Steps to Reproduce:
1. compose a mail. the mail compose window has all the HTML controls (bold, italics, fonts etc). just type normal text, don't use HTML elements (don't make text bold, italic, don't change the font etc: just type plain text).
2. send the mail. view source in the sent mail shows that since plain text and HTML mail were the same, thunderbird "optimized" and only sent the plain text version. smart.
3. right-click "edit as new" on that mail. you get the mail compose window to write a "plain text" mail. you don't have any HTML control (bold, italics). the text is written in a fixed font.



Expected Results:  
thunderbird should allow the user to use richtext controls when editing the mail as new, even if the mail to edit didn't use such controls.

Bug present on thunderbird 1.5

Comment 1

13 years ago
See also bug 130508.

*** This bug has been marked as a duplicate of 78794 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.