Closed Bug 323183 Opened 14 years ago Closed 14 years ago

Make Lightning use updated sunbird publish code

Categories

(Calendar :: Lightning Only, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: ssitter, Assigned: ssitter)

References

Details

Attachments

(1 file)

After some discussion on irc it seem to be the best solution to make Lightning use the updated Sunbird publish code. That code has been updated for Sunbird 0.3a1 and already gone throught testing with that version.

Depends on bug 323085 as this code uses the ics exporter.
Use the sunbird publish code in lightning. Did'n known that adding import-export to the make file is all I need to make them useable.
Assignee: nobody → ssitter
Status: NEW → ASSIGNED
Attachment #208384 - Flags: first-review?(jminta)
No longer depends on: 323085
Comment on attachment 208384 [details] [diff] [review]
use sunbird publish code

I like it! r=jminta

1.) I'm fairly certain I saw a bug about the Sunbird dialog not remembering what addresses are put into it.  Please either track that down or file it, and mark it as a lightning regression.

2.) Some of this is from my calConnect patch, and I don't like reviewing my own code.  Asking for a second review from dmose.
Attachment #208384 - Flags: second-review?(dmose)
Attachment #208384 - Flags: first-review?(jminta)
Attachment #208384 - Flags: first-review+
(In reply to comment #2)
> 1.) I'm fairly certain I saw a bug about the Sunbird dialog not remembering
> what addresses are put into it.  Please either track that down or file it, and
> mark it as a lightning regression.

Bug 323180, I'll work on it next.
Comment on attachment 208384 [details] [diff] [review]
use sunbird publish code

In general, the fix looks fine.  But at a file level, I think it's happening in the wrong place.  As I understand it, the reason the publish dialog was forked at all was just as a way to start the process of moving it out of the mess that is calendar/resources/content  into the new, more organized world of calendar calendar/base/content.  So my feeling is that whatever patches landed in the resources version of that file should be merged into the content version of that file.  Then Sunbird should switch to the content version, and the resources version should be removed.  But jminta and mvl might disagree with me here...
Attachment #208384 - Flags: second-review?(dmose) → second-review-
(In reply to comment #4)
> But jminta and mvl might disagree with me
> here...
> 
Yeah... At this point, the base/ version is substantially behind the resources/ version.  We can move the files in cvs around (from resources to base), but the code in the resources version requires much less work (and has received much more testing) than the base code.
My suggestion: Make Lightning use the code from resources/ to make it work. Afterwards use Bug 305526 to move/merge the code to the base/ directory.
Comment on attachment 208384 [details] [diff] [review]
use sunbird publish code

OK, I'm convinced.  r=dmose, but please file another bug to move the file at some later date.
Attachment #208384 - Flags: second-review- → second-review+
There is already Bug 305526 filed about moving the publish code to base/ directory.

jminta: Would you check in the patch please?
patch checked in.  great work stefan!
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.