Combobox on Sony web site doesn't work

VERIFIED DUPLICATE of bug 32198

Status

P1
normal
VERIFIED DUPLICATE of bug 32198
19 years ago
4 years ago

People

(Reporter: phil, Assigned: bc)

Tracking

Details

(URL)

Attachments

(5 attachments)

(Reporter)

Description

19 years ago
Using 2000-03-17-16 build from beta1 branch

Go to http://www.sony.com
There are two comboboxes on the page
Click on the Quick Link combobox
Nothing happens
Works fine in 4.72

Not sure if "event handling" is the right component for this. cc'ing rickg to 
help assign to the right person.

Comment 1

19 years ago
The page uses lots of layers which it activates and deactivates.  Since it's not
DOM compliant, a lot of things get broken. I suspect that there's a DIV with
visibility: hidden on top of that combobox.  Bug 29057 and bug 31340 may be
related.

Comment 2

19 years ago
Okay.  Well as far as I can tell the event handling here is correct.  The 
problem is in the layout.  I'm going to attach a couple of test cases that will 
illustrate my point.

The first is a reduced test case showing the problem.

The second is the same test case but with the transparent table cells colored 
red which shows that they're being painted on top of the non-working form 
elements.

Comment 3

19 years ago
Created attachment 10023 [details]
Test case showing the problem

Comment 4

19 years ago
Created attachment 10024 [details]
Test case with red table backgrounds

Comment 5

19 years ago
Reassigning out of event handling.
Assignee: joki → clayton
Component: Event Handling → Layout
QA Contact: janc → petersen

Comment 6

19 years ago
Taking guess at owner, trying buster.
Assignee: clayton → buster

Comment 7

19 years ago
I won't have much time to look at this before my sabattical, so assigning to 
rods for further investigation.  Rod, if there's anything I can do to help you 
dig into this, just let me know.
Assignee: buster → rods

Comment 8

19 years ago
Created attachment 10065 [details]
sony test case

Comment 9

19 years ago
Created attachment 10067 [details]
styles_orange0.css needed for attachment

Comment 10

19 years ago
Created attachment 10068 [details]
reduced way down

Comment 11

19 years ago
sony's html is wrong. each combobox is being partially or fully covered by the 
div that follows it. The div is taller than the combobox and covers it. The div 
is correctly getting the events. If sony were to place the divs before the 
comboboxes it would work alright.
Assignee: rods → ekrock
(Reporter)

Comment 12

19 years ago
Ok, but it works fine in IE5 and Nav4.
Keywords: 4xp
Accepting M18 to evangelize Sony. I'm assuming that we don't have the resources 
to consider implementing a quirk for this--nor do I see evidence that this would 
be widespread enough to justify a quirk.
Status: NEW → ASSIGNED
Target Milestone: --- → M18

Comment 14

19 years ago
*** Bug 54687 has been marked as a duplicate of this bug. ***

Comment 15

19 years ago
reassigning to me/evangelism because i suspect Eric is overloaded...
clearing cc's as a courtesy to reduce spam.
Assignee: ekrock → blakeross
Status: ASSIGNED → NEW
Component: Layout → Evangelism
QA Contact: petersen → zach

Comment 16

18 years ago
-> evangelism@telocity.com for my evangelism bugs.

removing the now-depreciated evangelism-related keywords.

setting platform to All.
Assignee: blakeross → evangelism
Hardware: PC → All

Comment 17

18 years ago
*** Bug 59439 has been marked as a duplicate of this bug. ***
*** Bug 63464 has been marked as a duplicate of this bug. ***
*** Bug 63710 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Target Milestone: M18 → ---

Comment 20

18 years ago
Reassigning evangelism bugs to bclary@netscape.com.
Assignee: evangelism → bclary

Comment 21

18 years ago
*** Bug 82548 has been marked as a duplicate of this bug. ***

Comment 22

18 years ago
*** Bug 82627 has been marked as a duplicate of this bug. ***

Comment 23

18 years ago
*** Bug 84902 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Blocks: 85276
(Assignee)

Comment 24

18 years ago

*** This bug has been marked as a duplicate of 32198 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Priority: P3 → P1
Resolution: --- → DUPLICATE
verified.
Status: RESOLVED → VERIFIED
(Assignee)

Comment 26

18 years ago
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.