pulldown's can jump / get stuck when mouse and keyboard are used together

VERIFIED DUPLICATE of bug 28477

Status

()

P3
minor
VERIFIED DUPLICATE of bug 28477
19 years ago
10 years ago

People

(Reporter: jmd, Assigned: mikepinkerton)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows 98)
BuildID:    2000031715

pulldown's can jump / get stuck when mouse and keyboard are used together

Reproducible: Always
Steps to Reproduce:
With the default bookmarks menu...
1. With the mouse, click the "Bookmarks" pulldown (eaither)
2. Move the mouse down to, lets say, "Directories"
3. Now, keep the cursor on Directories, and let go of the mouse.
4. Press left arrow key to close the auto-expanded Directories menu.
5. Press down arrow to go to a differant menu.
6. On, say, "Travel and Leisure", hit right arrow to expand.
7. Now, move mouse slightly.

Actual Results:  There are a few problems these action cause. First, if you 
used the blue bookmarks menu, the arrow on the Directories line is missing, 
because mozilla thinks it's currently selected because of the mouse.
This is a very trivial cosmetic problem.

The other (only-somewhat-trivial) problem is the jumping effect the highlight 
bar does, first under the cursor, then back to where the keyboard moved it, 
even though the menu being shown is the one the mouse is pointing to... looks 
very goofy.

The effect is usually more severe when done in the blue bookmark menu. Often, 
an expanded menu will get stuck on top of other ones...I've had three open at 
once, all layered.

No other win32 apps i tested behaved this way.


Additional Info:
The missing arrow thing might be due to the fact that this system has an ATI 
Rage 128, and there are quite a few display problems known. It doesn't look 
like a driver issue though.

Somewhat related is bug 26361 - Menus are not "attached" to the window / window 
jumps.


Severity: Minor

Comment 1

19 years ago
XPToolkit Menus
Assignee: cbegle → pinkerton
Component: Browser-General → XP Toolkit/Widgets: Menus
QA Contact: asadotzler → sairuh
(Assignee)

Comment 2

19 years ago


*** This bug has been marked as a duplicate of 28477 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
verif.
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: bugzilla → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.