Closed Bug 323911 Opened 14 years ago Closed 5 years ago

should not play sound when new feed items arrive

Categories

(MailNews Core :: Feed Reader, defect)

defect
Not set

Tracking

(thunderbird36 fixed)

RESOLVED FIXED
Thunderbird 36.0
Tracking Status
thunderbird36 --- fixed

People

(Reporter: Marsti, Assigned: alta88)

References

(Depends on 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8) Gecko/20051111 Firefox/1.5

Since TB 1.5 the notify sound is even played when a new news (RSS feed) comes in. This is not good because that isn't very interesting. In addition, setting news.notify.on to false doesn't work... the sound is played nevertheless. Playing notify sound on RSS news should be switchable (on/off).

Reproducible: Always

Steps to Reproduce:
1. Subscribe a RSS news
2. Turn notify sound on
3. Wait til a new RSS news comes in

Actual Results:  
You hear the sound which should (and was in TB 1.0x) played when a new MAIL comes in

Expected Results:  
The news notify sound setting should be switchable/working.
Version: unspecified → 1.5
Are you getting just the sound, or do you also get an alert (slide-up window) 
and/or tray icon?

Confirming based on similar report at bug 261841 comment 10.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Actually, there is already a bug about this. 

*** This bug has been marked as a duplicate of 311640 ***
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
(In reply to comment #2 [Magnus Melin])
> Actually, there is already a bug about this. 

That's not really the same thing.  RSS doesn't curently "notify" like mail; it only plays the sound, and that was a new behavior in 1.5.  That other bug is about customizing the notification sound, but it's not about fixing the problem that arose from this new 'feature'.

I've just turned on the notification sound on my system to see if this problem is still occurring, but I only have a few low-activity feeds subscribed.  Assuming it does, I recommend reopening this bug.
Ok, reopening (though a lot of the dupes from bug 311640 should probably want only this).

Btw, the news.notify.on is not used for anything anymore.
http://lxr.mozilla.org/seamonkey/search?string=news.notify.on
Status: RESOLVED → REOPENED
OS: Windows XP → All
Hardware: PC → All
Resolution: DUPLICATE → ---
Summary: New news (RSS) = Notify sound played → should not play sound when new feed items arrive
Version: 1.5 → 2.0
*** Bug 354072 has been marked as a duplicate of this bug. ***
With TB 3a1-1018, this is working correctly for me: new RSS items arrive without triggering the sound.  I was getting the sound recently with a 2b1 build (1014 or 1018, I think), so whatever fixed the trunk hasn't been ported back to the branch.
*** Bug 323261 has been marked as a duplicate of this bug. ***
(In reply to comment #6)
> With TB 3a1-1018, this is working correctly for me: new RSS items arrive
> without triggering the sound.

No longer true; I just experience sound played for arriving feed item with 
TB 3a1-1206, Win2K.
Still occurs for the latest 2.0.0.16 / Shredder trunk nightlies?
Assignee: mscott → nobody
Status: REOPENED → NEW
Whiteboard: closeme 2008-08-21
Yes.
Blocks: 286761
Whiteboard: closeme 2008-08-21
Version: 2.0 → Trunk
Component: RSS → Feed Reader
Product: Thunderbird → MailNews Core
Depends on: 311640
Flags: wanted-thunderbird3?
Just to keep this discussion alive ...
... are there any plans to improve this (wrong) TB behaviour in the near future ?

Or are there any workarounds to turn off sound for new RSS feeds ?

Sorry for annoying you, but the "new e-mail sound" for RSS articles drives me crazy :-( I never know whether I got an e-mail or just a RSS article :-(
Attached patch biffsound.patch (obsolete) — Splinter Review
yes, this is annoying.  simple patch to add a mail.biff.play_sound_feed pref (default false) and check it if server type is rss.

i don't think UI is needed here, as a more flexible/useful approach for tuning sounds on feed biff would be part of a solution in bug 311640 or rather bug 261841, which would be on a per feed url, not just folder, basis.

one could argue the tonequilla solution of a play sound action on a filter match is even more better.
Assignee: nobody → alta88
Attachment #8463651 - Flags: review?(mkmelin+mozilla)
Comment on attachment 8463651 [details] [diff] [review]
biffsound.patch

Review of attachment 8463651 [details] [diff] [review]:
-----------------------------------------------------------------

::: mailnews/mailnews.js
@@ +621,5 @@
>  pref("mail.biff.alert.preview_length", 40);
>  
>  pref("mail.biff.play_sound", true);
> +// For feed account serverType=rss sound on biff.
> +pref("mail.biff.play_sound_feed", false);

Could we make this mail.feeds.play_sound to align with mail.chat.play_sound
Attachment #8463651 - Flags: review?(mkmelin+mozilla) → review+
(In reply to Magnus Melin from comment #13)
> Comment on attachment 8463651 [details] [diff] [review]
> biffsound.patch
> 
> Review of attachment 8463651 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> ::: mailnews/mailnews.js
> @@ +621,5 @@
> >  pref("mail.biff.alert.preview_length", 40);
> >  
> >  pref("mail.biff.play_sound", true);
> > +// For feed account serverType=rss sound on biff.
> > +pref("mail.biff.play_sound_feed", false);
> 
> Could we make this mail.feeds.play_sound to align with mail.chat.play_sound

i spent more time on the pref name than the rest..  it's like this because feed is a subset of mail, ie if the feed pref is true, it uses the mail.biff.* settings.  chat on the other hand is promoted to having its own prefs for sounds etc.

there will likely never be feed (systemwide or account or even folder) prefs as it's totally not useful to have anything but a feed url filter type solution a la ToneQuilla.

it's not important; do you prefer it?
Ok, that's a point indeed, but I still think having it in the mail.feeds.xxx format would be preferabale. IF such a thing ever gets implemented you don't need to work with different naming schemes.
Attached patch biffsound.patchSplinter Review
updated.
Attachment #8463651 - Attachment is obsolete: true
Attachment #8474111 - Flags: review+
Keywords: checkin-needed
magnus, could you please land this and bug 304917?  thanks.
https://hg.mozilla.org/comm-central/rev/735e411003de
Status: NEW → RESOLVED
Closed: 14 years ago5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 36.0
Flags: wanted-thunderbird3?
You need to log in before you can comment on or make changes to this bug.