cannot paste text copied from tbird before 1st char of paragraph in html compose window

RESOLVED DUPLICATE of bug 299343

Status

RESOLVED DUPLICATE of bug 299343
13 years ago
8 years ago

People

(Reporter: LD_Bugzilla, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051201 Thunderbird/1.5 - Build ID: 2005120115

cannot paste in front of 1st character of paragraph in html message compose window in tb150 if copy is of text in tbird. text from other applications paste fine.

Reproducible: Always

Steps to Reproduce:
[1] start tb150
[2] open new html message compose window
[3] enter one character
- the number of chars or words or lines in any para is NOT a deciding factor. enter as many as you wish.
[4] select & copy the one char from item [3]
- the number chars or words or lines of the copy is NOT a deciding factor
[5] place the cursor in front of char entered in [3]
[6] attempt to paste there
- use ctrl-v or edit/paste or rtl-clk/paste
Actual Results:  
nothing is pasted.

Expected Results:  
current clipboard contents should have been pasted at current cursor location.

- if you copy text from another application, paste works as expected.
- for this purpose, paragraph is defined any collection of words that wraps in the window OR that ends with an <enter>.
- if you enter multiple words, the problem only exists in front of the 1st char of the paragraph.
- if you enter multiple paras, the problem exits in front of the 1st char of EACH para.
- the problem does NOT exist at any other position in the document.
(Reporter)

Updated

13 years ago
Summary: paste text copied from tbird before 1st char of paragraph in html compose window fails → cannot paste text copied from tbird before 1st char of paragraph in html compose window

Updated

13 years ago
Whiteboard: DUPEME

Comment 1

13 years ago
Related to/duplicate of Core bug 299343?

Comment 2

13 years ago
Our discussion confirming this bug on the Mozillazine Forums is here...
http://forums.mozillazine.org/viewtopic.php?t=367695

I don't have confirm permission, feel free to contact me or post in the forum...
OS is WinXP/32 sp2, Thunderbird Version is 1.5
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051201 Thunderbird/1.5

*** This bug has been marked as a duplicate of 299343 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Cleanup *dupeme* whiteboard flag from bugs that are marked as Resolved Duplicate!
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.