Last Comment Bug 299343 - Can't copy and paste into the beginning of a line
: Can't copy and paste into the beginning of a line
Status: RESOLVED FIXED
: fixed1.8.1, regression, verified1.8.0.1
Product: Core
Classification: Components
Component: Editor (show other bugs)
: Trunk
: All All
: -- major with 2 votes (vote)
: ---
Assigned To: Peter Van der Beken [:peterv]
:
Mentors:
: 300427 317638 318503 321145 323949 326298 326641 327852 (view as bug list)
Depends on: 286300
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-30 20:58 PDT by Matti
Modified: 2010-09-17 21:55 PDT (History)
16 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (884 bytes, patch)
2005-12-17 12:43 PST, Peter Van der Beken [:peterv]
jst: review+
jst: superreview+
dveditz: approval1.8.0.1+
dveditz: approval1.8.1+
Details | Diff | Review
v1 ported to 1.8 branch (884 bytes, patch)
2006-01-08 03:41 PST, Peter Van der Beken [:peterv]
no flags Details | Diff | Review

Description Matti 2005-06-30 20:58:31 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050629
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050629

If I copy text in Composer I can't then paste it into the first space of
paragraphs, headings, plain text, URLs (i.e. after the ">" closing the opening
tag)(e.g. at the asterisk in "<p>*Text here"). It's fine anywhere else or with
text from another program.

Reproducible: Always
Comment 1 Daniel Wang 2005-10-05 18:08:59 PDT
confirm bug exists in Seamonkey 1.0a
Comment 2 Andrew Schultz 2005-12-17 09:06:45 PST
this regressed between linux trunk builds 2005-06-16-02 and 2005-06-17-05

==> editor
Comment 3 Andrew Schultz 2005-12-17 09:07:37 PST
*** Bug 318503 has been marked as a duplicate of this bug. ***
Comment 4 Andrew Schultz 2005-12-17 09:10:53 PST
*** Bug 317638 has been marked as a duplicate of this bug. ***
Comment 5 Andrew Schultz 2005-12-17 10:51:16 PST
CVS build from 2005-06-16 7:30 is broken, so this is from bug 286300
Comment 6 Peter Van der Beken [:peterv] 2005-12-17 12:43:27 PST
Created attachment 206196 [details] [diff] [review]
v1
Comment 7 Johnny Stenback (:jst, jst@mozilla.com) 2005-12-17 13:00:58 PST
Comment on attachment 206196 [details] [diff] [review]
v1

r+sr=jst
Comment 8 Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( ) 2005-12-22 16:37:27 PST
*** Bug 321145 has been marked as a duplicate of this bug. ***
Comment 9 neil@parkwaycc.co.uk 2005-12-22 16:56:18 PST
Comment on attachment 206196 [details] [diff] [review]
v1

Highly visible regression (affects message compose and midas)
Comment 10 Daniel Veditz [:dveditz] 2006-01-05 11:35:18 PST
Comment on attachment 206196 [details] [diff] [review]
v1

a=dveditz for 1.8/1.8.0.1 branches. Please add the fixed1.8.1 and fixed1.8.0.1 keywords when checked in.
Comment 11 Peter Van der Beken [:peterv] 2006-01-08 03:41:33 PST
Created attachment 207886 [details] [diff] [review]
v1 ported to 1.8 branch

The code on the trunk has moved since the 1.8 branch was created. Here is the patch ported to the 1.8 branch.
Comment 12 Peter Van der Beken [:peterv] 2006-01-08 04:52:44 PST
Attachment 207886 [details] [diff] checked in on 1.8 and 1.8.0 branches.

To verify this fix in Firefox you can use http://www.mozilla.org/editor/midasdemo/ Check the "View HTML Source" checkbox, replace the '<br>' with '<p>abc</p>', uncheck the "View HTML Source" checkbox, select and copy the text ('abc') and try to paste it before the a. The paste will fail in a build without this fix, with this fix you should end up with 'abcabc'.
Comment 13 Marcia Knous [:marcia - use ni] 2006-01-11 14:10:55 PST
verified fixed on the branch using Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1. I used Peter Van der Beken's excellent test case in Comment 12 to verify. Thanks Peter.
Comment 14 Joe Amersdorfer 2006-01-12 01:51:59 PST
Did this fix go in Thunderbird 1.5, because I see the same bug in a "message compose" window (to test, see description in duplicate https://bugzilla.mozilla.org/show_bug.cgi?id=318503)?

Tested with Thunderbird 1.5, new profile, no extensions. Windows XP SP 2, all updates.

Testcase with Thunderbird 1.5:
1. open a new message compose window in HTML-mode.
2. write something in the body window.
3. select some written text and position cursor at beginning of the line
4. paste does nothing (if cursor is somewhere in the text, it works).
Comment 15 Peter Van der Beken [:peterv] 2006-01-12 02:00:55 PST
*** Bug 300427 has been marked as a duplicate of this bug. ***
Comment 16 Peter Van der Beken [:peterv] 2006-01-12 03:49:14 PST
This wasn't fixed in Thunderbird 1.5 afaik. I suppose 1.5.0.1 should pick it up from the 1.8.0.1 branch, but I'll try to find out if I need to do anything else.
Comment 17 Joe Amersdorfer 2006-01-12 14:00:12 PST
(In reply to comment #16)
> This wasn't fixed in Thunderbird 1.5 afaik. I suppose 1.5.0.1 should pick it up
> from the 1.8.0.1 branch, but I'll try to find out if I need to do anything
> else.

Thanks for the reply - so no need to file a new bug.
Comment 18 Art Wildman 2006-01-19 08:34:26 PST
Unfortunately we filed a dupe https://bugzilla.mozilla.org/show_bug.cgi?id=323949  This bug is very easy to duplicate for users that compose in HTML (many do) and when discovered degrades the perception of quality and confidence in the product. Our discussion confirming this bug on the Mozillazine Forums is here... -
http://forums.mozillazine.org/viewtopic.php?t=367695

OS is WinXP/32 sp2, Thunderbird Version is 1.5
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051201
Thunderbird/1.5
Comment 19 Boris Zbarsky [:bz] 2006-01-19 08:57:16 PST
*** Bug 323949 has been marked as a duplicate of this bug. ***
Comment 20 Boris Zbarsky [:bz] 2006-01-19 08:57:51 PST
Art, the bug is fixed.  Thunderbird 1.5 just shipped code that doesn't include the fix.  Thunderbird 1.5.0.1 should fix that when it ships.
Comment 21 Andrew Poth 2006-01-24 08:44:09 PST
(In reply to comment #18)
> Unfortunately we filed a dupe
> https://bugzilla.mozilla.org/show_bug.cgi?id=323949  This bug is very easy to
> duplicate for users that compose in HTML (many do) and when discovered degrades
> the perception of quality and confidence in the product. Our discussion
> confirming this bug on the Mozillazine Forums is here... -
> http://forums.mozillazine.org/viewtopic.php?t=367695
> 
> OS is WinXP/32 sp2, Thunderbird Version is 1.5
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051201
> Thunderbird/1.5
> 

Installed Thunderbird 1.5 yesterday on Win98SE, plain, no extensions; encountered this bug in the VERY FIRST message I composed this morning.  Definitely leaves a poor impression.
Comment 22 Boris Zbarsky [:bz] 2006-01-24 08:51:34 PST
Andrew: we know.  What do you expect to happen exactly?  Time travel to happen and affect the Thunderbird 1.5 release?  The next update to Thunderbird will have the fix.
Comment 23 Andrew Poth 2006-01-24 10:58:15 PST
(In reply to comment #22)
> Andrew: we know.  What do you expect to happen exactly?  Time travel to happen
> and affect the Thunderbird 1.5 release?
> 
I'm not that stupid.  Indulge me.  I sound off on Bugzilla about twice a year.  Some very annoying Mozilla Suite bugs never did get fixed, despite lots of discussion and promises, largely for lack of "squeaky wheels".  I don't want the same fate for Thunderbird and Firefox.
Comment 24 WADA 2006-02-07 14:24:03 PST
(In reply to comment #23)
> I don't want the same fate for Thunderbird and Firefox.

At least Firefox team is trying to improve release process of 1.8 Branch(Fx 1.5.x and Fx 2).
See nexts.
 - http://www.mozillazine.org/talkback.html?article=7819
 - http://wiki.mozilla.org/Global:1.9_Trunk_1.8_Branch_Plan
I don't know about Thunderbird, but I have no hope on Tb because of denial of Bug 316812 for Tb 1.5.0.x...
Comment 25 Mike Cowperthwaite 2006-02-19 15:36:11 PST
(In reply to comment #24)
> I don't know about Thunderbird, but I have no hope on Tb because of denial of
> Bug 316812 for Tb 1.5.0.x...

Well, that's a mail-specific bug.  The patch here is core, and is already in 
the 1.8.0.x branch.
Comment 26 Mike Cowperthwaite 2006-02-19 15:37:46 PST
*** Bug 327852 has been marked as a duplicate of this bug. ***
Comment 27 Mike Cowperthwaite 2006-02-19 15:38:07 PST
*** Bug 326641 has been marked as a duplicate of this bug. ***
Comment 28 Mike Cowperthwaite 2006-02-19 15:38:59 PST
*** Bug 326298 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.