Can't open attachments in forwarded email where original email forwarded as attachment

RESOLVED DUPLICATE of bug 320571

Status

Thunderbird
Mail Window Front End
--
major
RESOLVED DUPLICATE of bug 320571
13 years ago
8 years ago

People

(Reporter: PhilT, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Thunderbird version 1.5 (20051201)

I received two emails that had attachments, one a PDF the other a ZIP. In both cases the person sending me the email had forwarded the email as an attachment. In other words person 1 sends email with attachment to person 2 who sends it to me as an attachment, a sort of nested attachments situation.

I can't open the original attachments, or save them. If I forward them on to GMail it manages to give me access to the attachment. I note that in Thunderbird the forwarded email is shown as an attachment to itself

Reproducible: Always

Steps to Reproduce:
1. Send email to yourself with attachment, title original
2. Receive "original", forward as an attachment (default). Subject now [Fwd:original]
3. Open Fwd:original and see "original" as attachment. Double click "original" and you get an email with the attachment from step 1 and email "original" as two attachments. Neither of these will open.

Actual Results:  
Nothing happens if double click icon of attached file. "Save as" results in error message "Unable to save the attachment. Please check yor file name and try again later".

Expected Results:  
Should have opened original attachment. Didn't expect to see the orginal email as an attachment to itself.

Antivirus checkers are being used  in both cases on outgoing mail. AVG in my case.
(Reporter)

Comment 1

13 years ago
Created attachment 209267 [details]
Source of an example forwarded message

Message source from forwarded message that won't open attachment from original
Same issue as Bug 320571?

By the way, why couldn't you find DUPs or similar bugs thru Find a Specific Bug?
https://bugzilla.mozilla.org/query.cgi?format=specific
(Status: Open, Product: All, and  Words: approrpiate term)
Due to inapproariate keywords in summary of related bugs?
Or due to lack of appropriate keyword in Keywords: or Status: field of related bugs? 
(Reporter)

Comment 3

13 years ago
Created attachment 209275 [details]
Source of an example forwarded message

Message source from forwarded message that won't open attachment from original
(Reporter)

Updated

13 years ago
Attachment #209275 - Attachment is obsolete: true
(Reporter)

Comment 4

13 years ago
"Due to inapproariate keywords in summary of related bugs?
Or due to lack of appropriate keyword in Keywords: or Status: field of related
bugs? "

I'm obviously too stupid. The 200 hits I got contained many similar (often old) bugs but none that looked an exact match to my problem. Thankyou for your constructive input, perhaps you could suggest some search terms that will yield identical bugs ?

Comment 5

13 years ago
Agreed on the dupe.

(In reply to comment #4)
> I'm obviously too stupid. The 200 hits I got contained many similar 
> (often old) bugs but none that looked an exact match to my problem.
> Thankyou for your constructive input, perhaps you could suggest some
> search terms that will yield identical bugs ?

He's not criticizing your search, he's trying to figure out how to make the other bug better match the keywords people actually use.  As it happens, the underlying problem for this bug is very old, but it has been fixed recently; 
if you get a trunk nightly build, you should be able to open the attachment.

Figuring out good search terms is hard, and for some problems, *very* hard.

*** This bug has been marked as a duplicate of 320571 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 6

13 years ago
version 1.6a1 (20060119) does resolve this.
(In reply to comment #4)
> perhaps you could suggest some search terms that will yield identical bugs?

No, no. As mike says, my question can be said:
  What "Word:" do you usualy use, if you have to find already reported bug in
  bugzilla.mozilla.org for your this bug's problem?

"Forwarded mail" has too many variations:
 forwarded (e)mail, (e)mail attachment, attached (e)mail, 
 (e)mail forwarded as attachment, message forwarded as attachment,
 forwarded message, message attachment, attached message,
 nested (e)mail, child (e)mail, nested message, child message, 
 message/rfc822 part, ".eml" format attachment, etc. etc.
I tried to put word of "message/rfc822"(or ".eml") in summary of bugs listed in(put in dependency tree of) Bug 269826.
But "message/rfc822"(or ".eml") is term for programmer, not word for users.
So search by non-programer user is usually very hard when problem relates to "forwarded mail".

In addition to it, when bug is fixed in trunk, status becomes other than "Open".
Then, once Bug 320571's staus is changed to FIXED or DUP, Bug 320571 will never  be found by search for "Status: Open" bug only.
This is the reason why I postponed closing of Bug 320571, and one of the reasons why I opend meta Bug 269826.
You need to log in before you can comment on or make changes to this bug.