Can't open attachments of forwarded mail(message/rfc822 part), when the forwarded mail is opened in stand alone window("Display Attachments Inline" is disabled).

RESOLVED DUPLICATE of bug 203570

Status

--
major
RESOLVED DUPLICATE of bug 203570
13 years ago
8 years ago

People

(Reporter: thomas.mensak, Assigned: World)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; de; rv:1.8) Gecko/20051118 Firefox/1.5
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4.5; de; rv:1.8) Gecko/20051118 Firefox/1.5

Documents (*.doc, *.PDF) attached to a mail and the forwarded to me cannot be opened. If i select the attached file within the forwarded mail nothing happens.
the mail holding the attachment was itself forwarded as an attachment.

Reproducible: Always
(Reporter)

Updated

13 years ago
Version: unspecified → 1.5
Is there any chance it was sent by someone using LN?  There is a condition that occurs where the sender's temp directory has some corruption that creates a condition much like this (only on forwarded mail).  I have only seen the condition on the receivers end when the receiver had LN and it looks like an attachement but it isn't there.  Don't know if any other app has a similar issue.
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> Is there any chance it was sent by someone using LN?  There is a condition that
> occurs where the sender's temp directory has some corruption that creates a
> condition much like this (only on forwarded mail).  I have only seen the
> condition on the receivers end when the receiver had LN and it looks like an
> attachement but it isn't there.  Don't know if any other app has a similar
> issue.
> 

What do you mean with LM?
The sender of the mail uses Thunderbird 1.0.7 (which i installed on his machine...).
(Assignee)

Comment 3

13 years ago
Tb still has some unresolved problems in handling of nested message/rfc822.
See meta Bug 269826 comment #0 for major issues and dependency tree of the bug for other many related bugs.
(Q1) Is there DUP bug of your problem in it?

There are some new bugs after last listing of dependent bugs of Bug 269826.
(Q2) Can you find DUP bug of your problem by searching open bugs which has "rfc822" or ".eml" in summary?

I don't know whether all already fixed bugs are resolved by your 20051118 build or not.
(Q3) Does your problem still occur with newest Thunderbird latest-trunk nightly?

If both answer to Q1 & Q2 are "No" and answer to Q3 is "Yes", attach the mail to this bug(with text/plain Mime-Type for ease of chaking the data),
after replacing sensitive data(such as mail address) by meaningless text.  
(Reporter)

Comment 4

13 years ago
(In reply to comment #3)
> Tb still has some unresolved problems in handling of nested message/rfc822.
> See meta Bug 269826 comment #0 for major issues and dependency tree of the bug
> for other many related bugs.
> (Q1) Is there DUP bug of your problem in it?
> 
> There are some new bugs after last listing of dependent bugs of Bug 269826.
> (Q2) Can you find DUP bug of your problem by searching open bugs which has
> "rfc822" or ".eml" in summary?
> 
> I don't know whether all already fixed bugs are resolved by your 20051118 build
> or not.
> (Q3) Does your problem still occur with newest Thunderbird latest-trunk
> nightly?
> 
> If both answer to Q1 & Q2 are "No" and answer to Q3 is "Yes", attach the mail
> to this bug(with text/plain Mime-Type for ease of chaking the data),
> after replacing sensitive data(such as mail address) by meaningless text.  
> 


Maybe i should describe the problem more clearly. The mail i received was a mail with an attachment. This attachment itself included an email with an attachment.
I am not able to attach the email to this bug because of confidential contents. Sorry for that.
(Reporter)

Comment 5

13 years ago
Created attachment 206852 [details]
email with unusable attachment
(Reporter)

Comment 6

13 years ago
(In reply to comment #4)
> (In reply to comment #3)
> > Tb still has some unresolved problems in handling of nested message/rfc822.
> > See meta Bug 269826 comment #0 for major issues and dependency tree of the bug
> > for other many related bugs.
> > (Q1) Is there DUP bug of your problem in it?
> > 
> > There are some new bugs after last listing of dependent bugs of Bug 269826.
> > (Q2) Can you find DUP bug of your problem by searching open bugs which has
> > "rfc822" or ".eml" in summary?
> > 
> > I don't know whether all already fixed bugs are resolved by your 20051118 build
> > or not.
> > (Q3) Does your problem still occur with newest Thunderbird latest-trunk
> > nightly?
> > 
> > If both answer to Q1 & Q2 are "No" and answer to Q3 is "Yes", attach the mail
> > to this bug(with text/plain Mime-Type for ease of chaking the data),
> > after replacing sensitive data(such as mail address) by meaningless text.  
> > 
> 
> 
> Maybe i should describe the problem more clearly. The mail i received was a
> mail with an attachment. This attachment itself included an email with an
> attachment.
> I am not able to attach the email to this bug because of confidential contents.
> Sorry for that.
> 

In the meanwhile i switched to TBird Version 1.5 (20060113).
Bug still existing.
I also attached the mail having the describes problem.
Btw. i think this problem seems to be a DUP of MetaBug about "rfc822" but judge yourself (because i am not really able to judge it).

Comment 7

13 years ago
Hmm, I just built my unofficial Thunderbird for OS/2 from the 1.8.0 branch and in preparation for the release tested you attachment. To do that I shut down Thunderbird, opened the Inbox file of the "Local Folders" account with an editor (not e.exe), and after a few newlines added the three lines

From - Sat Nov 12 09:15:01 2005
X-Mozilla-Status: 0011
X-Mozilla-Status2: 00000000

and without any extra blank lines appended your attachment 206852 [details] to that email. Then I deleted Inbox.msf and restarted Thunderbird. The email showed up and I can see two attachments, one called "Forum" which is contains another email and is also automatically displayed inline, and a Word file called Forum-Bespr-1105.doc that here opens in StarOffice when I double-click on it. If I use the official Thunderbird I have to save it first but the saved DOC file is in good condition as far as I can see.

So, in summary, I don't see a problem with that email.

(Btw, I hope that there is nothing confidential in that email you attached here, not everything is x'ed out...)
Severity: major → normal
(Reporter)

Comment 8

13 years ago
(In reply to comment #7)
> Hmm, I just built my unofficial Thunderbird for OS/2 from the 1.8.0 branch and
> in preparation for the release tested you attachment. To do that I shut down
> Thunderbird, opened the Inbox file of the "Local Folders" account with an
> editor (not e.exe), and after a few newlines added the three lines
> 
> From - Sat Nov 12 09:15:01 2005
> X-Mozilla-Status: 0011
> X-Mozilla-Status2: 00000000
> 
> and without any extra blank lines appended your attachment 206852 [details] [edit] to that
> email. Then I deleted Inbox.msf and restarted Thunderbird. The email showed up
> and I can see two attachments, one called "Forum" which is contains another
> email and is also automatically displayed inline, and a Word file called
> Forum-Bespr-1105.doc that here opens in StarOffice when I double-click on it.
> If I use the official Thunderbird I have to save it first but the saved DOC
> file is in good condition as far as I can see.
> 
> So, in summary, I don't see a problem with that email.
> 
> (Btw, I hope that there is nothing confidential in that email you attached
> here, not everything is x'ed out...)
> 

Unfortunately not so for me! I have several forwarded mails with attachments at the forwarded mail. I see the attached mail and can open it. In the new opended window i can see the attachments but no action happens if i try to open them. If i try to save them to disk, there is the following error:" Unable to save the attachment. Please check your file name and try again later."
Everyting worked with Thunderbird 1.0.7.....
(Reporter)

Comment 9

13 years ago
(In reply to comment #8)
Just some further tests:
If i save the attached email from within the forwarded email and the open the .eml file i still can't open the attachment but now i can save the attachment to disk.
(Assignee)

Comment 10

13 years ago
(In reply to comment #5)
> Created an attachment (id=206852) [edit]
> email with unusable attachment

Normal nested(3 level) mail which contains file attachment(s) in attached mail(message/rfc822 part).

Same problem has been reported to a forum in Japan.
Main issue seems to be Bug 203570 which is listed at the top of Bug 269826 Comment #0, although I can't say your problem will be resolved when Bug 203570 will be fixed.

Will your problem varies according to following changes?
 (1) Vew/Message Body As : "Original HTML" or "Plain Text".
 (2) View/Display Attachments Inline : Enabled or Disabled.
 (3) Where "trying to open attached file" is executed :
     At original mail display pane, or at mail window of attached(nested) mail.
 (4) "Save As" of the attached file instead of "trying to open".          
(Reporter)

Comment 11

13 years ago
(In reply to comment #10)
> Will your problem varies according to following changes?
>  (1) Vew/Message Body As : "Original HTML" or "Plain Text".

Yes. Same problem at both view settings

>  (2) View/Display Attachments Inline : Enabled or Disabled.

Nothing changes while viewing the mail

>  (3) Where "trying to open attached file" is executed :
>      At original mail display pane, or at mail window of attached(nested) mail.

The attached email opens in a separate window and the attachments are shown (not inline but as attached files)

>  (4) "Save As" of the attached file instead of "trying to open".          
> 

"Save As" of the attachments ends up in error "Unable to save
the attachment. Please check your file name and try again later."
and the attached file cannot be saved

I also did some further tests:
If i save the attached email from within the forwarded email to disk (mail.eml) and the open the mail .eml file i still can't open the attachment but now i can save it to disk.
(Reporter)

Comment 12

13 years ago
(In reply to comment #10)

After some tests i just noticed a change:

If i view the email with "View/Display Attachments Inline : Disabled" only the forwarded email is visible in the attachment area. I have to open the forwarded email to see the attachments but i can't open them.

If i view the email with "View/Display Attachments Inline : Enabled" i can see the the forwarded mail and its attachments in the attachment area and i can open the attachments directly from within the attachment section of the window.
(Assignee)

Comment 13

13 years ago
(In reply to comment #12)
> If i view the email with "View/Display Attachments Inline : Disabled" only the
> forwarded email is visible in the attachment area. I have to open the forwarded
> email to see the attachments but i can't open them.
> 
> If i view the email with "View/Display Attachments Inline : Enabled" i can see
> the the forwarded mail and its attachments in the attachment area and i can
> open the attachments directly from within the attachment section of the window.

This is problem of Bug 203570 Comment #36.
Closing as DUP of Bug 203570.


*** This bug has been marked as a duplicate of 203570 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

13 years ago
Summary: can't open attachments from forwarded mails → Can't open attachments of forwarded mail(message/rfc822 part), when the forwarded mail is opened in stand alone window("Display Attachments Inline" is disabled). This is problem of Bug 203570 Comment #36.
(Assignee)

Updated

13 years ago
Severity: normal → major
OS: OS/2 → All
(Assignee)

Comment 14

13 years ago
Re-opening this bug.

Although problem itself is phenomenon of Bug 203570 Comment #36,
if the parent mail doesn't have file attachments(forwarded mailonly, message/rfc822 part only), attachment box of forwarded mail display window looks to be good.
This makes problem analysis difficult, then DUPing of bug reports of this bug's  phenomenon to Bug 203570 becomes very hard.
So keep this bug open, and set dependency to Bug 203570.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Assignee)

Updated

13 years ago
Blocks: 269826
Status: UNCONFIRMED → NEW
Depends on: 203570
Ever confirmed: true
(Assignee)

Updated

13 years ago
Hardware: Other → All
(Assignee)

Comment 15

13 years ago
Assigning  to me, because of special status, such as "pending DUP".
Assignee: mscott → m-wada
(Assignee)

Comment 16

13 years ago
Workaround :
 - Enable "View/Display Attachments Inline", and access to attachment(s) at main
   mail display pane, instead of opening new window of forwarded mail
   (attached mail, message/rfc822 part).
(See comment #12 by bug opener.)
(Assignee)

Comment 17

13 years ago
This bug's phenomenon always occurs if all next conditions are met.
 (A-1) A mail user uses Thunderbird 1.5.0.0.
 (A-2) The Thunderbird user enables "Mail forwarding by message filter".
 (A-3) A mail is sent to the Thunderbird user.
 (A-4) The mail has attachment(s).
 (A-5) The mail is forwarded(as attacment) by message filter.
 (B-1) Recipient of the forwared mail uses Thunderbird as his/her mail client.
       (Mozilla/Seamonkey, Netscape 6/7/8 are included).
 (B-2) The recepient of the forwarded mail disables
       "View/Display Attachments Inline" option.
Since "Mail forwarding by message filter" has been released with Thunderbird 1.5.0.0 without fixing Bug 203570, this bug's phenomenon is supposed to occur on many Thunderbird 1.5.0.0 users, then many many DUP bugs of this bug are expected.
Please close this kind of bugs as DUP of this bug, if you find such bugs.
Regards.
(Assignee)

Comment 18

13 years ago
cc-ing to Mike.
Previous my comment is mainly message to you :-)

Comment 19

13 years ago
(In reply to comment #17)
> This bug's phenomenon always occurs if all next conditions are met.
>  (A-1) A mail user uses Thunderbird 1.5.0.0.
>  (A-2) The Thunderbird user enables "Mail forwarding by message filter".
>  (A-3) A mail is sent to the Thunderbird user.
>  (A-4) The mail has attachment(s).
>  (A-5) The mail is forwarded(as attacment) by message filter.
>  (B-1) Recipient of the forwared mail uses Thunderbird as his/her mail client.
>        (Mozilla/Seamonkey, Netscape 6/7/8 are included).
>  (B-2) The recepient of the forwarded mail disables
>        "View/Display Attachments Inline" option.
> Since "Mail forwarding by message filter" has been released with Thunderbird
> 1.5.0.0 without fixing Bug 203570, this bug's phenomenon is supposed to occur
> on many Thunderbird 1.5.0.0 users, then many many DUP bugs of this bug are
> expected.

It's not clear to me that it's necessary to forward by filter, nor that the forwarding client needs to use TB; I see this same symptom in a message forwarded to me two years ago from a non-Mozilla client.  I believe you were basically correct on the dupe -- the problem is closer to bug 206278, which 
was marked fixed as part of the work on 203570.  At any rate, I don't see the problem using a trunk build (and 203570 was only fixed on the trunk).
(Assignee)

Comment 20

13 years ago
(In reply to comment #19)
> It's not clear to me that it's necessary to forward by filter, nor that the
> forwarding client needs to use TB;

This bug is not only when "message forwarding by filter" as you say.
But it's supposed to that many users will experience this bug's phenomenon, once "message forwarding by filter" is released.
This is the reason why I postponed DUPing to bug 203570.

> At any rate, I don't see the problem using a trunk build
> (and 203570 was only fixed on the trunk).

I was convinced that all patchs for bug 203570 are already applied to Thunderbird 1.5.0.0.
I've understood why this bug's phenomenon occurs when Thunderbird 1.5.0.0, but doesn't occur when trunk.
Thanks for your comment.
Summary: Can't open attachments of forwarded mail(message/rfc822 part), when the forwarded mail is opened in stand alone window("Display Attachments Inline" is disabled). This is problem of Bug 203570 Comment #36. → Can't open attachments of forwarded mail(message/rfc822 part), when the forwarded mail is opened in stand alone window("Display Attachments Inline" is disabled).
(Assignee)

Comment 21

13 years ago
(In reply to comment #19)
> the problem is closer to bug 206278, which was marked fixed as part of the work on 203570.

Difference between this bug and your Bug 206278 was "View/Display Attachments Inline" option setting only.
This bug is when the option is disabled, and your bug is when enabled.
Both are basicaly same issue, although external view is different.
I couldn't be aware of similarity of both bugs without your comment.
Thanks.
(Assignee)

Comment 22

13 years ago
This bug can be closed as any of nexts.
 (1) DUP of your Bug 206278, with adding "save as fail" in summary of it.
 (2) FIXED, with describing "Fixed by patch for Bug 203570" as your bug.
 (3) DUP of Bug 203570.
Mike, which is the best for searching bug do you think?
(I prefer (1), because only small difference of external view according to difference of option setting.)

Comment 23

13 years ago
*** Bug 324316 has been marked as a duplicate of this bug. ***

Comment 24

13 years ago
Re-duping this.  The patch at 203570 is now in the "1.8" branch (basis of 1.5, and will be for TB 2.0).  I've asked for approval for that patch for 1.5.0.x, but that's still pending.

*** This bug has been marked as a duplicate of 203570 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE

Comment 25

13 years ago
*** Bug 340393 has been marked as a duplicate of this bug. ***

Comment 26

13 years ago
*** Bug 340324 has been marked as a duplicate of this bug. ***

Comment 27

13 years ago
(In reply to comment #25)
> *** Bug 340393 has been marked as a duplicate of this bug. ***
> 

(In reply to comment #26)
> *** Bug 340324 has been marked as a duplicate of this bug. ***
> 

(In reply to comment #24)
> Re-duping this.  The patch at 203570 is now in the "1.8" branch (basis of 1.5,
> and will be for TB 2.0).  I've asked for approval for that patch for 1.5.0.x,
> but that's still pending.
> 
> *** This bug has been marked as a duplicate of 203570 ***

If this bug was duped to bug 203570, shouldn't these then be dupes of THAT, not this one since that is the active bug?

Comment 28

12 years ago
*** Bug 324950 has been marked as a duplicate of this bug. ***
No longer blocks: 269826
No longer depends on: 203570
You need to log in before you can comment on or make changes to this bug.