Closed Bug 325144 Opened 16 years ago Closed 12 years ago

Scroll Header with Message

Categories

(Thunderbird :: Mail Window Front End, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 464309

People

(Reporter: david, Unassigned)

References

Details

Attachments

(4 files)

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.12) Gecko/20050915
Build Identifier: Thunderbird 1.5

When I vertically scroll a message, the header should scroll with it.  That way, as the header scrolls out of the window, more of the message is visible.  

Reproducible: Always

Actual Results:  
While scrolling the messge, the header remains in a fixed position.
ref Seamonkey bug 9942
QA Contact: front-end
Assignee: mscott → nobody
ref Thunderbird bug 464309
This is covered by the other bug, thus duping.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 464309
From the initial description of bug 464309, this is NOT a duplicate of that bug.  

In bug 464309, the problem is that the frame for the headers is sized incorrectly.  The bug report also appears to refer to the upper-right pane in the three-pane "wide" view.  

This bug involves the complete header of a single message.  This is a problem whether the message is viewed in the bottom pane in the three-pane "wide" view or in a separate window.  If the complete header is viewed -- selecting the +- widget to the far left of the Subject with [View > Headers > All] -- the header might require more lines than can be displayed within the window.  There is no vertical scroll bar to view the entire set of header lines or to reach the message below the header.  On the other hand, selecting the +- widget again reduces the header to a single line with exactly the right amount of vertical space.  

I must also question closing a bug report that is more than three years old in favor of a newer report that is less than a year old.  This obscures the true age of the underlying problem.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(In reply to comment #4)
> I must also question closing a bug report that is more than three years old in
> favor of a newer report that is less than a year old.  This obscures the true
> age of the underlying problem.

For enhancement bugs, age is typically unimportant: I do not decide to implement bugs because one is older than another (although five or even four-digit bugs sometimes make more tempting targets). Also, when one bug has considerably more activity than another, it is preferable to dupe the low-activity bug to the high-activity one.
The initial description of this bug was very vague and hasn't been detailed even after cross-referencing to the other bugs. In contrast, bug 464309 might have been a duplicate of this one, but had already substantially progressed with a partial patch attached. In such cases it is acceptable to forward-dupe a bug though one would usually mark the newer one a duplicate of the older bug.
Status: REOPENED → NEW
File expanded.jpg shows the headers filling the message area, the bottom pane of the three-pane "wide" view.  There is no vertical scroll bar to view the entire set of headers or to reach the actual message.  

Yes, I could view the message source to see all the headers.  But then why even have the +- widget to expand or condense the header view?  Given the capability exists to view the headers without going to the message source, that capability should be made to be useful by allowing the user to scroll the display.
The attachment condensed.jpg shows a situation that is not a problem, with the header area condensed.  Note that the height of the area is appropriate to its content.  Thus, this RFE bug is indeed different from bug 464309, which is about an area that has excessive height.
Duplicate of this bug: 532012
This is cross posted to the dup above.
I have set [View > Layout > Wide View].  The elimination of the one-line header at the top of the message pane with Thunderbird 3.0 now means too much "real estate" is occupied by headers.  That would not be a problem if this RFE were implemented.  It is a severe problem without this RFE.  The area for the message itself is now a letter-box that is too narrow vertically for good reading comprehension.
David Ross, I think you misunderstood bug 464309. Both bug 9942 and bug 464309, (which is just the TB-cousin of the former) are about scrolling the header pane together with the message body. The "frame" stuff is just implementation detail.
Status: NEW → RESOLVED
Closed: 13 years ago12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 464309
You need to log in before you can comment on or make changes to this bug.