Thunderbird freezes when adding text BEFORE addressing to multiple recipients

RESOLVED DUPLICATE of bug 315412

Status

Thunderbird
General
--
critical
RESOLVED DUPLICATE of bug 315412
12 years ago
12 years ago

People

(Reporter: Victor McDonald, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Thunderbird 1.5  file version 3.12.0.0

This problem occurs when one adds text and images to a message BEFORE selecting the addresses.  It does not occur if one selects the addresses PRIOR to composing the message.

I open a new message and start inserting text and images.  The images are not large, but the amount of text can be.  Once the message is complete, I then use my mouse to select several addresses for the message -- usually more than ten.  Once I have selected the addresses and used my right mouse button to add the names to my "to" "cc" or "bcc" field, CPU useage soars to 100%.  Thundbird begins to very, very slowly add each address, often taking one minute to add each address.  More often then not the program stops responding

Reproducible: Always

Steps to Reproduce:
1.Open a blank message
2.Copy and paste a lot of text several times -- try to five or six hundred words
3.Highlight the addresses of those you want to receive the message.  Pick ten or fifteen addressees.
4.Use the RIGHT mouse button to add the addresses to the message.  

Actual Results:  
Once the addresses are selected, cpu useage hits 100% and the program eventually stops responding

Expected Results:  
Thunderbird came to a virtual stop; hogged 100% of the cpu; stopped all activity on the computer; and then showed the tag "program not responding"

Under the prior versions of Thunderbird, the addresses would have been instantly added and the message would be ready to send. 

Please read this message which I posted on the newsgroup mozilla.support.thunderbird:

Ernie wrote:
> On Thu, 9 Feb 2006 19:31:05 -0500, "vrm3" <vrm3@optonline.net> wrote:
> 
>> I've been trying to get help from the Thunderbird forum on the Mozilla 
>> Thunderbird Support forum. Some very well-intentioned and patient people 
>> have been trying to help me out, yet to date no one can solve my problem. 
>> Here are my posts and replies outlining each step I have taken to try to fix 
>> this insoluable problem.  As you can see, I've tried almost everything under 
>> the sun and nothing has worked.  Any help from this group would be deeply 
>> appreciated.
>>
>> FIRST POST
>>
>>
>> Just installed latest version of Thunderbird. It installed itself on top of 
>> my earlier version. The whole program is a lot slower than the earlier 
>> version.
>>
>> (1) When copying and pasting under previous version, the "paste" was 
>> instantaneous. Under new version, "paste" can take up to 15 seconds.
>>
>> (2) Addressing to more than one person is a nightmare. Under old version of 
>> Thunderbird when I wanted to send a message to multiple recipients I just 
>> highlighed the addresses and right clicked to, cc or bcc. The addresses were 
>> copied instantly. Under the new program if I want to send the same message 
>> to a number of people (say twenty) if I highlight the addresses and right 
>> click, the addresses are not copied instantly. The hourglass appears, cpu 
>> useage soars to 100% and in those cases when the addresses are copied it can 
>> take up to twenty minutes. More often than not Thunderbird freezes up an 
>> shows up as Not Responding. The only way to send mulitple addresses is to 
>> highlight them BEFORE composing the message, even then the transfer of 
>> addresses takes a lot longer than earlier versions.
>>
>> Any ideas as to how to correct this or what is causing it?
>>
>> If I uninstal version 1.5 will my earlier version reappear or am I screwed?
>>
>> Thanks.
>>
>> FORUM REPLY TO FIRST POST
>>
>> You needed have uninstalled any earlier version first, before installing 1.5 
>> though that will not be necessaary for any future versions.
>>
>> Uninstall both/all versions core programs and delete the program files 
>> directory. Restart your system and reinstall version 1.5.
>>
>>
>>
>> SECOND POST
>>
>> Will I lose the mail I sent under 1.5 and the earlier versions when I 
>> uninstall them?
>>
>>
>>
>> FORUM REPLY TO SECOND POST
>>
>> No because they are stored completely separate from Program Files on a 
>> different part of your hard drive.
>>
>>
>>
>> THIRD POST
>>
>> I uninstalled Thunderbird; deleted the Thunderbird directory; and then 
>> re-installed Thunderbird 1.5. (I never could find any traces of my earlier 
>> Thunderbird program.) I was able to send a few messages, but the problem 
>> returned. I then uninstalled Thunderbird again, etc. re-installed my earlier 
>> version of Thunderbird and used that for a while. I then uninstalled the 
>> earlier version and re-installed Thunderbird 1.5. The same problem keeps 
>> happening over and over again. "Paste" suddenly slows to a crawl -- 20 
>> seconds and clicking on multiple addresses produces the hour glass and 100% 
>> cpu useage. I am using Windows XP if that is any help. This is a complete 
>> mystery. Any suggestions. (I have uninstalled Thunderbird using its 
>> unistalled program and I've uninstalled it using the Windows XP uninstall 
>> program. Either way the problem returns.
>>
>>
>>
>>
>>
>> FORUM REPLY TO THIRD POST
>>
>> How recently have you compacted your folders? Compacting is something that 
>> needs to be done regularly in any email program. We recommend weekly, but 
>> many of us do it daily. When done often enough, it can be an extremely fast 
>> process. Not doing so can lead to problems like those you are experiencing. 
>> See this about how to and why it's so important: 
>> http://kb.mozillazine.org/Compacting_folders
>>
>> Plus do the following:
>>
>> Move any messages you want to retain out of all/any Inbox/es to a temporary 
>> folder that you create in 'Local Folders'.
>>
>> Now close Thunderbird.
>>
>> Navigate to your Thunderbird Profile Folder which is stored in Win Xp as 
>> follows:
>>
>> c/documents and settings/*your username*/application 
>> data/thunderbird/profiles/
>>
>> You may need to 'unhide' all files and folders via Folder Options > View > 
>> Show all hidden files and folders
>>
>> http://kb.mozillazine.org/Profile_Folder#Thunderbird
>>
>> Now locate ALL files with the name 'Inbox' and 'Inbox.msf' and DELETE those 
>> files.
>>
>> Now relaunch Thunderbird and see whether the problem is resolved. Don't 
>> forget to 'compact' all folders and especially the Inbox/es regularly.
>>
>>
>>
>>
>>
>> FOURTH POST
>>
>> I deleted all of my Inboxes and all of my files "Inbox.msf" I then compacted 
>> my folders and tried Thunderbird. It worked okay for a short time, but after 
>> a dozen or so messages the problem re-emerged. I uninstalled Firefox 1.5, 
>> manually deleted the left over folders etc and re-installed it. Again, it 
>> worked for a little while, but the problem quickly returned. Uninstalled and 
>> re-installed the program several times, but the same pattern of problems --  
>> 100% cpu useage -- returned.
>>
>> I then took matters into my own hands and deleted all of my sent and 
>> sent.msf files. Did the old compact routine, but all was for naught. 
>> Uninstalled Thunderbird again; reinstalled Thunderbird, and compacted the 
>> folders but the problem persisted.
>>
>> I don't know if this will help you, but the only reason I upgraded from 
>> Thunderbird 1 to Thunderbird 1.5 is that Thunderbird one developed a bizarre 
>> habit of over writing gif and jegs. I sometimes copy and paste text with 
>> graphics directly from Firefox into a Thunderbird message. This worked well 
>> for a long time. The other week Thunderbird 1.0 got really weird and started 
>> over writing all images in messages so that they were only one. In other 
>> words if a message had a picture of Hillary Clinton, a tree and a car, (with 
>> the car being the part of the message copied and pasted) when I sent the 
>> message all three places in the message ended up being the car. My inability 
>> to correct that flaw -- I have no idea where it came from -- triggered my 
>> very unfortunate decision to download and install Thunderbird 1.5, which as 
>> you know I installed over top of the earlier Thunderbird 1.0 version.
>>
>> I appreciate you patience with me, but do you have any other suggestions? Is 
>> there any other place where the problem could be originating?
>>
>>
>>
>>
>>
>> FORUM REPLY TO FOURTH POST
>>
>> I think you need a new profile. We can migrate your message, etc. over when 
>> we know the new one is working properly. I'll give you all the steps, but 
>> don't import anything until you know it works properly first.
>>
>> Close Thunderbird and open the profile manager. 
>> http://kb.mozillazine.org/Profile_manager
>>
>> Create your new profile and setup your accounts. Make sure it's working.
>>
>> Then I want you to install this extension: Mboximport: 
>> http://www.extensionsmirror.nl/index.php?showtopic=2074
>>
>> To install a Thunderbird extension do the following:
>>
>> Right click the download link and choose "Save Link As...". Then open 
>> Thunderbird, in Thunderbird go to Tools->Extensions->Install. Find the just 
>> downloaded .xpi file and select it. The installation will now begin.
>>
>> When it's installed, you will have a new menu item in Tools called 
>> Import/Export Mbox and under it, Import Mbox File. Select it and when you 
>> get to the Windows file navigation window, find your OLD profile and get the 
>> files with no extension that you want from Mail/*account*. Example: there 
>> are two files and 1 folder in your profile for your inbox. Inbox.sbd is the 
>> folder, inbox.msf is the index and inbox (no extension) is the actual 
>> message file. The last one is the one you want. Do this for each folder that 
>> contains messages that you want to bring in. If you have subfolders, these 
>> files are in the .sbd folder for the parent folder. The messages will be in 
>> a new folder named for the original with three numbers, ex: Inbox123, which 
>> you can then move the messages out of and sort as you want.
>>
>> For your address books, Close TB. Find your old profile and in the top level 
>> of it you will find some files with the .mab extension. TB creates two, 
>> abook.mab and history.mab. These are your main address books. These files 
>> can be just copied right into your new profile at the same level if you 
>> haven't added any new ones to the new address book. Let them copy over any 
>> existing files. If you do have addresses in the new address book already, 
>> then rename the old ones and copy them in that way. If you created any of 
>> your own please let me know, they will also be named with the .mab 
>> extension, but they won't be automatically picked up.
>>
>> If you have any filters set in your accounts, the files you want to copy is 
>> msgFilterRules.dat This goes in the Mail/*account* folder. For Junk controls 
>> training, the file is training.dat and it is kept in the top level of the 
>> profile folder.
>>
>> That should be everything. Let me know how it turns out.
>>
>> _________________
>>
>>
>>
>>
>>
>> FIFTH POST
>>
>> I followed all of the instructions creating the new profile, installing the 
>> extension, importing the inbox, copying my address book, and copying my junk 
>> control training file.
>>
>> The problem still exists -- the cpu goes to 100% when addressing the 
>> messages. For instance I prepared a message and then highlighted fifteen 
>> names for receiving the message. When I used my right mouse button to bcc 
>> the recipients, the names began to appear in my recipients' window at an 
>> incredibly slow pace. While the addresses were slowly being added, cpu 
>> useage once again soared to 100%.
>>
>> I have also noticed that the copy and paste hang-up gets worse and worse as 
>> the length of the message increases. I never used to have this problem in 
>> the past. My messages often have lots of text and some jpgs or gifs in them. 
>> For my test message of my new profile Thunderbird, I just kept copying and 
>> pasting the same text several times. Each "paste" was noticiably slower than 
>> the previous paste effort.
>>
>> What should we do next? Thanks for you patience and assistance.
>>
>>
>>
>>
>>
>> FORUM REPLY TO FIFTH POST
>>
>> Very strange. How recently have you defragged your hard drive?
>>
>>
>>
>>
>>
>> SIXTH POST
>>
>> Further information on my never ending Thunderbird 1.5 100% cpu problem. If 
>> I address a message BEFORE writing it, the names are added to the send list 
>> relatively quickly. I have discovered that the more text and images I add to 
>> the body of a message, the longer and longer it takes for the addresses to 
>> be added. During the time that the addresses are being added, my cpu useage 
>> soars to 100%. Often Thunderbird just stops responding and freezes up, 
>> requiring a Control-alt-delete to end it. It is also common for this message 
>> to appear when I am adding a long list of addressees: "A script on this page 
>> may be busy, or it may have stopped responding. You can stop the script now, 
>> or you can continue to see if the script will complete." I am then given the 
>> options "Stop script" or "Continue."
>>
>>
>>
>> FORUM REPLY TO SIXTH POST
>>
>> What extensions and themes do you have installed?
>>
>>
>>
>>
>>
>> SEVENTH POST
>>
>> The only extensions I have installed are Talkback 1.5 and MboxImport 0.5.1. 
>> The only Thunderbird theme I have is the default one.
>>
>>
>>
>>
>>
>> FORUM REPLY TO SEVENTH POST
>>
>> I asked because I have received that error, but usually when restarting 
>> Thunderbird after installing an extension. I have never seen it before 
>> version 1.5, but I haven't totally figured it out yet and I can't find 
>> anything in the Knowledge base about it yet.
>>
>> I'm at a loss with your problem at this point. I know this isn't normal 
>> behavior, but...
>>
>>
>>
>>
>>
>> EIGHTH POST
>>
>> I was wondering if there are any residual files that are created by versions 
>> of Thunderbird that could have been corrupted and were somehow getting 
>> picked up by each new reinstall. The very first time I uninstalled 
>> Thunderbird 1.5 (after having installed it on top of version 1.0) I never 
>> did find any trace of the original version 1.0. Could bits of it be hanging 
>> around? Does it have a cache or create temp files that might be causing the 
>> problem? Is there any way to totally wipe out all traces of Thunderbird from 
>> my hard drive, and I mean not just uninstalling it, but deleting everything 
>> so that there was no trace that any version of it had ever been on my hard 
>> drive. Would that work?
>>
>> Thanks for staying with me on this.
>>
>>
>>
>> FORUM REPLY TO EIGHT POST
>>
>> You could try a registry cleaner like CCleaner http://www.ccleaner.com/
>>
>> Uninstall again, delete the program directory again and then run it.
>>
>>
>>
>>
>>
>> NINETH POST
>>
>> Cleaned a huge load of junk off of my hard drive using CCleaner; but alas, 
>> the 100% cpu problem persists. It is definitely related to copy and pasting 
>> and addressing. If I address the message BEFORE adding text and images, the 
>> addressing script runs without a glitch. If I compose the message first, and 
>> then add the addresses, all hell breaks loose! The "copy and paste" process 
>> is an interesting phenomenon to watch. Each subsequent paste takes longer 
>> and longer to occur. The first paste happens in the blink of an eye. Six 
>> copy and pastes later the process takes several seconds. Of course running 
>> the address script AFTER placing text and images in the body of a message 
>> triggers the 100% cpu problem.
>>
>> One other thing that I have noticed, is that if I start to type in an 
>> address, Thunderbird brings up the list of possible addressees and allows me 
>> to select the correct recipient. Adding one addressee that way usually works 
>> okay. Using the RIGHT mouse to add recipients to the message from my address 
>> book is when cpu useage immediately jumps to 100%.
>>
>>
>>
>> Thanks for telling me about CCleaner. I freed up a lot of space on my hard 
>> drive.
>>
>>
>>
>>
>>
>> FORUM REPLY TO NINTH POST
>>
>> CCleaner is pretty nice.
>>
>> I'm wondering... Are you using a clipboard assistant program? You know, the 
>> ones that allow multiple clips like Word offers? I tried one for a while and 
>> it slowed my system to a crawl...
>>
>>
>>
>> TENTH POST
>>
>> Not to my knowledge. I have never modified my clipboard. I just use it as it 
>> came with Windows XP.
>>
>> I see that others have experienced the 100% cpu useage problem. Have they 
>> been able to overcome it? I wonder if the problem is in the address script 
>> for Thunderbird. Could you do me a favor and compose a very large message --  
>> copy and paste a huge wad of text -- say ten paragraphs copied ten times --  
>> so you would have 100 paragraphs. Then see if you can highlight and bcc ten 
>> addressees. I can do that in Thunderbird 1.07, but not 1.5. Can you do it in 
>> 1.5?
>>
>> ELEVENTH POST
>>
>> Defragged my hard drive. While the copy and paste appears to be working 
>> better, once the body of the message has text and images in it, my cpu 
>> useage goes to 100% as soon as I use my mouse to highlight and add multiple 
>> e-mail addresses.
>>
>> ____________________________________________
>>
>> Has anyone else experienced this nightmare?  Any thoughts or suggestions 
>> would be greatly appreciated.
>>
> 
> 
> I was able to reproduce/verify your problem:
> 
> I copied the text of this post, launched TB 1.5 and proceeded to
> compose a message. I immediately pasted 10 copies of this post into
> the message body then attached 3 JPG files, sizes: 39KB, 38KB, 59KB.
> 
> I then opened my contacts and clicked on one of the address and hit
> the "Add to To:" button. My task manager showed TB pegging the CPU at
> 100% for almost 30 seconds here. Each time I added a new contact to
> the message, the same thing happened. After 5 contacts, TB was
> unresponsive, after a couple of minutes, I had to kill the task.
> 
> Running Win2000 Pro SP4, PIII 900MHz, 256MB. Running Task Manager
> showed TB's memory usage did not really spike, but remained fairly
> constant at around 30MB.
> 
> I guess I never really tried this method, as I usually enter contacts
> first, usually direct with TB's auto completion and rarely from the
> address book. Then, I enter my message body and add attachments if
> any.
> 
> I would recommend filing a bug report with the steps to reproduce.
> 
> 
> 
> 
I did a similar test, I copied this entire message and pasted it into a 
new message 3 times.  When I tried to add recipients it maxed out the 
cpu usage, like you saw, for about 30 seconds, then I tried adding a few 
more and it froze TB and had to kill it.  I am running XPSP2, Athlon64 
2800, 1 GB RAM.

I think it has to do with the message length itself.  I usually write 
fairly short messages, and if I have added an attachment (even fairly 
large ones - several hundred MB), then added the recipients I have not 
had a problem. (Maybe I've just been lucky.)

Comment 1

12 years ago
Maybe a duplicate of bug 315412. Try disabling spell checking to see if it helps. 

Comment 2

12 years ago
In email from reporter:
I think that you are correct!   I  disabled spell checking and my nightmare ended!!!!!!!

Duping...

*** This bug has been marked as a duplicate of 315412 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.